Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Przy uruchomieniu Gentoo kernel panic
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
antarcticuspl
n00b
n00b


Joined: 28 Jul 2012
Posts: 17
Location: PL

PostPosted: Sun Jul 29, 2012 2:44 pm    Post subject: [SOLVED] Przy uruchomieniu Gentoo kernel panic Reply with quote

Przy próbie uruchomienia Gentoo pojawia się Kernel Panic pokazując ten błąd:
Code:
No filesystem could mount root, tried: ext3 vfat msdos iso9660
Kernel panic - not syncing: VFS: Unable to mount root on unknown block (8,1)
Pid: 1, com: swapper Not tainted 3.3.8-gentoo #1
Call Trace:
Więc na nowo kompilowałem kernel włączając Reiserfs.
Code:
File systems  --->
   <*> Reiserfs support

Bazując się na tym wątku. http://forums.gentoo.org/viewtopic-t-907364-start-0.html
Jednak nadal to nic nie dało i występuje ten sam błąd.
Nie wiem czy mam dobrze ustawione w /etc/fstab ponieważ ten opis w handbook jest przestarzały trochę.
Code:
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#tmpfs           /tmp    tmpfs   nodev,nosuid    0       0
/dev/sda1               /               ext4      defaults              0 1
/dev/sda2               /home2          ext4      defaults              0 1

#/dev/SWAP              none            swap       sw                   0 0
#/dev/cdrom             /mnt/cdrom      auto       noauto,ro            0 0
#/dev/fd0               /mnt/floppy     auto       noauto               0 0

proc                    /proc           proc       defaults             0 0
shm                     /dev/shm        tmpfs      nodev,nosuid,noexec  0 0

fdisk -l
Code:
Urządzenie Rozruch   Początek      Koniec   Bloków   ID  System
/dev/sda1            2048    31459327    15728640   83  Linux
/dev/sda2        31459328   446949375   207745024   83  Linux
/dev/sda3   *   446949376   480155730    16603177+  83  Linux
/dev/sda4       480155731   976773167   248308718+   5  Rozszerzona
Partycja 4 nie zaczyna się na granicy bloku fizycznego.
/dev/sda5       480155794   976773167   248308687   83  Linux
Partycja 5 nie zaczyna się na granicy bloku fizycznego.
Nie korzystam ze SWAP. Natomiast boot mam na partycji głównej sda1. Podam jeszcze jak wygląda u mnie /boot/grub/menu.lst
Code:
# (0) Arch Linux
title  Arch Linux
root   (hd0,2)
kernel /boot/vmlinuz-linux root=/dev/sda3 ro i915.modeset=1
initrd /boot/initramfs-linux.img

# (1) Arch Linux
title  Arch Linux Fallback
root   (hd0,2)
kernel /boot/vmlinuz-linux root=/dev/sda3 ro
initrd /boot/initramfs-linux-fallback.img

# (2) Gentoo Linux
title  Gentoo Linux
root   (hd0,0)
kernel /boot/vmlinuz-3.3.8-gentoo.old root=/dev/sda1

cat /boot
Code:
boot # ls
config-3.3.8-gentoo      System.map-3.3.8-gentoo      vmlinuz-3.3.8-gentoo
config-3.3.8-gentoo.old  System.map-3.3.8-gentoo.old  vmlinuz-3.3.8-gentoo.old
Może podpowiecie czemu nie można uruchomić Gentoo? To moje pierwsze podejście do tego systemu.

Last edited by antarcticuspl on Sun Jul 29, 2012 6:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2836

PostPosted: Sun Jul 29, 2012 3:59 pm    Post subject: Reply with quote

napewno sda1 to ten reiserfs? Mozesz tez sprobowac dac rootfstype=reiserfs. Wystaw tez swoj config kernela bez nowych linijek i hashy. tj "grep -Ev '^(#|$)' .config"
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Garrappachc
Guru
Guru


Joined: 26 Dec 2008
Posts: 357
Location: Kraków

PostPosted: Sun Jul 29, 2012 4:12 pm    Post subject: Reply with quote

Jeżeli Twój system plików to reiserfs, to dlaczego masz ext4 w fstabie?
_________________
De profundis clamavi ad Te, Domine

emerge --info | virtual aviation
Back to top
View user's profile Send private message
antarcticuspl
n00b
n00b


Joined: 28 Jul 2012
Posts: 17
Location: PL

PostPosted: Sun Jul 29, 2012 4:28 pm    Post subject: Reply with quote

SlashBeast wrote:
napewno sda1 to ten reiserfs? Mozesz tez sprobowac dac rootfstype=reiserfs. Wystaw tez swoj config kernela bez nowych linijek i hashy. tj "grep -Ev '^(#|$)' .config"
Nie, ja mam ext4. Tylko dla przykładu wskazałem tamten temat, ponieważ był identyczny komunikat. Dopisałem do gruba ro rootfstype=ext4 i to nic nie dało. Ten sam komunikat nadal występuje. Dodałem już
Code:
Support for large (2TB+) block devices and files

Code:
   < > RAID Transport Class                                          │ │
  │ │    -*- SCSI device support                                           │ │
  │ │    < > SCSI target support                                           │ │
  │ │    [*] legacy /proc/scsi/ support                                    │ │
  │ │        *** SCSI support type (disk, tape, CD-ROM) ***                │ │
  │ │    <*> SCSI disk support                                             │ │
  │ │    < > SCSI tape support                                             │ │
  │ │    < > SCSI OnStream SC-x0 tape support                              │ │
  │ │    <*> SCSI CDROM support                                            │ │
  │ │    [ ]   Enable vendor-specific extensions (for SCSI CDROM)          │ │
  │ │    <*> SCSI generic support                                          │ │
  │ │    < > SCSI media changer support                                    │ │
  │ │    [*] Probe all LUNs on each SCSI device

i wszystko z ext4
Code:
  < > Second extended fs support                                    │ │
  │ │    < > Ext3 journalling file system support                          │ │
  │ │    <*> The Extended 4 (ext4) filesystem                              │ │
  │ │    [*]   Use ext4 for ext2/ext3 file systems (NEW)                   │ │
  │ │    [*]   Ext4 extended attributes 

Sprawdzam różne rozwiązania tego komunikatu http://forums.gentoo.org/viewtopic-t-900178-start-0.html
Tu podaje config kernela
http://wklej.org/id/800004/

Edit. Znalazłem rozwiązanie w tym ostatnim linku. Trzeba było usunąc
Code:
Generic ATA support
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum