Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Eclipse 3.7
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
awaters
n00b
n00b


Joined: 17 Jan 2011
Posts: 2

PostPosted: Thu Aug 11, 2011 8:33 am    Post subject: Eclipse 3.7 Reply with quote

What needs to be done to get this into portage?

Is Jetty still the issue? If so what does the ebuild for Jetty need to do that the latest update is not doing?
Back to top
View user's profile Send private message
sera
Developer
Developer


Joined: 29 Feb 2008
Posts: 992
Location: CET

PostPosted: Thu Aug 11, 2011 11:49 pm    Post subject: Reply with quote

Well, there is an upstream bug preventing the use of a shared installation in conjunction with p2. They don't seem to be particularly interested in fixing it. The good news is Windows7 started to have the same issue and so the priority might go up.

Then there is likely the need for a dedicated maintainer as the build is anything but trivial. So all in all it's unlikely that eclipse 3.7 will hit the tree anytime soon.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Fri Aug 12, 2011 7:35 am    Post subject: Reply with quote

Yes, building eclipse-sdk-3.7 seems to be a mess.

Just read into the according bug to find more information: https://bugs.gentoo.org/show_bug.cgi?id=325271
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1378
Location: Bardowick, Germany

PostPosted: Tue Aug 16, 2011 11:08 am    Post subject: Reply with quote

The ebuilds from Bug #328747 and Bug #325271 are rather good. I have modified two of them (eclipse-3.7.0 and jetty-bin-6.1.26) a bit and uploaded the suite to my overlay (layman -a seden) for further testing. I am not done properly testing Eclipse-3.7 yet, but at least it builds fine, runs, updating works, installation of E-P-I-C and CDT works so far. Next I'll try is to get Subversive running, we'll see...

Edit: Yes, Subversive + Connector installs fine. Eclipse-3.7 seems to be a lot faster than 3.5 to me...
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
heheman3000
n00b
n00b


Joined: 22 Oct 2006
Posts: 18

PostPosted: Wed Aug 17, 2011 4:00 pm    Post subject: Reply with quote

Thanks a lot! I have been using eclipse-3.7 from the seden overlay and it is fantastic!

It is weird that it depends on some sat4j stuff from the 'dustin' overlay though. I hope we can just get this into the tree.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1378
Location: Bardowick, Germany

PostPosted: Fri Aug 19, 2011 11:49 am    Post subject: Reply with quote

The needed sat4j-core and sat4j-pseudo ebuilds are in my overlay, too. emerge simply found the ones from the other overlay on your system first. ;-)

I am still testing, but everything seems to be working. Unfortunately it will be a long time until it hits the tree. The reason is the new dependency on "jetty". Jetty itself is built with "maven", and maven is not supported by Gentoo, see? But maybe the jetty-bin ebuild I am using in my overlay can hit it.

The bugs where you can follow stuff are:

Eclipse-3.6 / 3.7
www-servers/jetty-6.1.24
dev-java/swt-3.6.2 and
CVE-2010-4647
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Moriah
Veteran
Veteran


Joined: 27 Mar 2004
Posts: 1907
Location: Kentucky

PostPosted: Sun Nov 13, 2011 5:04 pm    Post subject: Reply with quote

What's the status of this now?

I need eclipse for compatibility with a project that is using xp and w7 versions of eclipse indego with CDT and CVS. I think it is probably a step down for me from SVN, but maybe a step up in terms of source code analysis from xemacs. Oh well, gotta do what the client wants... :?

If I am going to go to all the grief of learning a new editor, I want to be able to use it everywhere, and running xemacs under cygwin under w7 is a disaster, as w7 and cygwin do not play nicely together at all. Eclipse works under w7 and xp, but the gentoo default ebuild is for the old version without CDT, and CDT is essential for what I am doing.

Is there a work-around to get eclipse indego up on gentoo? I mean besides building directly from the tarball and just horsing it thru to make it work. I want a supported install.
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
john.newman
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2009
Posts: 80

PostPosted: Sun Nov 13, 2011 5:51 pm    Post subject: Reply with quote

+1 on all of this ... 3.5 is ancient and a lot of plugins don't work / i'm getting swt crashes. how about ecilpse 3.6? does that have all the same problems as 3.7?

i'm very close to just downloading the tarball and running it out of my home directory.. yeah that sucks, but to me using a supported 3.5 sucks worse.
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Sun Nov 13, 2011 8:31 pm    Post subject: Reply with quote

john.newman wrote:
+1 on all of this ... 3.5 is ancient and a lot of plugins don't work / i'm getting swt crashes. how about ecilpse 3.6? does that have all the same problems as 3.7?

i'm very close to just downloading the tarball and running it out of my home directory.. yeah that sucks, but to me using a supported 3.5 sucks worse.


Thank bug link listed by Genstorm has everything you need. Works perfectly on my system.
Back to top
View user's profile Send private message
john.newman
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2009
Posts: 80

PostPosted: Sun Nov 13, 2011 10:42 pm    Post subject: Reply with quote

thanks... it's a very long bug report. lol. I went to the bottom and saw the "seden" overlay has the package.

Code:
layman -a seden
emerge --sync
echo ">=dev-util/eclipse-sdk-3.7.1 ~amd64" >> /etc/portage/package.keywords
emerge -uDNpv eclipse-sdk
# more required unmaskings..
echo -e ">=www-servers/tomcat-7.0.22-r1 ~amd64\n>=dev-java/tomcat-servlet-api-7.0.22 ~amd64\n>=dev-java/swt-3.7.1 ~amd64\n>=dev-java/sat4j-core-2.3.0 ~amd64\n>=dev-java/ant-eclipse-ecj-3.7.1 ~amd64\n>=dev-java/junit-4.8.2-r1 ~amd64\n>=dev-java/sat4j-pseudo-2.3.0 ~amd64\n>=dev-java/eclipse-ecj-3.7.1 ~amd64\n>=java-virtuals/jetty-server-6\n>=www-servers/jetty-bin-6.1.26-r1" >> /etc/portage/pakcage.keywords
# jta has to be fetched .. again
wget -O /usr/portage/distfiles/jta-1_0_1B-classes.zip http://download.oracle.com/otn-pub/jcp/7089-jta-1.0.1B-mr-class-oth-JSpec/jta-1_0_1B-classes.zip
emerge -uDNpv eclipse-sdk


working. thanks all.
Back to top
View user's profile Send private message
Moriah
Veteran
Veteran


Joined: 27 Mar 2004
Posts: 1907
Location: Kentucky

PostPosted: Tue Nov 15, 2011 4:19 pm    Post subject: Reply with quote

What is layman -a seden?

And do I really need tomcat ???

And what is jta ???

Sorry, but I'm pretty ignorant when it comes to the java stuff. :oops:
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
john.newman
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2009
Posts: 80

PostPosted: Wed Nov 16, 2011 3:28 am    Post subject: Reply with quote

Quote:
What is layman -a seden?
add the "seden" overlay to portage ... see http://www.gentoo.org/proj/en/overlays/userguide.xml .. another genius feature of portage.

And do I really need tomcat ???
well no .. but unfortunately it is a dependency of eclipse for whatever reason. it will install, but you really won't know it's there

And what is jta ???
java transaction API .. a library jar packaged by sun
Back to top
View user's profile Send private message
Moriah
Veteran
Veteran


Joined: 27 Mar 2004
Posts: 1907
Location: Kentucky

PostPosted: Wed Nov 16, 2011 10:27 am    Post subject: Reply with quote

Quote:

And do I really need tomcat ???
well no .. but unfortunately it is a dependency of eclipse for whatever reason. it will install, but you really won't know it's there

It occupies zero disk space? That's pretty slick. :evil:
Can I remove it after the install, or will it actually break something?

Actually, I have been running short on disk space, but I just ordered a 480 GB SSD to replace the 256 GB SSD I have been filling up on my laptop for 2 years. The new drive is scheduled to arrive today, so this really should not be such a problem anymore.

Wait.. That's how I filled up the old drive, isn't it? :roll:

Thanks for the help. I've not used overlays before. This should be yet abother learning experience for me. :D
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Fri Feb 03, 2012 5:55 pm    Post subject: Reply with quote

Have people had success with 3.7 from seden overlay? I always get a failure loading it

Code:
!SESSION 2012-02-03 17:54:43.005 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.6.0_22
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Framework arguments: 
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2012-02-03 17:54:45.039
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        no swt-gtk-3735 in java.library.path
        no swt-gtk in java.library.path
        Can't load library: /home/jon/.swt/lib/linux/x86_64/libswt-gtk-3735.so
        Can't load library: /home/jon/.swt/lib/linux/x86_64/libswt-gtk.so

        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:285)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:194)                         
        at org.eclipse.swt.internal.C.<clinit>(C.java:21)                                         
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)                         
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)                         
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)                             
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:690)                     
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)                           
        at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:153)                                                                                             
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:95)   
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)       
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)                                                                                   
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)                                                                                             
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)           
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:616)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
Back to top
View user's profile Send private message
Abraxa
Apprentice
Apprentice


Joined: 14 Jun 2005
Posts: 172
Location: Germany

PostPosted: Tue Feb 14, 2012 9:54 am    Post subject: Reply with quote

Quote:
Have people had success with 3.7 from seden overlay? I always get a failure loading it


Looks like it's missing a dependency. A simple "emerge swt" helps with that error. Then you'll find that icu4j is needed as well.
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Mon Feb 27, 2012 12:28 pm    Post subject: Reply with quote

Having trouble installing this ebuild. I know it's not a supported ebuild but this seems like a very trivial problem... Here's the tail of my build log
Code:

provision:
     [echo] Installing into:  /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation
     [echo] Build log is available in build_20120227004451.log
     [echo] uname -m: x86_64. Build eclipse on x86_64 for x86_64.

run.director:
     [java] ACCESS DENIED  open_wr:      /dev/random
     [java] !SESSION 2012-02-27 04:02:04.155 -----------------------------------------------
     [java] eclipse.buildId=unknown
     [java] java.version=1.6.0_24
     [java] java.vendor=Sun Microsystems Inc.
     [java] BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
     [java] Framework arguments:  -application org.eclipse.equinox.p2.director -flavor tooling -installIU org.eclipse.sdk.ide -p2.os linux -p2.ws gtk -p2.arch x86_64 -roaming -profile SDKProfile -profileProperties org.eclipse.update.install.features=true -metadatarepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -artifactrepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -destination /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation -bundlepool /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/
eclipse-3.7.1-src/installation
     [java] Command-line arguments:  -data /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/buildworkspace -application org.eclipse.equinox.p2.director -consoleLog -flavor tooling -installIU org.eclipse.sdk.ide -p2.os linux -p2.ws gtk -p2.arch x86_64 -roaming -profile SDKProfile -profileProperties org.eclipse.update.install.features=true -metadatarepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -artifactrepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -destination /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/
installation -bundlepool /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation
     [java]
     [java] !ENTRY org.eclipse.osgi 4 0 2012-02-27 04:02:05.308
     [java] !MESSAGE Bundle org.apache.lucene not found.
     [java] Installing org.eclipse.sdk.ide 3.7.0.I20110909-1335.
     [java] Operation completed in 62872 ms.

BUILD SUCCESSFUL
Total time: 198 minutes 31 seconds
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-27660.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile ../pdebuild.xml generateScripts2 -DbuildArch=x86_64 -DbuildId=I20110909-1335 -debug -consolelog

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.pde.build/scripts/build.xml -propertyfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties -Dbuilder=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config -DbuildDirectory=/var/tmp/portage/dev-util/eclipse-sdk-3.7.
1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -consolelog

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.core.launcher.Main -data /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/buildworkspace -Duser.home=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/home -application org.eclipse.ant.core.antRunner -f build.xml build.update.jar

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/tempexec/build.xml -propertyfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties -Dbuilder=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config -DbuildDirectory=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.
eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -Dp2.gathering=true -Dp2.build.repo=file://var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -consolelog publish.bin.parts

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile buildConfiguration.xml -propertyfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties -Dconfigs=linux,gtk,x86_64 -Dreposource=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -Dbasedir=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config/productFiles/
rcpConfig -DbuildId=I20110909-1335 -DbaseBuildPath=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -DbaseLocation=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -Declipse.pdebuild.scripts=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.pde.build/scripts -consolelog

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile publishProduct.xml -propertyfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties -DbuildArch=x86_64 -Dreposource=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -DbuildConfig=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config -DproductFile=/var/tmp/
portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config/productFiles/sdk/sdk.product -DbuildDirectory=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -consolelog

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -configuration configuration -application org.eclipse.ant.core.antRunner -buildfile publishProduct.xml -propertyfile /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties -DbuildArch=x86_64 -Dreposource=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -DbuildConfig=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config -DproductFile=/var/tmp/
portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/buildConfigs/eclipse-build-config/productFiles/platform/platform.product -DbuildDirectory=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src -consolelog

F: open_wr
S: deny
P: /dev/random
A: /dev/random
R: /dev/random
C: /opt/icedtea-bin-6.1.11.1/jre/bin/java -Declipse.p2.data.area=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation/p2 -Xmx512M -classpath /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/bootstrap/plugins/org.eclipse.equinox.launcher.jar org.eclipse.equinox.launcher.Main -data /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/buildworkspace -application org.eclipse.equinox.p2.director -consoleLog -flavor tooling -installIU org.eclipse.sdk.ide -p2.os linux -p2.ws gtk -p2.arch x86_64 -roaming -profile SDKProfile -profileProperties org.eclipse.update.install.features=true -metadatarepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-
9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -artifactrepository file:/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/reposource -destination /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation -bundlepool /var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation -vmargs -Declipse.p2.data.area=/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build/eclipse-3.7.1-src/installation/p2 -Declipse.p2.MD5Check=false -Declipse.p2.profile=@none -Dorg.eclipse.equinox.p2.reconciler.dropins.directory= -propertyfile /
var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r4/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.properties
--------------------------------------------------------------------------------
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-bin-6  CLASSPATH="" JAVA_HOME="/opt/icedtea-bin-6.1.11.1"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER="javac"
and of course, the output of emerge --info

Any suggestions?
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1378
Location: Bardowick, Germany

PostPosted: Mon Feb 27, 2012 4:30 pm    Post subject: Reply with quote

jayseejc3191 wrote:
Having trouble installing this ebuild. I know it's not a supported ebuild but this seems like a very trivial problem... Here's the tail of my build log
Code:
(...snip...)GENTOO_VM=icedtea-bin-6(...snip)
Any suggestions?
Yes, that is your problem. IcedTea6 does not work. sun-jdk does work and IcedTea7 is said to work, but I haven't tested it, yet.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Tue Feb 28, 2012 4:45 am    Post subject: Reply with quote

Thanks Yamakuzure, worked like a charm! Now time to install that ADT plugin that's so incompatible with 3.5...
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
jayseejc3191
n00b
n00b


Joined: 09 Dec 2011
Posts: 33
Location: Canada

PostPosted: Wed Feb 29, 2012 4:37 pm    Post subject: Reply with quote

I hate to be a pain, but i don't get this bug with the precompiled version of eclipse... Unfortunately my system can barely handle that...

Installing the Color Theme Plugin(http://www.eclipsecolorthemes.org/?view=plugin) doesn't work. I have a dark themed desktop and so need a way to change the syntax highlighting to an easier color. Anyways, the installation of the plugin works fine after adding the indigo update site (http://download.eclipse.org/releases/indigo/). When I go to change the settings for the color theme plugin eclipse completely crashes. I don't have this problem with the precompiled version of eclipse, but my computer can barely handle that... The debug output's here: http://pastebin.com/aLreH6aX it wouldn't fit in a forum post. I hope this is easily resolved. And just as a side note, I have tried three different Java VMs (icedtea-7, icedtea-bin-6, and sun-jdk-1.6) and I get the exact same bug at the exact same place, some taking a little longer to hit it than others.
_________________
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1378
Location: Bardowick, Germany

PostPosted: Mon Mar 12, 2012 10:16 am    Post subject: Reply with quote

I have tried the plugin, and it works mostly, unless I count the fact that this plugin adds key bindings without checking whethere they are set already. So when I switch the color theme, this thing floods my workbench log with errors about conflicting key bindings (ctrl-alt-P and ctrl-alt-I), eventually crashing swt and asking whether to restart the workbench or not.
Unfortunately I have not yet found out what exactly happens.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1378
Location: Bardowick, Germany

PostPosted: Mon Mar 12, 2012 1:15 pm    Post subject: Reply with quote

Okay, I have updated the ebuild in my overlay to require libpng:1.2 (This seems to be missing on some systems but is unfortunately still needed) and the correct version of SWT. Eclipse-SDK-3.7.1 is _not_ fit to use anything else but SWT-3.7.1.

If I now use the mentioned color plugin, everything works fine but one issue: A null pointer exception when the change of the theme states, that "some editors have to be closed and reopened". In fact, no editor is closed and reopened, the new theme is simply applied on-the-fly.

Here is the exception:
Code:
java.lang.NullPointerException
   at org.eclipse.ui.texteditor.AbstractTextEditor.initializeViewerColors(AbstractTextEditor.java:3947)
   at org.eclipse.ui.texteditor.AbstractTextEditor.handlePreferenceStoreChanged(AbstractTextEditor.java:4598)
   at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.handlePreferenceStoreChanged(AbstractDecoratedTextEditor.java:877)
   at org.eclipse.ui.editors.text.TextEditor.handlePreferenceStoreChanged(TextEditor.java:218)
   at org.eclipse.ui.texteditor.AbstractTextEditor$PropertyChangeListener.propertyChange(AbstractTextEditor.java:710)
   at org.eclipse.ui.preferences.ScopedPreferenceStore$3.run(ScopedPreferenceStore.java:375)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.ui.preferences.ScopedPreferenceStore.firePropertyChangeEvent(ScopedPreferenceStore.java:372)
   at org.eclipse.ui.preferences.ScopedPreferenceStore$2.preferenceChange(ScopedPreferenceStore.java:194)
   at org.eclipse.core.internal.preferences.EclipsePreferences$2.run(EclipsePreferences.java:754)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.core.internal.preferences.EclipsePreferences.firePreferenceEvent(EclipsePreferences.java:757)
   at org.eclipse.core.internal.preferences.EclipsePreferences.put(EclipsePreferences.java:770)
   at com.github.eclipsecolortheme.ColorThemeMapping.putPreferences(ColorThemeMapping.java:18)
   at com.github.eclipsecolortheme.mapper.GenericMapper.map(GenericMapper.java:90)
   at com.github.eclipsecolortheme.mapper.TextEditorMapper.map(TextEditorMapper.java:15)
   at com.github.eclipsecolortheme.ColorThemeManager.applyTheme(ColorThemeManager.java:215)
   at com.github.eclipsecolortheme.preferences.ColorThemePreferencePage.performOk(ColorThemePreferencePage.java:211)
   at org.eclipse.jface.preference.PreferencePage.performApply(PreferencePage.java:432)
   at org.eclipse.jface.preference.PreferencePage$2.widgetSelected(PreferencePage.java:281)
   at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:240)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
   at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3588)
   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3209)
   at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
   at org.eclipse.jface.window.Window.open(Window.java:801)
   at org.eclipse.ui.internal.dialogs.WorkbenchPreferenceDialog.open(WorkbenchPreferenceDialog.java:215)
   at org.eclipse.ui.internal.handlers.ShowPreferencePageHandler.execute(ShowPreferencePageHandler.java:54)
   at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:293)
   at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
   at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
   at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
   at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.java:241)
   at org.eclipse.ui.internal.actions.CommandAction.runWithEvent(CommandAction.java:157)
   at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
   at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
   at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
   at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3588)
   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3209)
   at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
   at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
   at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
   at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
   at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
   at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
With this info on my machine:
Code:
eclipse.buildId=I20110909-1335
java.version=1.6.0_31
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Framework arguments: 
Command-line arguments:  -os linux -ws gtk -arch x86_64
Maybe someone who _does_ know Java (thus not me) is able to figure out whether something is missing, or if the plugin is simply badly written.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
luciano
Tux's lil' helper
Tux's lil' helper


Joined: 18 Nov 2004
Posts: 91

PostPosted: Wed May 16, 2012 3:19 pm    Post subject: Thanks for seden overlay Reply with quote

Just wanted to express my gratitude; the aforementioned ebuild worked fine for me and hope it will be integrated into the main tree soon!
Back to top
View user's profile Send private message
thens
n00b
n00b


Joined: 07 Apr 2012
Posts: 12

PostPosted: Sat Jun 30, 2012 6:09 pm    Post subject: Reply with quote

hey,

first of all thanks for these ebuilds, for now it's working almost perfectly.
The one problem i got is while trying to debug a java application.
Error msg:
Code:
ERROR: transport error 202: connect failed: Connection timed out
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:708]
FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)


Anyone got suggestions? Problem with network settings? It's more or less a "clean" (means rather new ;p) gentoo
installation. Currently using icedtea-bin-6 with eclipse 3.7.1-r7.

thanks in advance.
Back to top
View user's profile Send private message
lalebarde
Guru
Guru


Joined: 03 Sep 2006
Posts: 464
Location: France, Haute-Garonne

PostPosted: Thu Jul 05, 2012 4:54 pm    Post subject: Reply with quote

Yamakuzure wrote:
IcedTea6 does not work. sun-jdk does work and IcedTea7 is said to work, but I haven't tested it, yet.

I have installed icedtea-7.2.2.1, and java-config --set-system-vm icedtea-7, but the eclipse-sdk-3.7 ebuid still emerge dev-java/icedtea-bin-6.1.11.3

With sun-jdk-1.6.0.33, eclipse-sdk-3.7 emerge right.

Any idea please ?
Back to top
View user's profile Send private message
thens
n00b
n00b


Joined: 07 Apr 2012
Posts: 12

PostPosted: Mon Jul 09, 2012 4:23 pm    Post subject: Reply with quote

Anyone got the same problem? I'm still stuck here ;-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum