Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 24, 25, 26  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Nov 27, 2013 5:26 pm    Post subject: Reply with quote

Bluemerlin wrote:
I'm having an issue with emerging unity-meta in that nux requires <media-libs/glew-1.8 however 1.9 is in stable portage and the overlay.

Code:
emerge: there are no ebuilds to satisfy "<media-libs/glew-1.8".
(dependency required by "unity-base/nux-4.0.3_p0_p01::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-7.1.2_p0_p01-r3::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-7.1.2::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


What should I do?

Sync up, this should be fixed now.
Back to top
View user's profile Send private message
denysonique
n00b
n00b


Joined: 17 Apr 2010
Posts: 60
Location: London

PostPosted: Wed Dec 11, 2013 8:10 am    Post subject: Reply with quote

Code:

Total: 310 packages (17 upgrades, 12 downgrades, 228 new, 36 in new slots, 17 reinstalls), Size of downloads: 690,807 kB
Conflict: 5 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.38.1_p0_p01-r1::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36:2[utils] required by (x11-libs/gtk+-3.8.6_p0_p03::unity-gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.38.1:2 required by (dev-util/gdbus-codegen-2.38.1::unity-gentoo, ebuild scheduled for merge)
    (and 4 more with the same problems)

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)

sys-devel/gettext:0

  (sys-devel/gettext-0.18.2::gentoo, ebuild scheduled for merge) pulled in by
    <sys-devel/gettext-0.18.3 required by (unity-base/gnome-control-center-unity-1.3_p0_p01-r1::unity-gentoo, ebuild scheduled for merge)

  (sys-devel/gettext-0.18.3.1-r1::gentoo, installed) pulled in by
    >=sys-devel/gettext-0.18.3:0 required by (media-video/vlc-2.1.1::gentoo, installed)

dev-libs/boost:0

  (dev-libs/boost-1.53.0::gentoo, installed) pulled in by
    >=dev-libs/boost-1.35.0-r5:0/1.53= required by (kde-base/kdepimlibs-4.11.4::gentoo, installed)
    dev-libs/boost:0/1.53= required by (kde-base/kdepim-runtime-4.11.4::gentoo, installed)
    dev-libs/boost:0/1.53= required by (app-office/akonadi-server-1.10.3::gentoo, installed)

  (dev-libs/boost-1.52.0-r6::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.52 required by (unity-base/compiz-0.9.10_p0_p01-r7::unity-gentoo, ebuild scheduled for merge)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.14.3_p3_p02::unity-gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server[dmx] required by (unity-base/frame-2.5.0a_p0_p01::unity-gentoo, ebuild scheduled for merge)
    x11-base/xorg-server[dmx] required by (unity-base/unity-7.1.2_p0_p01-r4::unity-gentoo, ebuild scheduled for merge)
    x11-base/xorg-server[dmx] required by (unity-base/compiz-0.9.10_p0_p01-r7::unity-gentoo, ebuild scheduled for merge)

  (x11-base/xorg-server-1.14.99.903-r1::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-video-modesetting-0.8.1::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-input-evdev-2.8.2::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-video-vesa-2.3.3::gentoo, installed)
    x11-base/xorg-server:0/1.14.99.903= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/libpostproc-0.8.0.20121125::gentoo, installed) pulled in by
    media-libs/libpostproc required by @selected

  (media-video/ffmpeg-1.2.4::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.0:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/ffmpeg-1.0:0[X,encode,mp3,sdl,threads,truetype,vaapi,x264]) required by (virtual/ffmpeg-9::gentoo, ebuild scheduled for merge)
    media-video/ffmpeg:0 required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1::gentoo, installed)
    >=media-video/ffmpeg-1.2:0= required by (media-video/vlc-2.1.1::gentoo, installed)

  (media-video/libav-0.8.6::dennis, installed) pulled in by
    media-video/libav required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-video/kdenlive-0.9.6
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/gentoo.pmask:
# only libav-0.8.6 can record my desktop with sound
=virtual/ffmpeg-9

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


I am running ~amd64.

I think that /var/lib/layman/unity-gentoo/unity-portage.pmask should be updated to solve most of the problems, such as the Xorg stuff.
_________________
http://gplus.to/denysonique
https://twitter.com/denysonique
Back to top
View user's profile Send private message
denysonique
n00b
n00b


Joined: 17 Apr 2010
Posts: 60
Location: London

PostPosted: Wed Dec 11, 2013 9:31 am    Post subject: Reply with quote

Uninstalling the conflicting x11-drivers/* helped.


Any idea why Portage didn't resolve that automatically, by simply resinstalling them?
_________________
http://gplus.to/denysonique
https://twitter.com/denysonique
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Dec 12, 2013 2:40 am    Post subject: Reply with quote

denysonique wrote:
Uninstalling the conflicting x11-drivers/* helped.


Any idea why Portage didn't resolve that automatically, by simply resinstalling them?

Not sure. Did you try the '--backtrack' option ?
Gettext and boost version limits have been resolved by upstream and fixed in overlay.

Thanks! :)
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Thu Jan 02, 2014 1:16 pm    Post subject: Reply with quote

Hi


I have problem when updating:
Code:


 * Succeeded:
 * ------
 * Successfully synchronized overlay "java".
 * Successfully synchronized overlay "owncloud-client".
 * Successfully synchronized overlay "qt".
 * Successfully synchronized overlay "steam".
 * Successfully synchronized overlay "sunrise".
 * Successfully synchronized overlay "unity-gentoo".
 *

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] app-admin/eselect-lightdm-0.2 [0.1]
[ebuild     UD~] dev-libs/libindicator-12.10.2_p0_p02 [12.10.2a_p0_p02]
[ebuild     U ~] dev-libs/check-0.9.11 [0.9.10] ABI_X86="(64%*) -32% (-x32)"
[ebuild     UD~] dev-libs/libappindicator-12.10.1_p0_p02 [12.10.1a_p0_p02]
[ebuild     U ~] net-im/telepathy-mission-control-5.16.0_p1_p06 [5.16.0_p1_p05]
[ebuild     U ~] gnome-base/gnome-desktop-3.8.4_p0_p0101 [3.8.4_p0_p01]
[ebuild     U ~] x11-misc/lightdm-1.8.4_p0_p01 [1.8.2_p0_p01]
[ebuild     U  ] mail-client/thunderbird-24.2.0_p0_p0013101-r1 [24.2.0_p0_p0013101]
[ebuild     U ~] gnome-base/nautilus-3.8.2_p0_p0201 [3.8.2_p0_p02]
[ebuild     U ~] app-emulation/wine-1.7.9 [1.7.4] USE="-netapi%"
[ebuild     U  ] gnome-base/gnome-shell-3.8.4-r2 [3.8.4-r1]

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

!!! A file listed in the Manifest could not be found: /var/lib/layman/unity-gentoo/x11-misc/lightdm/lightdm-1.8.2_p0_p01.ebuild
!!! A file is not listed in the Manifest: '/var/lib/layman/unity-gentoo/mail-client/thunderbird/files/icon/thunderbird.desktop_sav'

What can I do? Probably a problem on overlys's side or is it "my fault"? :) Thanks! :)
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Thu Jan 02, 2014 2:57 pm    Post subject: Reply with quote

The issue is already fixed, please make an update of the overlay :)
Back to top
View user's profile Send private message
noclear2000
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jun 2006
Posts: 139
Location: Germany

PostPosted: Thu Jan 02, 2014 4:26 pm    Post subject: Reply with quote

hi renegart,

thanks a lo!

yes for lightdm, no for thunderbird:
Code:

>>> Verifying ebuild manifests
!!! A file is not listed in the Manifest: '/var/lib/layman/unity-gentoo/mail-client/thunderbird/files/icon/thunderbird.desktop_sav'
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Thu Jan 02, 2014 4:32 pm    Post subject: Reply with quote

noclear2000 wrote:
hi renegart,

thanks a lo!

yes for lightdm, no for thunderbird:
Code:

>>> Verifying ebuild manifests
!!! A file is not listed in the Manifest: '/var/lib/layman/unity-gentoo/mail-client/thunderbird/files/icon/thunderbird.desktop_sav'


shiznix has pushed the commit (632e3eea5b) yesterday. please remove the file manually on your side.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 24, 25, 26
Page 26 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum