Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Fri Mar 01, 2013 5:16 pm    Post subject: Reply with quote

Hello,

I am having this issue when I try to emerge unity-meta. I am not really sure what it means. I have tried play with the use flags but I have gotten no where.



Code:

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.29.0-r1::gentoo (Change USE: +curl_ssl_nss, this change violates use flag constraints defined by net-misc/curl-7.29.0-r1: 'threads? ( !adns ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )')
(dependency required by "net-libs/liboauth-0.9.7[curl,nss]" [ebuild])
(dependency required by "gnome-extra/evolution-data-server-3.6.3[gnome-online-accounts]" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.6.3.1" [ebuild])
(dependency required by "unity-base/unity-6.12.0_p0_p0002::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-scope-video-remote-0.3.10_p0_p01::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-6.12.0::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


my make file is
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X acl additions alsa apache2 consolekit curl dbus dconf dmx dvd
     extensions flac fuse gd geolocation gflags gnome gtk gtk3 icu id3tag
     introspection kdepim libkms mad minizip mysql mysqli nautilus
     networkmanager nls nss off openssl pam passiv pdo php plugins policykit
     postgresql pulseaudio python qt4 script sqlite ssl symlink telepathy udev
     udisks unicode vala vorbis wavpack xorg zip -cdr -doc -kde -test"

MAKEOPTS="-j5"

source "/var/lib/layman/make.conf"

GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"

SYNC="rsync://rsync4.ca.gentoo.org/gentoo-portage"

INPUT_DEVICES="evdev synaptics"

VIDEO_CARDS="nvidia nouveau"
ACCEPT_LICENSE="*"

ACCEPT_KEYWORDS="~amd64"
#ACCEPT_KEYWORDS="~amd64 **"


any help is greatly appreciated.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Mar 01, 2013 5:32 pm    Post subject: Reply with quote

arty71 wrote:
Hello,

I am having this issue when I try to emerge unity-meta. I am not really sure what it means. I have tried play with the use flags but I have gotten no where.



Code:

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.29.0-r1::gentoo (Change USE: +curl_ssl_nss, this change violates use flag constraints defined by net-misc/curl-7.29.0-r1: 'threads? ( !adns ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )')
(dependency required by "net-libs/liboauth-0.9.7[curl,nss]" [ebuild])
(dependency required by "gnome-extra/evolution-data-server-3.6.3[gnome-online-accounts]" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.6.3.1" [ebuild])
(dependency required by "unity-base/unity-6.12.0_p0_p0002::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-scope-video-remote-0.3.10_p0_p01::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-6.12.0::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


my make file is
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X acl additions alsa apache2 consolekit curl dbus dconf dmx dvd
     extensions flac fuse gd geolocation gflags gnome gtk gtk3 icu id3tag
     introspection kdepim libkms mad minizip mysql mysqli nautilus
     networkmanager nls nss off openssl pam passiv pdo php plugins policykit
     postgresql pulseaudio python qt4 script sqlite ssl symlink telepathy udev
     udisks unicode vala vorbis wavpack xorg zip -cdr -doc -kde -test"

MAKEOPTS="-j5"

source "/var/lib/layman/make.conf"

GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"

SYNC="rsync://rsync4.ca.gentoo.org/gentoo-portage"

INPUT_DEVICES="evdev synaptics"

VIDEO_CARDS="nvidia nouveau"
ACCEPT_LICENSE="*"

ACCEPT_KEYWORDS="~amd64"
#ACCEPT_KEYWORDS="~amd64 **"


any help is greatly appreciated.

Check your use flags for 'curl'. I guess you have set 'nss' for 'CURL_SSL'. That's the default I guess.
just add following line to your make.conf
Code:
CURL_SSL="openssl"

it can be that you have to remerge curl to get it work.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Mar 01, 2013 6:12 pm    Post subject: Reply with quote

I've an error (re)compile the unity package.

http://bpaste.net/show/80755/

Any ideas?
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Fri Mar 01, 2013 7:09 pm    Post subject: Reply with quote

renegart wrote:
arty71 wrote:
Hello,

I am having this issue when I try to emerge unity-meta. I am not really sure what it means. I have tried play with the use flags but I have gotten no where.



Code:

emerge: there are no ebuilds built with USE flags to satisfy "net-misc/curl[ssl,curl_ssl_nss]".
!!! One of the following packages is required to complete your request:
- net-misc/curl-7.29.0-r1::gentoo (Change USE: +curl_ssl_nss, this change violates use flag constraints defined by net-misc/curl-7.29.0-r1: 'threads? ( !adns ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )')
(dependency required by "net-libs/liboauth-0.9.7[curl,nss]" [ebuild])
(dependency required by "gnome-extra/evolution-data-server-3.6.3[gnome-online-accounts]" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.6.3.1" [ebuild])
(dependency required by "unity-base/unity-6.12.0_p0_p0002::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-scope-video-remote-0.3.10_p0_p01::unity-gentoo" [ebuild])
(dependency required by "unity-base/unity-meta-6.12.0::unity-gentoo" [ebuild])
(dependency required by "unity-meta" [argument])


my make file is
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X acl additions alsa apache2 consolekit curl dbus dconf dmx dvd
     extensions flac fuse gd geolocation gflags gnome gtk gtk3 icu id3tag
     introspection kdepim libkms mad minizip mysql mysqli nautilus
     networkmanager nls nss off openssl pam passiv pdo php plugins policykit
     postgresql pulseaudio python qt4 script sqlite ssl symlink telepathy udev
     udisks unicode vala vorbis wavpack xorg zip -cdr -doc -kde -test"

MAKEOPTS="-j5"

source "/var/lib/layman/make.conf"

GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"

SYNC="rsync://rsync4.ca.gentoo.org/gentoo-portage"

INPUT_DEVICES="evdev synaptics"

VIDEO_CARDS="nvidia nouveau"
ACCEPT_LICENSE="*"

ACCEPT_KEYWORDS="~amd64"
#ACCEPT_KEYWORDS="~amd64 **"


any help is greatly appreciated.

Check your use flags for 'curl'. I guess you have set 'nss' for 'CURL_SSL'. That's the default I guess.
just add following line to your make.conf
Code:
CURL_SSL="openssl"

it can be that you have to remerge curl to get it work.



Thank you, I was able to fix my issue
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Mar 01, 2013 10:06 pm    Post subject: Reply with quote

renegart wrote:
I've an error (re)compile the unity package.

http://bpaste.net/show/80755/

Any ideas?
That was my fault, was tinkering with libXfixes and fixesproto ebuilds to make them use portage's new MULTILIB_USEDEP and messed the patchset path so they weren't getting applied.
Sync up, should be fixed now thanks ;)
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Sat Mar 02, 2013 3:18 am    Post subject: Reply with quote

Hello again,

I have had another issue during my install.

I am getting the output:

Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/gnutls:0

  (net-libs/gnutls-3.1.9-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnutls-2.12.23::gentoo, ebuild scheduled for merge) pulled in by
    <net-libs/gnutls-3 required by (net-nds/openldap-2.4.33-r1::gentoo, ebuild scheduled for merge)

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20130224 required by (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-baselibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20121202 required by (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed)
    (and 5 more with the same problem)

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20121202 required by (app-emulation/emul-linux-x86-sdl-20121202::gentoo, installed)
    (and 2 more with the same problem)

  (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-emulation/emul-linux-x86-opengl:0

  (app-emulation/emul-linux-x86-opengl-20130224::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-emulation/emul-linux-x86-opengl-20121202-r1::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20121202 required by (app-emulation/emul-linux-x86-gtklibs-20121202::gentoo, installed)



I am not sure what the best way to deal with this is?

should i be masking packages?
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sat Mar 02, 2013 8:14 am    Post subject: Reply with quote

arty71 wrote:
Hello again,

I have had another issue during my install.

I am getting the output:

Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/gnutls:0

  (net-libs/gnutls-3.1.9-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnutls-2.12.23::gentoo, ebuild scheduled for merge) pulled in by
    <net-libs/gnutls-3 required by (net-nds/openldap-2.4.33-r1::gentoo, ebuild scheduled for merge)

app-emulation/emul-linux-x86-baselibs:0

  (app-emulation/emul-linux-x86-baselibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20130224 required by (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-baselibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20121202 required by (app-emulation/emul-linux-x86-medialibs-20121202::gentoo, installed)
    (and 5 more with the same problem)

app-emulation/emul-linux-x86-xlibs:0

  (app-emulation/emul-linux-x86-xlibs-20121202::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-xlibs-20121202 required by (app-emulation/emul-linux-x86-sdl-20121202::gentoo, installed)
    (and 2 more with the same problem)

  (app-emulation/emul-linux-x86-xlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-emulation/emul-linux-x86-opengl:0

  (app-emulation/emul-linux-x86-opengl-20130224::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-emulation/emul-linux-x86-opengl-20121202-r1::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20121202 required by (app-emulation/emul-linux-x86-gtklibs-20121202::gentoo, installed)



I am not sure what the best way to deal with this is?

should i be masking packages?

You're merge needs new packages as allready installed. check your package.keywords file or package.keywords/package.accept_keywords directory and add the missing packages marked as 'ebuild scheduled for merge'
It can happen that you have do this more times until all dependencies are fulfilled.
Sometimes it also helps if updates a package manually if portage complains about multiple packages which are already unmaksed. e.g. 'emerge -u1 gnutls'
Back to top
View user's profile Send private message
and3k
n00b
n00b


Joined: 12 May 2006
Posts: 32

PostPosted: Sat Mar 02, 2013 1:01 pm    Post subject: Reply with quote

My unity stopped working since my @world update yesterday. X works, but I have no window manager, no panel and no indicators, etc. Metacity works...

I’m not sure how to debug it, which command starts the unity window manger, and the panel?

Best,
and3k
Back to top
View user's profile Send private message
and3k
n00b
n00b


Joined: 12 May 2006
Posts: 32

PostPosted: Sat Mar 02, 2013 1:24 pm    Post subject: Reply with quote

and3k wrote:
My unity stopped working since my @world update yesterday. X works, but I have no window manager, no panel and no indicators, etc. Metacity works...

I’m not sure how to debug it, which command starts the unity window manger, and the panel?

Best,
and3k

Nevermind, another @world update fixed it… Thx
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Mar 02, 2013 1:41 pm    Post subject: Reply with quote

So I've just been setting up a clean Gentoo install inside a chroot and I sympathise a whole lot more with those who are running a stable system wanting to install Unity.

The amount of packages to keyword unmask is enormous and so even though I've said before that I can't accurately maintain a package.keywords list, I should at least provide a base list that users can tweak to their own liking.

So here are the package.keywords and package.use entries needed to get Unity to install:

/etc/portage/package.keywords/unity
Code:
*/*::unity-gentoo
app-accessibility/at-spi2-atk
app-accessibility/at-spi2-core
app-accessibility/caribou
app-admin/openrc-settingsd
app-admin/packagekit
app-admin/packagekit-base
app-admin/packagekit-gtk
app-admin/packagekit-qt4
app-cdr/brasero
app-crypt/gcr
app-crypt/libsecret
app-i18n/ibus
app-text/evince
dev-libs/atk
dev-libs/folks
dev-libs/gjs
dev-libs/glib
dev-libs/gobject-introspection
dev-libs/gobject-introspection-common
dev-libs/libgdata
dev-libs/libgee
dev-libs/libgweather
dev-libs/libindicate
dev-libs/libindicate-qt
dev-libs/libpeas
dev-libs/libpwquality
dev-libs/libzeitgeist
dev-python/dbus-python
dev-python/isodate
dev-python/oauthlib
dev-python/pyatspi
dev-python/pycairo
dev-python/pycrypto
dev-python/pygobject
dev-python/python-distutils-extra
dev-python/rdflib
dev-python/twisted
dev-python/twisted-names
dev-python/twisted-web
dev-util/fix-la-relink-command
dev-util/gdbus-codegen
gnome-base/dconf
gnome-base/gdm
gnome-base/gnome-common
gnome-base/gnome-desktop
gnome-base/gnome-keyring
gnome-base/gnome-menus
gnome-base/gnome-panel
gnome-base/gnome-shell
gnome-base/gvfs
gnome-base/libgnomekbd
gnome-base/libgnome-keyring
gnome-extra/evolution-data-server
gnome-extra/gnome-color-manager
gnome-extra/nautilus-sendto
gnome-extra/sushi
gnome-extra/zeitgeist
gnome-extra/zeitgeist-datahub
media-gfx/shotwell
media-libs/clutter
media-libs/clutter-gst
media-libs/clutter-gtk
media-libs/cogl
media-libs/libvpx
media-plugins/gst-plugins-vpx
media-video/cheese
net-im/telepathy-mission-control
net-libs/farstream
net-libs/gnome-online-accounts
net-libs/liboauth
net-libs/libsoup
net-libs/libsoup-gnome
net-libs/telepathy-farstream
net-libs/telepathy-glib
net-misc/networkmanager
net-voip/telepathy-rakia
net-voip/telepathy-salut
net-wireless/gnome-bluetooth
sys-apps/shadow
sys-auth/pambase
sys-libs/db
x11-misc/appmenu-qt
x11-themes/gnome-backgrounds
x11-themes/gnome-icon-theme
x11-themes/gnome-themes-standard
x11-wm/mutter

/etc/portage/package.use/unity
Code:
app-admin/packagekit-base networkmanager
app-backup/deja-dup nautilus
app-cdr/brasero nautilus
app-crypt/libsecret vala
app-i18n/ibus dconf
dev-lang/python sqlite
dev-libs/protobuf python
dev-libs/xapian-bindings python
dev-libs/libxml2 icu
gnome-base/gdm -gnome-shell
gnome-base/gvfs fuse
gnome-base/nautilus sendto
media-libs/mesa xorg
media-libs/gst-plugins-base theora
media-plugins/alsa-plugins pulseaudio
media-sound/rhythmbox zeitgeist
sys-auth/pambase consolekit
sys-libs/zlib minizip
unity-base/unity-meta chat webapps
x11-base/xorg-server dmx
x11-libs/libdrm libkms
x11-libs/qt-webkit icu
x11-misc/webaccounts-browser-extension firefox chromium
x11-themes/light-themes gtk3

/etc/portage/package.unmask/unity
Code:
net-misc/networkmanager
sys-libs/db

Hope that helps some, I'll place a copy of these files in the top level directory of the overlay and as an edit in the 1st post of the topic, thanks 8)
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Mar 03, 2013 11:39 am    Post subject: Reply with quote

the gentoo guys made a huge bunch of profile updates.
one change is the move of 'x11-libs/qt-core' to 'dev-qt/qtcore'

following packages needs to be updated:
unity-base/signon-keyring-extension-0.3_p0_p01
net-libs/account-plugins-0.8_p0_p02
net-im/empathy-3.6.3_p0_p04

EDIT:
'unity-extra/indicator-power' needs 'gnome-settings-daemon >= 3.1.4' as dependency
'unity-base/indicator-sound' needs 'dev-libs/libgee:0' (0.6.4-0.6.7) as dependency

EDIT2:
the build of gnome-control-panel stops with following error http://bpaste.net/show/81195/
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Mar 04, 2013 4:31 am    Post subject: Reply with quote

renegart wrote:
the gentoo guys made a huge bunch of profile updates.
one change is the move of 'x11-libs/qt-core' to 'dev-qt/qtcore'

following packages needs to be updated:
unity-base/signon-keyring-extension-0.3_p0_p01
net-libs/account-plugins-0.8_p0_p02
net-im/empathy-3.6.3_p0_p04

EDIT:
'unity-extra/indicator-power' needs 'gnome-settings-daemon >= 3.1.4' as dependency
'unity-base/indicator-sound' needs 'dev-libs/libgee:0' (0.6.4-0.6.7) as dependency

EDIT2:
the build of gnome-control-panel stops with following error http://bpaste.net/show/81195/

Have updated all to dev-qt/qt*:4 and added those needed dependencies for indicator-power and indicator-sound, thanks for reporting.

Have not been able to reproduce the gnome-control-center problem yet...
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Mar 04, 2013 7:29 pm    Post subject: Reply with quote

shiznix wrote:

Have not been able to reproduce the gnome-control-center problem yet...


after restarting the VM the build succeed. Very strange.
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 447
Location: Sao Paulo, Brazil

PostPosted: Thu Mar 07, 2013 8:08 pm    Post subject: Reply with quote

Hi there folks,
Is there a possibility we have the unity-meta package in the Gentoo official tree? I haven't try it yet, but this post is getting old, so I presume that Unity has reach some stability. Any comments are appreciated.
Best
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Mar 07, 2013 10:01 pm    Post subject: Reply with quote

ferreirafm wrote:
Hi there folks,
Is there a possibility we have the unity-meta package in the Gentoo official tree? I haven't try it yet, but this post is getting old, so I presume that Unity has reach some stability. Any comments are appreciated.
Best

It's inclusion can be tracked here -> https://bugs.gentoo.org/show_bug.cgi?id=428792

The set of ebuilds are now fairly stable, but there is some major upstream upheaval ahead which may change that for a time.
As part of their 'convergence' strategy to deliver Unity to the desktop, TV and phone, Ubuntu have announced they will do away with X11 and create their own display server called MIR, and re-develop Unity to use QT/QML.
This is all set to take off in a couple of months time, see here -> https://wiki.ubuntu.com/UnityNextSpec

It reads like their going to resurrect a lot of the old Unity2d code (which in itself was a very slick performer) and access OpenGL functionality using QT5/QML2, instead of the current use of nux + compiz.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Mar 10, 2013 8:22 am    Post subject: Reply with quote

Hello,
there is something wrong with the 'x11-misc/appmenu-thunderbird-17.0.3_p0_p00121001' package.
I've installed 'mail-client/thunderbird' which shall be updated to 17.0.4, now the appmenu-thunderbird will install 'mail-client/thunderbird-bin-17.0.3' in addition.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sun Mar 10, 2013 4:08 pm    Post subject: Reply with quote

Hi, shiznix! THANK YOU FOR YOUR OVERLAY!
Good work! I'm very happy to install this, but i have a little problem.
How to fix white lines on text?
http://dl.dropbox.com/u/34973756/2013-03-10%2022.04.45.jpg
(theme is ambiance)
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Sun Mar 10, 2013 5:09 pm    Post subject: Reply with quote

shiznix, can you add to overlay Novacut? https://wiki.ubuntu.com/Novacut
it will be nice...
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Mar 11, 2013 5:29 am    Post subject: Reply with quote

@renegart
I've adjusted the appmenu-thunderbird ebuild to be more like the appmenu-firefox ebuild, check the commit history for more detail.
This should fix the version problems you are experiencing.

@brothermechanic
No problem, glad it mostly works for you ;)

The white lines behind text should be fixed now.
Was able to reproduce this by downgrading x11-themes/light-themes to 0.1.8.32, so you'll need the keyword masked version (tested with 0.1.93).
A sync up and emerge should pick up the higher light-themes version as a new dep. for gnome-base/gsettings-desktop-schemas.

Thanks for reporting guys!

Had a quick look at novacut and it looks a nice video editor with some extras.
Unfortunately it's probably more than I can handle at the moment and I don't want to spread myself so thin that I can't do justice to what's already in the overlay.
However if you were to come up with the necessary ebuilds (at least 6 afaict) I'd be happy to pull them into the overlay.

Trying to pretty much stick to what Ubuntu comes with by default, plus a few small self-contained extras packages that can be seen in unity-extra/ (mostly indicators and lenses).
I also hope we can get some more developers on board interested in the project and perhaps then it can be fleshed out a bit more.
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Mon Mar 11, 2013 8:52 am    Post subject: Reply with quote

Hi!
Thank's for answer, now all work fine!!!
But)))) i cant to start libreoffice-bin
Code:

$ libreoffice
/usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libdb-4.8.so: cannot open shared object file: No such file or directory

Code:

[ebuild   R   #] sys-libs/db-5.3.21:5.3
[ebuild   R    ] app-office/libreoffice-bin-3.6.4.3

Code:

unity-base/unity-lens-applications-6.10.0_p0_p01 (sys-libs/db:5.1)


If it possible to solve it deppends will be nice)))

>novacut
i will try to create ebuilds

Thank you! Very very good DE
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Mar 11, 2013 8:52 pm    Post subject: Reply with quote

brothermechanic wrote:
Hi!
Thank's for answer, now all work fine!!!
But)))) i cant to start libreoffice-bin
Code:

$ libreoffice
/usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libdb-4.8.so: cannot open shared object file: No such file or directory

Code:

[ebuild   R   #] sys-libs/db-5.3.21:5.3
[ebuild   R    ] app-office/libreoffice-bin-3.6.4.3

Code:

unity-base/unity-lens-applications-6.10.0_p0_p01 (sys-libs/db:5.1)


If it possible to solve it deppends will be nice)))

>novacut
i will try to create ebuilds

Thank you! Very very good DE

That's an problem of the libreoffice ebuild. The dependency is following '>=sys-libs/db-4.8'. That's why the system puts 'sys-libs/db-5.3.21'

File a bug against the libreoffice ebuild pleace. And in meanwhile you can merge 'sys-libs/db:4.8' by hand. It's an own slot, so it can be installed side-by-side.
Back to top
View user's profile Send private message
yaront
n00b
n00b


Joined: 18 Jan 2012
Posts: 16

PostPosted: Tue Mar 12, 2013 12:43 pm    Post subject: Reply with quote

I have a problem with the eclass: the check for */*::unity-gentoo always fails when I try to emerge packages using it.
When I run grep -r '\*/\*::unity-gentoo' /etc/portage/package.keywords* I don't get any output, but if I modify it to grep -r '\*/\*::unity-gentoo' /etc/portage/package.keywords/* I get /etc/portage/package.keywords/unity-portage.pkeywords:*/*::unity-gentoo as expected.
Could it be a shell problem? I suppose it's new, because no one else complains about it... :D
Back to top
View user's profile Send private message
yaront
n00b
n00b


Joined: 18 Jan 2012
Posts: 16

PostPosted: Tue Mar 12, 2013 3:04 pm    Post subject: Reply with quote

Never mind, I just read the grep man page and figured it's the intended behaviour for symlinks, which is what my unity-portage.pkeywords is. :D
Back to top
View user's profile Send private message
javispedro
n00b
n00b


Joined: 11 Mar 2013
Posts: 13

PostPosted: Tue Mar 12, 2013 9:25 pm    Post subject: Reply with quote

Thanks a lot for this overlay!

Turns out that, after a brief evaluation of Gnome 3, Unity, and other Gtk+ desktop environments, I happened to like Unity most, despite the fact I despise Ubuntu and Canonical.
So, thanks a lot! If you accept donations, I'm willing to send some $5 in your direction because I know how much of a time sink maintaining this is.

I was able to migrate a Gentoo stable (Gnome2) system to Unity in around an afternoon. Lots of packages have to be keyworded, but I see there's now a list in the overlay itself, so it should be easier to migrate now. Additionally, migrating from Gnome2 to 3 still requires one to manually unmerge some packages. But in general, the migration was smooth enough.

I have some feature requests. I will tryi to make them small enough so as not to cause much distraction :)

1. As the poster above noticed,
Code:
grep -r '\*/\*::unity-gentoo' /etc/portage/package.keywords*
will not follow symlinks. Per the manual of grep, -R (yes, uppercase), does. Should be a simple fix :)

Personally though, I would remove this check entirely. When using BINHOSTs, the fact that the check must be run for virtually every package in the overlay breaks parallel fetching. All of the packages have to be downloaded before starting to install anything because of the check.
And the check is not that useful. Maybe it could be done in the unity-meta package instead of the eclass.

2. I experienced a file conflict. Both unity-language-pack and gnome-extra/activity-log-manager want to install the file

/usr/share/locale/es/LC_MESSAGES/activity-log-manager.mo

(my LINGUAS are 'es_ES es en')

I can guess this is because upstream Ubuntu locale packaging is a mess. I am not sure which package should actually own this file.

3. Nautilus 3.6 is currently a bit of a mess under Unity. The HUD is mostly useless because of the removal of the menu bar.

Could you, for the time being, also keep Quantal's version of nautilus (that is, 3.4.2, even if the package says 3.5.90) in the overlay?. The same 3.6.x ebuild file can be used, so this should not cause much headache.

And those were all the problems I had to fix, from reading the output of 'git diff' :)
Again, nice work there!
Back to top
View user's profile Send private message
brothermechanic
n00b
n00b


Joined: 10 Dec 2012
Posts: 31

PostPosted: Wed Mar 13, 2013 7:33 am    Post subject: Reply with quote

!bugreport!
For emerge unity-extra/indicator-weather i take this
http://bpaste.net/show/83396/
Please fix this.
Thank's for overlay!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 24, 25, 26  Next
Page 17 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum