Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge xorg-server-1.13.0-r1 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 82

PostPosted: Fri Nov 23, 2012 4:40 pm    Post subject: emerge xorg-server-1.13.0-r1 failed Reply with quote

Hi, I'm trying to update to 1.13.0-r1 from 1.12.4 but it fails with the following error:
Code:

/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c: In function '__glXVertexAttribs3fvNVReqSize':
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c:764:5: warning: cast discards qualifiers from pointer target type
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c: In function '__glXVertexAttribs3svNVReqSize':
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c:776:5: warning: cast discards qualifiers from pointer target type
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c: In function '__glXVertexAttribs4dvNVReqSize':
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c:788:5: warning: cast discards qualifiers from pointer target type
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c: In function '__glXProgramNamedParameter4fvNVReqSize':
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/indirect_reqsize.c:800:5: warning: cast discards qualifiers from pointer target type
  CC     indirect_table.lo
  CC     glapi.lo
  CC     glapi_gentable.lo
  CC     glthread.lo
  CC     clientinfo.lo
  CC     createcontext.lo
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/createcontext.c: In function '__glXDisp_CreateContextAttribsARB':
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/createcontext.c:190:29: error: 'GLX_LOSE_CONTEXT_ON_RESET_ARB' undeclared (first use in this function)
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/createcontext.c:190:29: note: each undeclared identifier is reported only once for each function it appears in
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/createcontext.c:248:10: error: 'GLX_CONTEXT_ES2_PROFILE_BIT_EXT' undeclared (first use in this function)
make[1]: *** [createcontext.lo] Error 1
make[1]: *** Se espera a que terminen otras tareas....
make[1]: se sale del directorio `/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0_build/glx'
make: *** [all-recursive] Error 1
 * ERROR: x11-base/xorg-server-1.13.0-r1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-base/xorg-server-1.13.0-r1'`,
 * the complete build log and the output of `emerge -pqv '=x11-base/xorg-server-1.13.0-r1'`.
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0_build'
 * S: '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0'

>>> Failed to emerge x11-base/xorg-server-1.13.0-r1, Log file:

>>>  '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/temp/build.log'

 * Messages for package x11-base/xorg-server-1.13.0-r1:

 * ERROR: x11-base/xorg-server-1.13.0-r1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-base/xorg-server-1.13.0-r1'`,
 * the complete build log and the output of `emerge -pqv '=x11-base/xorg-server-1.13.0-r1'`.
 * The complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0_build'
 * S: '/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0'

This is my emerge --info:
Code:

Portage 2.1.11.31 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.4, glibc-2.15-r3, 3.4.11-tuxonice x86_64)
=================================================================
System uname: Linux-3.4.11-tuxonice-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.1
Timestamp of tree: Thu, 22 Nov 2012 06:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org/"
LANG="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran fuse g3dvl gd gdbm gif gnome gnome-keyring gnome-online-accounts gphoto2 gpm gstreamer gtk iconv ipv6 java jpeg lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nsplugin ogg opengl openmp optimization pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline samba sdl session socialweb spell sse sse2 ssl startup-notification strong-optimization svg tcpd threads tiff truetype udev udisks unicode upower usb vdpau vorbis vpx wxwidgets x264 xcb xinerama xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es" PHP_TARGETS="php5-3" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


And I don't know what else to do. Could anybody provide some help?

Regards.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Fri Nov 23, 2012 5:14 pm    Post subject: Re: emerge xorg-server-1.13.0-r1 failed Reply with quote

erzapito wrote:
/var/tmp/portage/x11-base/xorg-server-1.13.0-r1/work/xorg-server-1.13.0/glx/createcontext.c:190:29: error: 'GLX_LOSE_CONTEXT_ON_RESET_ARB' undeclared (first use in this function)

Comes from mesa, i.e. (different distro):
Code:
/usr/include/GL/glxext.h:#define GLX_LOSE_CONTEXT_ON_RESET_ARB      0x8252


Also from glproto:
Code:
/usr/include/GL/glxtokens.h:#define GLX_LOSE_CONTEXT_ON_RESET_ARB      0x8252
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 82

PostPosted: Fri Nov 23, 2012 11:45 pm    Post subject: Reply with quote

I've got both packages installed. I've tried rebuilding them and still nothing :S.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Fri Nov 23, 2012 11:52 pm    Post subject: Reply with quote

Look inside the 2 files I showed - check that they have the #define lines as I showed.
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 82

PostPosted: Sat Nov 24, 2012 12:26 am    Post subject: Reply with quote

Yes, its in both of them in the following route:
/usr/lib64/opengl/xorg-x11/include/GL/glxext.h
/usr/lib64/opengl/xorg-x11/include/GL/glxtokens.h
Back to top
View user's profile Send private message
erzapito
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2007
Posts: 82

PostPosted: Mon Nov 26, 2012 8:05 pm    Post subject: Reply with quote

I've tried to manually run "./configure" and "make" from the emerge work directory and it runs.

Does anybody knows how to get the "configure" command run by emerge?
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Thu Jan 31, 2013 7:16 pm    Post subject: Reply with quote

I got similar error

Code:
  CC     clientinfo.lo
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:33:40: error: unknown type name 'xGLXSetClientInfoARBReq'
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDisp_SetClientInfoARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:77:5: warning: implicit declaration of function 'set_client_info' [-Wimplicit-function-declaration]
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:77:5: warning: nested extern declaration of 'set_client_info' [-Wnested-externs]
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:77:33: error: 'xGLXSetClientInfoARBReq' undeclared (first use in this function)
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:77:33: note: each undeclared identifier is reported only once for each function it appears in
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:77:58: error: expected expression before ')' token
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDispSwap_SetClientInfoARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:83:5: error: unknown type name 'xGLXSetClientInfoARBReq'
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:83:37: error: 'xGLXSetClientInfoARBReq' undeclared (first use in this function)
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:83:62: error: expected expression before ')' token
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:85:8: error: request for member 'length' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:85:19: error: request for member 'length' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:86:8: error: request for member 'numVersions' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:86:24: error: request for member 'numVersions' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:87:8: error: request for member 'numGLExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:87:32: error: request for member 'numGLExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:88:8: error: request for member 'numGLXExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:88:33: error: request for member 'numGLXExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDisp_SetClientInfo2ARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:96:33: error: 'xGLXSetClientInfoARBReq' undeclared (first use in this function)
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:96:58: error: expected expression before ')' token
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDispSwap_SetClientInfo2ARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:102:5: error: unknown type name 'xGLXSetClientInfoARBReq'
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:102:37: error: 'xGLXSetClientInfoARBReq' undeclared (first use in this function)
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:102:62: error: expected expression before ')' token
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:104:8: error: request for member 'length' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:104:19: error: request for member 'length' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:105:8: error: request for member 'numVersions' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:105:24: error: request for member 'numVersions' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:106:8: error: request for member 'numGLExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:106:32: error: request for member 'numGLExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:107:8: error: request for member 'numGLXExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:107:33: error: request for member 'numGLXExtensionBytes' in something not a structure or union
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDisp_SetClientInfo2ARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:97:1: error: control reaches end of non-void function [-Werror=return-type]
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c: In function '__glXDisp_SetClientInfoARB':
/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1/glx/clientinfo.c:78:1: error: control reaches end of non-void function [-Werror=return-type]
cc1: some warnings being treated as errors
make[1]: *** [clientinfo.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.13.1/work/xorg-server-1.13.1_build/glx'
make: *** [all-recursive] Error 1


did you managed to solve the issue? I can compile with USE="minimal".
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Thu Jan 31, 2013 7:40 pm    Post subject: Reply with quote

@Drkg4b:
:roll: Do explain in which way exactly it's a similar error.
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Thu Jan 31, 2013 9:08 pm    Post subject: Reply with quote

VoidMage wrote:
@Drkg4b:
:roll: Do explain in which way exactly it's a similar error.


It seems to me so. Do explain how your comment improve this discussion.
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Thu Jan 31, 2013 9:53 pm    Post subject: Reply with quote

Drkg4b wrote:
VoidMage wrote:
@Drkg4b:
:roll: Do explain in which way exactly it's a similar error.


It seems to me so. Do explain how your comment improve this discussion.


There's no discussion here - just a person, that for some odd reason revived an old thread with a post, that doesn't seems to have anything to do with the original topic.
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Thu Jan 31, 2013 10:08 pm    Post subject: Reply with quote

The fact that both errors come from the glx directory might relate them to the same problem that's why I think if he got a solution that one can give me some hint in finding mine.

Now tell me why this is a so odd reason.
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Thu Jan 31, 2013 10:48 pm    Post subject: Reply with quote

Cause if that's related, then it's only by a long shot.

:roll: Honestly,...

As for the error, there's nothing very obvious in it, so let's assume you didn't update your system correctly.
What's the output of 'emerge -upvD --with-bdeps y xorg-server' ?
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Thu Jan 31, 2013 11:32 pm    Post subject: Reply with quote

I updated my system with emerge --sync && emerge --keep-going --jobs=3 --changed-use -uDav --autounmask-write @world, tryed also the option --with-bdeps y and also after other try I run emerge -e system and emerge -e world but the problem is still there. By the way

Code:
# emerge -upvD --with-bdeps y xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB


also revdep-rebuild runs without a problem.
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Fri Feb 01, 2013 12:07 am    Post subject: Reply with quote

'--keep-going' tends to bite you in the a** every now and then, if you're not watching it.

But let's try from a different angle: what's the output of 'emerge -1pv xorg-server glproto' ?
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Fri Feb 01, 2013 11:38 am    Post subject: Reply with quote

Here it is

Code:
emerge -1pv xorg-server glproto

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-proto/glproto-1.4.16  0 kB
[ebuild   R    ] x11-base/xorg-server-1.13.1  USE="ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal* (-selinux) -static-libs -tslib -xnest -xvfb" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB


I have compiled xorg server with the use minimal, its the only way to compile.
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2372
Location: Dallas area

PostPosted: Fri Feb 01, 2013 12:05 pm    Post subject: Reply with quote

It acts like it's not seeing or not using the /usr/include/GL/glxproto.h file.

Do you have an old glxproto.h somewhere in /usr/local/include ?

if you have locate installed on your system, what does "locate glxproto.h" return?
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Fri Feb 01, 2013 12:52 pm    Post subject: Reply with quote

Actually, in the case of xorg-server 'minimal' is for very specific needs, that you most likely don't have.
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Fri Feb 01, 2013 1:10 pm    Post subject: Reply with quote

Code:
# locate glxproto.h
/usr/include/GL/glxproto.h
/usr/lib64/opengl/xorg-x11/include/glxproto.h
/usr/lib64/opengl/xorg-x11/include/GL/glxproto.h


VoidMage wrote:
Actually, in the case of xorg-server 'minimal' is for very specific needs, that you most likely don't have.


Indeed I don't have any specific need!
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Fri Feb 01, 2013 4:33 pm    Post subject: Reply with quote

What does 'grep xGLXSetClientInfoARBReq /usr/include/GL/glxproto.h' return ?
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2372
Location: Dallas area

PostPosted: Fri Feb 01, 2013 4:47 pm    Post subject: Reply with quote

Drkg4b wrote:
Code:
# locate glxproto.h
/usr/include/GL/glxproto.h
/usr/lib64/opengl/xorg-x11/include/glxproto.h
/usr/lib64/opengl/xorg-x11/include/GL/glxproto.h



I have the one in /usr/include, which is a link to /usr/lib64/opengl/xorg-x11/include/GL/glxproto.h

I don't have /usr/lib64/opengl/xorg-x11/include/glxproto.h
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Fri Feb 01, 2013 6:33 pm    Post subject: Reply with quote

Code:
# grep xGLXSetClientInfoARBReq /usr/include/GL/glxproto.h
} xGLXSetClientInfoARBReq;
#define sz_xGLXSetClientInfoARBReq 24


I tried to move /usr/lib64/opengl/xorg-x11/include/glxproto.h and recompile but nothing changed.
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
gentryx
n00b
n00b


Joined: 22 Aug 2007
Posts: 2

PostPosted: Wed Apr 24, 2013 5:28 am    Post subject: Reply with quote

This issue seems to be caused by the current ebuilds not using the correct location for the GL headers provided by the binary drivers. The fixed ebuilds available at https://bugs.gentoo.org/show_bug.cgi?id=463284 merge fine on my machines.
Back to top
View user's profile Send private message
Drkg4b
n00b
n00b


Joined: 07 Aug 2006
Posts: 42
Location: Italy

PostPosted: Wed Apr 24, 2013 10:12 am    Post subject: Reply with quote

That is probably it! Thanks!
_________________
No Star Can Light Our Way In This Life Of Dark And Fear
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum