Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved, z.t.] Installationsprobleme (chroot / keyboard)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
CoPyCaT
n00b
n00b


Joined: 02 Jul 2004
Posts: 68
Location: Germany

PostPosted: Wed Jul 11, 2012 6:47 pm    Post subject: [solved, z.t.] Installationsprobleme (chroot / keyboard) Reply with quote

Hallo,

nachdem Gentoo seit Jahren auf meinem betagten Notebook ohne nennenswerte Probleme läuft, wollte ich es nun auch endlich auf meinem neuen Desktoprechner installieren der bisher nur Windows kannte.
Die Installation von den Gentoo LiveCD's kann ich vergessen, nach dem booten wird mein USB Keyboard nicht erkannt, weder ab,-anstöpseln, noch Keyboardwechsel und Suchmaschine schafften abhilfe.
Einer der letzten c't Ausgaben lag eine UbuntuDVD bei, also habe ich die Installation von der aus versucht, was bis zum betreten des Gentoo Systems per chroot auch funktionierte.
Bevor die Frage kommt, DVD ist ein x64 System, mein Stagetarball auch x64

Nach Alternativanleitung:
Code:

# env -i HOME=$HOME TERM=$TERM chroot /mnt/gentoo /bin/bash
# /usr/sbin/env-update
# source /etc/profile


Der chroot funktioniert scheinbar nicht richtig, zwar ändert sich in der Eingabe die Farbe des Hostnamens aber env-update wird dann nicht gefunden.
Nun habe ich eine Weile mit dem Suchmaschinenprimus verbracht aber eine wirkliche Lösung oder auch nur ein Ansatz konnt ich nicht finden.
_________________
"I essentially started using Gentoo because my ....ing KDE clock would never show the right time in Red Hat."


Last edited by CoPyCaT on Thu Jul 19, 2012 9:34 am; edited 1 time in total
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 568

PostPosted: Wed Jul 11, 2012 10:57 pm    Post subject: Re: Installationsprobleme (chroot / keyboard) Reply with quote

Hi
CoPyCaT wrote:
...
Der chroot funktioniert scheinbar nicht richtig, zwar ändert sich in der Eingabe die Farbe des Hostnamens aber env-update wird dann nicht gefunden.
Nun habe ich eine Weile mit dem Suchmaschinenprimus verbracht aber eine wirkliche Lösung oder auch nur ein Ansatz konnt ich nicht finden.

Funktioniert es wenn du:
Code:
mount -o bind /proc /mnt/gentoo/proc
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
ausführst?

Wenn nicht was sagt denn in der chroot umgebung
Code:
ls -al /usr/sbin/env-update


MfG
Back to top
View user's profile Send private message
CoPyCaT
n00b
n00b


Joined: 02 Jul 2004
Posts: 68
Location: Germany

PostPosted: Thu Jul 19, 2012 9:40 am    Post subject: Reply with quote

Hiho,

Ich konnte einen Teil meiner Probleme lösen. Hatte den snapshot entpackt und dann erst /usr gemounted.......... Kein Wunder also etc-update nicht funktionierte.

Das Keyboard Problem besteht weiterhin, System ist installiert, zur Sicherheit hab ich mir einen Kernel mittels genkernel gebaut, aber weder meine Roccat Isku noch die Razr Tarantula werden erkannt, wie schon unter den livecd's. Konnte mir dahingehend nur mit einer Funktastatur von Feinkost Albrecht behelfen, was aber keine dauerhafte Lösung ist.

Jemand eine Idee?
_________________
"I essentially started using Gentoo because my ....ing KDE clock would never show the right time in Red Hat."
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2303
Location: Germany

PostPosted: Thu Jul 19, 2012 12:43 pm    Post subject: Reply with quote

CoPyCaT wrote:
.... aber weder meine Roccat Isku noch die Razr Tarantula werden erkannt ....
Fehlt eventuell noch der CONFIG_HID_ROCCAT Treiber?
Code:
CONFIG_HID_ROCCAT:

Support for Roccat devices.
Say Y here if you have a Roccat mouse or keyboard and want
support for its special functionalities.

Symbol: HID_ROCCAT [=n]
Type  : tristate
Prompt: Roccat device support
  Defined at drivers/hid/Kconfig:485
  Depends on: HID_SUPPORT [=y] && HID [=y] && USB_HID [=m]
  Location:
    -> Device Drivers
      -> HID Devices (HID_SUPPORT [=y])
        -> Special HID drivers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum