Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201206-36 ] logrotate: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1561

PostPosted: Tue Jun 26, 2012 3:26 am    Post subject: [ GLSA 201206-36 ] logrotate: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: logrotate: Multiple vulnerabilities (GLSA 201206-36)
Severity: high
Exploitable: local
Date: June 25, 2012
Bug(s): #356811, #372973
ID: 201206-36

Synopsis

Multiple vulnerabilities were found in logrotate, which could lead
to arbitrary system command execution.


Background

logrotate rotates, compresses, and mails system logs.

Affected Packages

Package: app-admin/logrotate
Vulnerable: < 3.8.0
Unaffected: >= 3.8.0
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in logrotate. Please
review the CVE identifiers referenced below for details.


Impact

A local attacker could use this flaw to truncate arbitrary system file,
to change file owner or mode on arbitrary system files, to conduct
symlink attacks and send arbitrary system files, to execute arbitrary
system commands, to cause abort in subsequent logrotate runs, to disclose
sensitive information, to execute arbitrary code or cause a Denial of
Service condition.


Workaround

There is no known workaround at this time.

Resolution

All logrotate users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-admin/logrotate-3.8.0"
   


References

CVE-2011-1098
CVE-2011-1154
CVE-2011-1155
CVE-2011-1549
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum