Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hat jemand Bock auf grub2?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4123

PostPosted: Wed Jul 04, 2012 5:59 pm    Post subject: Reply with quote

musv wrote:
Ich hab systematisch alles auf grub2 umgestellt, da ich bei 2 Rechnern auf GPT umgestiegen bin. Die Konfigurationsskripte gingen bei mir nie auch nur ansatzweise. Hab mir 'ne minimale grub.cfg zusammengebastelt, die ganz gut funktioniert.

Bis auf die Partitionsnummern war's kein großer Unterschied zu Grub1.

Ich verwende auf meinem Laptop auch GPT partitionen und verwende grub1. (Das ebuild patched grub1 mit gpt support, https://bugs.gentoo.org/show_bug.cgi?id=178586)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2696
Location: de

PostPosted: Wed Jul 04, 2012 7:08 pm    Post subject: Reply with quote

Klaus Meier wrote:
Hast du eine arg komplizierte Konfiguration? Poste mal den Inhalt von deinem Ordner /boot. Es dürfen keine Links drin sein und an alle Dateien muss die Versionsnr. angehängt sein, sonst klappt es nicht.


grub.cfg:

if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
set timeout=5
insmod fat
insmod font
set gfxmode=1024x768
set gfxpayload=keep
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
insmod gfxterm
terminal_output gfxterm
loadfont ${prefix}/unifont.pf2
#insmod jpeg
#background_image ${prefix}/Alley_Baggett_003.jpg
set menu_color_normal=blue/black
set menu_color_highlight=light-blue/dark-gray

menuentry "Gentoo 3.4.4 WLan"   {
        set root=(hd0,2)
        linux /boot/bzImage-344 root=/dev/sda4 ro video=uvesafb:ywrap,mtrr:3,1200x800-32@60 softlevel=wlan acpi_enforce_resources=lax CONSOLE=/dev/tty1
                # resume=swap:/dev/sda2 - für tuxonice
                #initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
}

menuentry "Gentoo 3.4.4 Lan"   {
        set root=(hd0,2)
        linux /boot/bzImage-344 root=/dev/sda4 ro video=uvesafb:ywrap,mtrr:3,1200x800-32@60 softlevel=lan acpi_enforce_resources=lax CONSOLE=/dev/tty1
        # resume=swap:/dev/sda2 - für tuxonice
        #initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
}

menuentry "Gentoo 3.4.4 Networkmanager"   {
        set root=(hd0,2)
        linux /boot/bzImage-344 root=/dev/sda4 ro video=uvesafb:ywrap,mtrr:3,1200x800-32@60 acpi_enforce_resources=lax CONSOLE=/dev/tty1
        # resume=swap:/dev/sda2 - für tuxonice
        #initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
}


ls /boot/:
la /boot/
insgesamt 12544
drwxr-xr-x 7 root root    4096 26. Jun 21:19 .
dr-xr-xr-x 1 root root     128 23. Jun 17:44 ..
lrwxrwxrwx 1 root root       1 31. Mär 23:06 boot -> .
-rw-r--r-- 1 root root 2614880 31. Mär 09:12 bzImage-330
-rw-r--r-- 1 root root 2618080 12. Apr 22:02 bzImage-331
-rw-r--r-- 1 root root 2629376 29. Apr 17:54 bzImage-333
-rw-r--r-- 1 root root 2454832 25. Jun 21:58 bzImage-340
-rw-r--r-- 1 root root 2456208 26. Jun 21:19 bzImage-344
drwxr-xr-x 6 root root    4096 26. Jun 21:18 grub2
drwxr-xr-x 2 root root    4096  2. Mai 19:20 grub.old
drwxr-xr-x 2 root root    4096  3. Mai 12:48 iso
drwx------ 2 root root   16384 26. Okt 2010  lost+found
drwxr-xr-x 2 root root    4096 28. Mär 2011  memtest86plus


Nix kompliziertes. Funktioniert halt so. Ich seh auch keinen Bedarf für die Automatisierung durch die Scripte.

firefly wrote:
Ich verwende auf meinem Laptop auch GPT partitionen und verwende grub1.

Viellleicht hab ich's auch nur aus Neugierde ausprobiert. Ist auch egal. Es läuft und das reicht mir. Wenn ich mal zuviel Zeit hab, bastel ich mal noch etwas an der Optik und bau noch die Sysrescue-Disk ins Startmenü mit rein.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2388
Location: Bozen

PostPosted: Wed Jul 04, 2012 7:11 pm    Post subject: Reply with quote

Da sehe ich schon ein Problem. Stand in irgendeiner Doku. Die Kernel müssen mit vmlinuz losgehen und hinten muss die Version dran stehen. Sieht bei mir so aus, wurde so von make install erzeugt, ohne dass ich etwas änder musste.
Code:
-rw-r--r-- 1 root root   69110  3. Jul 19:31 config-3.4.4-gentoo
-rw-r--r-- 1 root root   69110  3. Jul 12:24 config-3.4.4-gentoo.old
drwxr-xr-x 6 root root    1024  1. Jul 13:22 grub2
drwx------ 2 root root   12288  1. Jul 12:28 lost+found
-rw-r--r-- 1 root root 1678862  3. Jul 19:31 System.map-3.4.4-gentoo
-rw-r--r-- 1 root root 1681614  3. Jul 12:24 System.map-3.4.4-gentoo.old
-rw-r--r-- 1 root root 2970432  3. Jul 19:31 vmlinuz-3.4.4-gentoo
-rw-r--r-- 1 root root 2998208  3. Jul 12:24 vmlinuz-3.4.4-gentoo.old

Lösch mal alles in /boot bis auf die beiden grub Ordner und mach in /usr/src/linux mal ein make install. Zum Komprimieren nehme ich lzma.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum