Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201206-15 ] libpng: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1578

PostPosted: Fri Jun 22, 2012 12:26 pm    Post subject: [ GLSA 201206-15 ] libpng: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libpng: Multiple vulnerabilities (GLSA 201206-15)
Severity: normal
Exploitable: remote
Date: June 22, 2012
Updated: June 02, 2014
Bug(s): #373967, #386185, #401987, #404197, #410153
ID: 201206-15

Synopsis

Multiple vulnerabilities in libpng might allow remote attackers to
execute arbitrary code or cause a Denial of Service condition.


Background

libpng is a standard library used to process PNG (Portable Network
Graphics) images. It is used by several programs, including web browsers
and potentially server processes.


Affected Packages

Package: media-libs/libpng
Vulnerable: < 1.5.10
Unaffected: >= 1.5.10
Unaffected: >= 1.2.49 < 1.2.50
Unaffected: >= 1.2.50 < 1.2.51
Unaffected: >= 1.2.51 < 1.2.52
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in libpng:
  • The “embedded_profile_len()” function in pngwutil.c does not
    check for negative values, resulting in a memory leak (CVE-2009-5063).
  • The “png_format_buffer()” function in pngerror.c contains an
    off-by-one error (CVE-2011-2501).
  • The “png_rgb_to_gray()” function in pngrtran.c contains an
    integer overflow error (CVE-2011-2690).
  • The “png_err()” function in pngerror.c contains a NULL pointer
    dereference error (CVE-2011-2691).
  • The “png_handle_sCAL()” function in pngrutil.c improperly handles
    malformed sCAL chunks(CVE-2011-2692).
  • The “png_decompress_chunk()” function in pngrutil.c contains an
    integer overflow error (CVE-2011-3026).
  • The “png_inflate()” function in pngrutil.c contains and out of
    bounds error (CVE-2011-3045).
  • The “png_set_text_2()” function in pngset.c contains an error
    which could result in memory corruption (CVE-2011-3048).
  • The “png_formatted_warning()” function in pngerror.c contains an
    off-by-one error (CVE-2011-3464).


Impact

An attacker could exploit these vulnerabilities to execute arbitrary
code with the permissions of the user running the vulnerable program,
which could be the root user, or to cause programs linked against the
library to crash.


Workaround

There is no known workaround at this time.

Resolution

All libpng 1.5 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.10"
   
All libpng 1.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.49"
   
Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these packages.


References

CVE-2009-5063
CVE-2011-2501
CVE-2011-2690
CVE-2011-2691
CVE-2011-2692
CVE-2011-3026
CVE-2011-3045
CVE-2011-3048
CVE-2011-3464


Last edited by GLSA on Tue Jun 03, 2014 4:31 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum