Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201206-13 ] Mono: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Thu Jun 21, 2012 11:26 pm    Post subject: [ GLSA 201206-13 ] Mono: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Mono: Multiple vulnerabilities (GLSA 201206-13)
Severity: high
Exploitable: local, remote
Date: June 21, 2012
Bug(s): #277878, #342133, #345561, #346401, #351087, #372983
ID: 201206-13

Synopsis

Multiple vulnerabilities were found in Mono, the worst of which
allowing for the remote execution of arbitrary code.


Background

Mono is an open source implementation of Microsoft's .NET Framework.

Affected Packages

Package: dev-util/mono-debugger
Vulnerable: < 2.8.1-r1
Unaffected: >= 2.8.1-r1
Architectures: All supported architectures

Package: dev-lang/mono
Vulnerable: < 2.10.2-r1
Unaffected: >= 2.10.2-r1
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Mono and Mono debugger.
Please review the CVE identifiers referenced below for details.


Impact

A remote attacker could execute arbitrary code, bypass general
constraints, obtain the source code for .aspx applications, obtain other
sensitive information, cause a Denial of Service, modify internal data
structures, or corrupt the internal state of the security manager.
A local attacker could entice a user into running Mono debugger in a
directory containing a specially crafted library file to execute
arbitrary code with the privileges of the user running Mono debugger.
A context-dependant attacker could bypass the authentication mechanism
provided by the XML Signature specification.


Workaround

There is no known workaround at this time.

Resolution

All Mono debugger users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-util/mono-debugger-2.8.1-r1"
   
All Mono users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/mono-2.10.2-r1"
   


References

CVE-2009-0217
CVE-2010-3332
CVE-2010-3369
CVE-2010-4159
CVE-2010-4225
CVE-2010-4254
CVE-2011-0989
CVE-2011-0990
CVE-2011-0991
CVE-2011-0992
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum