Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xorg] [evdev] pas de souris ni clavier(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Thu Jun 21, 2012 8:55 pm    Post subject: [xorg] [evdev] pas de souris ni clavier(résolu) Reply with quote

Bonjour,

Je viens d'installer xorg et xterm, j'ai une carte ATI Raedon j'ai réussi a installer les drivers fglrx et j'obtiens bien un accès au serveur avec startx. En revanche je n'ai pas la possibilité d'utiliser ni souris ni clavier.
Si je lis le log de xorg je peux voir que evdev n'est pas chargé :
Code:
[   783.077] (II) Initializing built-in extension DAMAGE
[   783.081] (II) AIGLX: Screen 0 is not DRI capable
[   783.082] [glesx] __glESXExtensionInit: No GL ES2.0 capable screen found!
[   783.088] (II) fglrx(0): Setting screen physical size to 338 x 270
[   783.767] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   783.767] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   783.767] (**) Power Button: Applying InputClass "keyboard-all"
[   783.767] (II) LoadModule: "evdev"
[   783.767] (WW) Warning, couldn't open module evdev
[   783.767] (II) UnloadModule: "evdev"
[   783.767] (II) Unloading evdev
[   783.767] (EE) Failed to load module "evdev" (module does not exist, 0)
[   783.767] (EE) No input driver matching `evdev'
[   783.767] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[   783.767] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   783.767] (**) Power Button: Applying InputClass "keyboard-all"
[   783.767] (II) LoadModule: "evdev"
[   783.768] (WW) Warning, couldn't open module evdev
[   783.768] (II) UnloadModule: "evdev"
[   783.768] (II) Unloading evdev
[   783.768] (EE) Failed to load module "evdev" (module does not exist, 0)
[   783.768] (EE) No input driver matching `evdev'
[   783.768] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event2)
[   783.768] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[   783.768] (II) LoadModule: "evdev"
[   783.768] (WW) Warning, couldn't open module evdev
[   783.768] (II) UnloadModule: "evdev"
[   783.768] (II) Unloading evdev
[   783.768] (EE) Failed to load module "evdev" (module does not exist, 0)
[   783.768] (EE) No input driver matching `evdev'
[   783.769] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[   783.769] (II) No input driver specified, ignoring this device.
[   783.769] (II) This device may have been added with another device file.
[   783.769] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[   783.769] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[   783.769] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[   783.769] (II) LoadModule: "evdev"
[   783.769] (WW) Warning, couldn't open module evdev
[   783.769] (II) UnloadModule: "evdev"
[   783.769] (II) Unloading evdev
[   783.769] (EE) Failed to load module "evdev" (module does not exist, 0)
[   783.769] (EE) No input driver matching `evdev'
[   783.777] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments


J'ai pourtant bien compiler mon noyau avec :
Device Drivers --->
Input device support --->
<*> Event interface

Comme indiqué dans le manuel...

J'ai un clavier PS/2 et une souris USB Logitech pour laquelle j'ai activer le support dans menuconfig.

Merci pour votre aide


Last edited by Sirmk on Fri Jun 22, 2012 7:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Thu Jun 21, 2012 9:00 pm    Post subject: Reply with quote

Bonjour,

Pour evdev il te faut : x11-drivers/xf86-input-evdev, que donnes un "emerge -pv xf86-input-evdev" ?

Avec dans le /etc/make.conf les éléments suivants : INPUT_DEVICES="evdev"

@+
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Thu Jun 21, 2012 9:06 pm    Post subject: Reply with quote

merci je le cherche depuis tout à l'heure... très rapide la réponse en plus merci++

Je regarde si j'ai le driver...
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Thu Jun 21, 2012 9:11 pm    Post subject: Reply with quote

Nickel tout fonctionne... Comment peut-on consulter les ebuild sur gentoo ?

Merci pour ton aide

@+
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Thu Jun 21, 2012 9:16 pm    Post subject: Reply with quote

Si tu veux regarder ce que contient les ebuild c'est par défaut dans /usr/portage, par exemple pour evdev c'est : /usr/portage/x11-drivers/xf86-input-evdev/*.ebuild

@+
Back to top
View user's profile Send private message
Sirmk
n00b
n00b


Joined: 16 Jun 2012
Posts: 28

PostPosted: Thu Jun 21, 2012 9:18 pm    Post subject: Reply with quote

Ok merci beaucoup...@+
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Thu Jun 21, 2012 9:24 pm    Post subject: Reply with quote

De rien @+
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum