Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Problema emerge kde
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
primax
n00b
n00b


Joined: 12 Dec 2011
Posts: 29
Location: Perfugas (SS) , Sardegna

PostPosted: Wed Jun 20, 2012 7:02 pm    Post subject: [Risolto] Problema emerge kde Reply with quote

Ciao a tutti,
sto seguendo questa guida per installare kde: http://www.gentoo.org/proj/it/desktop/kde/kde4-guide.xml
Al momento che do 'emerge -uDNav world' mi da questo errore:
Code:
# emerge -uDNav world

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "media-libs/mesa" has unmet requirements.
- media-libs/mesa-8.0.3::gentoo USE="classic egl gallium llvm (multilib) nptl shared-glapi vdpau -bindist -d3d -debug -g3dvl -gbm -gles1 -gles2 -openvg -osmesa -pax_kernel -pic (-selinux) -shared-dricore (-wayland) -xa -xvmc" VIDEO_CARDS="-i915 -i965 -intel -nouveau -r100 -r200 -r300 -r600 -radeon -vmware"

  The following REQUIRED_USE flag constraints are unsatisfied:
    vdpau? ( g3dvl )

  The above constraints are a subset of the following complete expression:
    d3d? ( gallium ) g3dvl? ( gallium ) llvm? ( gallium ) openvg? ( egl gallium ) gbm? ( shared-glapi ) g3dvl? ( any-of ( vdpau xvmc ) ) vdpau? ( g3dvl ) xa? ( gallium ) xvmc? ( g3dvl ) video_cards_intel? ( any-of ( classic gallium ) ) video_cards_i915? ( any-of ( classic gallium ) ) video_cards_i965? ( classic ) video_cards_nouveau? ( any-of ( classic gallium ) ) video_cards_radeon? ( any-of ( classic gallium ) ) video_cards_r100? ( classic ) video_cards_r200? ( classic ) video_cards_r300? ( gallium ) video_cards_r600? ( gallium ) video_cards_vmware? ( gallium )

(dependency required by "virtual/glu-7.0" [ebuild])
(dependency required by "media-libs/libsdl-1.2.15-r2[opengl]" [ebuild])
(dependency required by "media-libs/libmpeg2-0.5.1-r1[sdl]" [ebuild])
(dependency required by "media-plugins/gst-plugins-mpeg2dec-0.10.18" [ebuild])
(dependency required by "media-plugins/gst-plugins-meta-0.10-r7[dvd,mpeg,-vcd]" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.6.0" [ebuild])
(dependency required by "media-libs/phonon-4.6.0-r1[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.8.3" [ebuild])
(dependency required by "sys-auth/polkit-kde-agent-0.99.0" [ebuild])
(dependency required by "sys-auth/polkit-0.104-r1[kde]" [ebuild])
(dependency required by "sys-fs/udisks-1.0.4-r2" [ebuild])


Qualcuno puo' spiegarmi a cosa e dovuto? E' gia' capitato a qualcuno?
_________________
www.linuxmx.it


Last edited by primax on Thu Jun 21, 2012 2:08 pm; edited 3 times in total
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 610
Location: Milano

PostPosted: Wed Jun 20, 2012 9:01 pm    Post subject: Reply with quote

hai per caso messo un fantastico ACCEPT_KEYWORDS="~amd64" nel tuo make.conf?

in ogni caso il succo del discorso è questo:

Quote:
The following REQUIRED_USE flag constraints are unsatisfied:
vdpau? ( g3dvl )


se hai la flag vdpau attiva, media-libs/mesa deve essere compilato con la flag g3dvl attiva, quindi un semplice

echo "media-libs/mesa g3dvl" >> /etc/portage/package.use

dovrebbe risolvere il tuo problema
Back to top
View user's profile Send private message
primax
n00b
n00b


Joined: 12 Dec 2011
Posts: 29
Location: Perfugas (SS) , Sardegna

PostPosted: Thu Jun 21, 2012 6:41 am    Post subject: Reply with quote

grazie k01 ora è partito a compilare, dando echo "media-libs/mesa g3dvl" >> /etc/portage/package.use
cmq si ho ACCEPT_KEYWORDS="~amd64" nel make.conf perchè ho il sistema a 64bit...comportà qualcosa?
_________________
www.linuxmx.it
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Thu Jun 21, 2012 7:20 am    Post subject: Reply with quote

primax wrote:
cmq si ho ACCEPT_KEYWORDS="~amd64" nel make.conf perchè ho il sistema a 64bit...comportà qualcosa?

sì, che installerai tutti pacchetti considerati ancora in testing.

Visto che ti sei bloccato su una cosa semplice semplice come ili cambiamento di una USE io ti consiglio di reinstallare usando amd64 (senza tilde) come keyword e poi, se ne avrai bisogno (e quando avrai un po' più si esperienza), smascherare selettivamente solo alcuni pacchetti.

poi se sei un avventuroso continua pure così :lol:
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
primax
n00b
n00b


Joined: 12 Dec 2011
Posts: 29
Location: Perfugas (SS) , Sardegna

PostPosted: Thu Jun 21, 2012 8:15 am    Post subject: Reply with quote

grazie mille dell'aiuto e delle dritte. Reistallerò sicuramente :)
_________________
www.linuxmx.it
Back to top
View user's profile Send private message
primax
n00b
n00b


Joined: 12 Dec 2011
Posts: 29
Location: Perfugas (SS) , Sardegna

PostPosted: Thu Jun 21, 2012 1:00 pm    Post subject: Reply with quote

Ciao ragazzi....ho reinstallato. Questa volta ho levato la tilde. Ora quando vado ad emergere wolrd e kde-meta mi risponde cosi:
Code:
# emerge -uDNav world kde-meta

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/util-linux:0

  (sys-apps/util-linux-2.20.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/util-linux-2.21::gentoo, installed) pulled in by
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.4-r2::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
#required by kde-base/plasma-workspace-4.8.3[python], required by kde-base/kdebase-startkde-4.8.3, required by kde-base/kdebase-meta-4.8.3, required by kde-base/kde-meta-4.8.3, required by kde-meta (argument)
>=dev-python/PyQt4-4.9.1 webkit declarative sql

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! All ebuilds that could satisfy ">=dev-python/PyQt4-4.8.2[dbus,declarative,sql,svg,webkit,X,python_abis_2.5?,python_abis_2.6?,python_abis_2.7?,python_abis_3.1?,python_abis_3.2?,python_abis_3.3?]" have been masked.                       
!!! One of the following masked packages is required to complete your request:
- dev-python/PyQt4-4.9.1::gentoo (masked by: )

(dependency required by "kde-base/pykde4-4.8.3-r1000" [ebuild])
(dependency required by "kde-base/plasma-workspace-4.8.3[python]" [ebuild])
(dependency required by "kde-base/kdebase-startkde-4.8.3" [ebuild])
(dependency required by "kde-base/kdebase-meta-4.8.3" [ebuild])
(dependency required by "kde-base/kde-meta-4.8.3" [ebuild])
(dependency required by "kde-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Cosa posso fare per andare avanti?


#####EDIT#####
Ora ho capito il meccanismo...
Ho aggiunto questo:
Code:
>=dev-python/PyQt4-4.9.1 webkit declarative sql

a /etc/portage/package.use
Poi ho ridato il comando e mi ha detto che c'erano pacchetti mascherati allora li ho aggiunti a /etc/portage/package.keywords
_________________
www.linuxmx.it
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 610
Location: Milano

PostPosted: Thu Jun 21, 2012 1:49 pm    Post subject: Reply with quote

questo succede perchè stai usando gli stage di funtoo, e non gentoo... correggimi se sbaglio
Back to top
View user's profile Send private message
primax
n00b
n00b


Joined: 12 Dec 2011
Posts: 29
Location: Perfugas (SS) , Sardegna

PostPosted: Thu Jun 21, 2012 7:26 pm    Post subject: Reply with quote

mi hai beccato :D
_________________
www.linuxmx.it
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2960
Location: Milano, Italy

PostPosted: Sat Jun 23, 2012 10:15 am    Post subject: Reply with quote

benvenuto :D

Forse ti conviene iniziare con Gentoo standard, con gli stage di gentoo e tutto standard. Così anche potremo darti più facilmente supporto.

Funtoo è un progetto affascinante ma ha delle differenze e pertanto se hai bisogno di supporto sarebbe più corretto tu lo vada a chiedere alla comunità funtoo.

Al tempo stesso, visto che per te che cominci non cambia molto, ti conviene partire con gentoo, farti le ossa, acquisire maggiori competenze e poi così sarai in grado in autonomia di decidere se le evoluzioni di funtoo ti servono o meno ;)

my 0.02€

Per finire, forse ti conviene reinstallare... una 3a volta :D

Coraggio, ci siamo passati tutti, l'handbook sotto mano, appunti di installazione sparsi qua e là, e qualche reinstallazione :D
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum