Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc-4.7.1: LTO and --as-needed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Ginta
Tux's lil' helper
Tux's lil' helper


Joined: 17 Feb 2006
Posts: 105
Location: Spain

PostPosted: Tue Jun 19, 2012 6:48 pm    Post subject: gcc-4.7.1: LTO and --as-needed Reply with quote

I am testing to compile the whole system with lto enabled and --as-needed (which is the default for Gentoo).

But I am curious: There are several packages that fails to build with compination of -flto and --as-needed, but they don't fail is --as-needed is not present.

I already know that lto is oficially unsupported yet in Gentoo, yet I am curious: Is this a bug related to lto, related to --as-needed, or related to package's build scripts?
_________________
Somebody should use emerge brain on theirselves...
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1063
Location: /dev/koelsch

PostPosted: Sun Jun 24, 2012 6:00 pm    Post subject: Reply with quote

Hi Ginta,

eventually you could find on the following link some reason for this:

Look at Gentoo Linux Health Report (June 22, 2012, 10:41 UTC) from Diego E. Pettenò a.k.a. flameeyes here
http://planet.gentoo.org/


Regards, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum