Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Can't see software stuff in POL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Demontager
n00b
n00b


Joined: 31 Oct 2010
Posts: 52
Location: Kherson Ukraine

PostPosted: Wed Jun 06, 2012 4:02 pm    Post subject: [SOLVED]Can't see software stuff in POL Reply with quote

I got PlayOnLinux 4.0.14 installed on Gentoo amd64 with Zen kernel 3.3.7.

When first time i tried to start POL it failed because was asking for python 2.6, so i set main python version as 2.7 and then it started. Second problem appeared when I searched for software description inside POL and also I unable to install any versions of WINE

I shoot this video which fully represents my problem - http://youtu.be/etEEQplc-jw
_________________
gentoo and linux:


Last edited by Demontager on Thu Jun 07, 2012 9:17 am; edited 1 time in total
Back to top
View user's profile Send private message
PhaytalError
n00b
n00b


Joined: 17 May 2012
Posts: 42

PostPosted: Wed Jun 06, 2012 4:07 pm    Post subject: Reply with quote

Hmmm, try and double click on the categories and see if that pulls any of the apps and games up.
_________________
Linux. Freedom. Power.
Back to top
View user's profile Send private message
Demontager
n00b
n00b


Joined: 31 Oct 2010
Posts: 52
Location: Kherson Ukraine

PostPosted: Wed Jun 06, 2012 4:15 pm    Post subject: Reply with quote

Nope. Tried to double click. Also list of available libraries for override is empty. Got same problem on both machines where Gentoo installed and one machine with Ubuntu where POL works fine and successfully gets all info.
_________________
gentoo and linux:
Back to top
View user's profile Send private message
PhaytalError
n00b
n00b


Joined: 17 May 2012
Posts: 42

PostPosted: Wed Jun 06, 2012 5:17 pm    Post subject: Reply with quote

Demontager wrote:
Nope. Tried to double click. Also list of available libraries for override is empty. Got same problem on both machines where Gentoo installed and one machine with Ubuntu where POL works fine and successfully gets all info.


Hmmm, let me emerge POL for ya and see what the results are... :)


Okay, so it's emerged... and I do not experience the same issue you're having. Perhaps, you should remove the ~/.PlayOnLinux directory and try it again and see if that helps. 8)
_________________
Linux. Freedom. Power.
Back to top
View user's profile Send private message
Demontager
n00b
n00b


Joined: 31 Oct 2010
Posts: 52
Location: Kherson Ukraine

PostPosted: Wed Jun 06, 2012 5:42 pm    Post subject: Reply with quote

Ok, "hope" same problem happened to you :D so we may figure out what's wrong. That's my whole system stuff:
Code:

dem@localhost ~ $ emerge --info
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.3.7-zen+ x86_64)
=================================================================
System uname: Linux-3.3.7-zen+-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Wed, 30 May 2012 14:30:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X a52 aac acl acpi alsa amd64 bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv jpeg lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nvidia ogg opengl openmp pam pango pcre pdf pmu png policykit ppds pppd pulseaudio qt3support readline samba sdl semantic-desktop session smp socialweb spell sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb userlocales utf8 v4l2 vorbis wifi wxwidgets x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


_________________
gentoo and linux:
Back to top
View user's profile Send private message
Demontager
n00b
n00b


Joined: 31 Oct 2010
Posts: 52
Location: Kherson Ukraine

PostPosted: Wed Jun 06, 2012 7:45 pm    Post subject: Reply with quote

Ok, I found the source of problem. Asked about it in POL messenger. Short answer - My POL version is too old and I need update it to recent available version, because this well known bug and been fixed long time ago.
Then I been advised to use POL which is available on official website 4.1.1 (our in portage has old and nasty 4.0.14 v). That's fine to me to try recent, because POL runs as portable application and doesn't mess portage. But, I got problem when launching it - "PlayOnLinux cannot find icotool." Then I started to search this magic "icotool" in portage - not found, then Google said me gently that it may be part of media-gfx/icoutils package. Tried to compile it and failed on
Code:

 Emerging (1 of 1) media-gfx/icoutils-0.29.1-r1
 * icoutils-0.29.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...               [ ok ]
>>> Unpacking source...
>>> Unpacking icoutils-0.29.1.tar.bz2 to /var/tmp/portage/media-gfx/icoutils-0.29.1-r1/work
>>> Source unpacked in /var/tmp/portage/media-gfx/icoutils-0.29.1-r1/work
>>> Preparing source in /var/tmp/portage/media-gfx/icoutils-0.29.1-r1/work/icoutils-0.29.1 ...
 * Applying icoutils-0.29.1-locale.patch ...                             [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-gfx/icoutils-0.29.1-r1/work/icoutils-0.29.1' ...
 * Running autopoint --force ...                                         [ !! ]

 * Failed Running autopoint !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/media-gfx/icoutils-0.29.1-r1/temp/autopoint.out

 * ERROR: media-gfx/icoutils-0.29.1-r1 failed (prepare phase):
 *   Failed Running autopoint !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 2666:  Called eautoreconf
 *   environment, line  768:  Called eautopoint '--force'
 *   environment, line  745:  Called autotools_run_tool 'autopoint' '--force'
 *   environment, line  554:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";


_________________
gentoo and linux:
Back to top
View user's profile Send private message
Demontager
n00b
n00b


Joined: 31 Oct 2010
Posts: 52
Location: Kherson Ukraine

PostPosted: Thu Jun 07, 2012 8:02 am    Post subject: Reply with quote

Fixed and found real source of problem. The problem was in wget, it was giving an error "wget --4 unrecognised option" That means it tried to retrieve software info using ipv6 protocol, which was enabled in kernel, but in fact lacked wget doesn't know about ipv6. Then i discovered that i may compile wget with ipv6 support, so i did and then everything became normal. Even old version of POL starts retrieving info.
_________________
gentoo and linux:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum