Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Moved to different forum] [SOLVED]: Firefox upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Mon May 28, 2012 7:20 am    Post subject: [Moved to different forum] [SOLVED]: Firefox upgrade Reply with quote

Hi, ALL,

Is there anything I need to take care after such an upgrade:

Code:

IgorReinCloud igor # emerge -pv firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libpng-1.5.10 [1.4.5] USE="apng%* (-neon) -static-libs" 697 kB
[ebuild  N     ] virtual/freedesktop-icon-theme-0  0 kB
[ebuild     U  ] dev-libs/nspr-4.9 [4.8.7] USE="-debug" 1,190 kB
[ebuild  N     ] media-libs/libvpx-1.0.0  USE="mmx sse sse2 threads (-altivec) -debug -doc -postproc -sse3 -sse4_1 -ssse3 -static-libs" 1,603 kB
[ebuild     U  ] media-libs/libjpeg-turbo-1.2.0-r1 [1.1.0] USE="-java% -static-libs" 1,726 kB
[ebuild     U  ] dev-util/pkgconfig-0.26 [0.25-r2] USE="-hardened" 0 kB
[ebuild  N     ] virtual/pkgconfig-0  0 kB
[ebuild     U  ] dev-libs/nss-3.13.4 [3.12.9-r1] USE="-utils" 6,201 kB
[ebuild     U  ] www-client/firefox-10.0.4 [3.6.20] USE="alsa crashreporter%* dbus ipc libnotify minimal%* startup-notification webm%* -bindist -custom-cflags -custom-optimization -debug -pgo% (-selinux) -system-sqlite -wifi (-gnome%*) (-java%)" LINGUAS="-af -ak% -ar -as -ast% -be -bg -bn_BD -bn_IN -br% -bs% -ca -cs -csb% -cy -da -de -el -en_GB -en_ZA% -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd% -gl -gu_IN -he -hi_IN -hr -hu -hy_AM% -id -is -it -ja -kk -kn -ko -ku -lg% -lt -lv -mai% -mk -ml -mr -nb_NO -nl -nn_NO -nso% -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son% -sq -sr -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW -zu% (-bn%) (-en%) (-en_US%) (-es%) (-fy%) (-ga%) (-gu%) (-hi%) (-ka%) (-nb%) (-nn%) (-oc%) (-pa%) (-pt%) (-sv%)" 73,959 kB

Total: 9 packages (6 upgrades, 3 new), Size of downloads: 85,373 kB

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Thank you.

I needed this version for the vmware product but now I don't need it anymore.

Thank you.

P.S.: Probably this does not belong here. If it's not please don't kick me too hard. ;-)


Last edited by ONEEYEMAN on Fri Jun 01, 2012 8:09 am; edited 2 times in total
Back to top
View user's profile Send private message
Gentoo64
n00b
n00b


Joined: 21 Oct 2011
Posts: 47
Location: ::

PostPosted: Mon May 28, 2012 4:52 pm    Post subject: Reply with quote

Just mask that version and run depclean after downgrading
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Mon May 28, 2012 6:22 pm    Post subject: Reply with quote

Hi,
Gentoo64 wrote:

Just mask that version and run depclean after downgrading


This is not downgrading, but upgrading. ;-)

So there is no culprits? Just straight upgrade?

Thank you.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon May 28, 2012 6:43 pm    Post subject: Reply with quote

should be a straight upgrade (although I have not upgraded from 3.6 to 10.0, but went thought the version in-between).

mozilla just changed their release policy, and recreated a stable branch. 10.0 is one of those stable version, therefore i assume a flawless upgrade.
17.0 will be next major stable version, which will be available somewhen in autumn. details

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
popsUlfr
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2011
Posts: 80

PostPosted: Mon May 28, 2012 8:07 pm    Post subject: Reply with quote

The worst that could happen is your preferences or bookmarks not getting ported over to the new version (highly doubt it though, there haven't been fundamental changes to the layout), so you might consider backing up your bookmarks just in case.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Mon May 28, 2012 8:33 pm    Post subject: Reply with quote

Hi,
Well, it does require an upgrade to libpng and libjpeg-turbo. That's why I was asking.

Thank you.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon May 28, 2012 9:49 pm    Post subject: Reply with quote

firefox depend on virtual/jpeg and media-libs/libpng[apng], therefore no upgrade should be required.
in addition, all version of libpng, libjepeg-turbo and jpeg are stable.

if there is an upgrade, then it is no caused by firefox itself.


V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Tue May 29, 2012 1:47 am    Post subject: Reply with quote

Hi,
This is what I got afterwards:

Code:

 * Messages for package media-libs/libpng-1.5.10:

 * Old versions of installed libraries were detected on your system.
 * In order to avoid breaking packages that depend on these old libs,
 * the libraries are not being removed.  You need to run revdep-rebuild
 * in order to remove these old dependencies.  If you do not have this
 * helper program, simply emerge the 'gentoolkit' package.
 *
 *   # revdep-rebuild --library '/usr/lib64/libpng14.so.14'
 *
 * Once you've finished running revdep-rebuild, it should be safe to
 * delete the old libraries.  Here is a copy & paste for the lazy:
 *   # rm '/usr/lib64/libpng14.so.14'

 * Messages for package www-client/firefox-10.0.4:

 * You are enabling official branding. You may not redistribute this build
 * to any users on your network or the internet. Doing so puts yourself into
 * a legal problem with Mozilla Foundation
 * You can disable it by emerging firefox _with_ the bindist USE-flag


But doing "revdep-rebuild" I am receiving:

Code:

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-libs/libusb-1.0.9 [1.0.8] USE="-static-libs%"
[ebuild  N     ] media-gfx/shared-color-profiles-0.1.5
[ebuild  N     ] app-text/poppler-data-0.4.5-r1
[ebuild     U  ] app-emulation/virtualbox-additions-4.1.12 [4.1.4]
[ebuild  N     ] media-libs/libquvi-scripts-0.4.2  USE="-offensive"
[ebuild  N     ] virtual/modutils-0
[ebuild  NS    ] media-libs/lcms-2.3 [1.19] USE="jpeg tiff zlib -doc -static-libs -test"
[ebuild  N     ] sys-apps/paxctl-0.7-r1
[ebuild  N     ] media-libs/libmp4v2-1.9.1  USE="-static-libs -utils"
[ebuild     U  ] dev-libs/libusb-0.1.12-r7 [0.1.12-r5] USE="cxx%* -static-libs%"
[ebuild  N     ] media-libs/faac-1.28-r1  USE="-static-libs"
[ebuild  N     ] media-libs/jbig2dec-0.11-r1  USE="png -static-libs -test"
[ebuild  N     ] media-libs/libdca-0.0.5-r2  USE="-debug -oss -static-libs"
[ebuild  N     ] media-libs/faad2-2.7-r2  USE="-digitalradio -static-libs"
[ebuild     U  ] app-emulation/virtualbox-modules-4.1.12 [4.1.4]
[ebuild  N     ] app-admin/eselect-qtgraphicssystem-1.1.1
[ebuild     U  ] dev-libs/glib-2.30.3 [2.28.6] USE="(-fam*) -systemtap% -utils%"
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.2.0-r1
[ebuild     U  ] x11-libs/cairo-1.10.2-r2 [1.10.2-r1]
[ebuild     U  ] sys-fs/udev-171-r6 [171-r5]
[ebuild     U  ] dev-libs/atk-2.2.0 [1.32.0-r1]
[ebuild     U  ] x11-libs/gdk-pixbuf-2.24.1-r1 [2.24.0-r1]
[ebuild     U  ] sys-apps/dbus-1.4.20 [1.4.6]
[ebuild     U  ] net-libs/libproxy-0.4.7 [0.4.6]
[ebuild     U  ] media-libs/gstreamer-0.10.35 [0.10.32-r1] USE="introspection*"
[ebuild  N     ] media-libs/libquvi-0.4.0  USE="-examples -static-libs"
[ebuild  N     ] media-plugins/gst-plugins-lame-0.10.18
[ebuild  N     ] media-plugins/gst-plugins-ffmpeg-0.10.11-r1  USE="orc"
[ebuild  N     ] dev-libs/fribidi-0.19.2-r2  USE="-static-libs"
[ebuild   R    ] media-libs/gd-2.0.35-r3
[ebuild     U  ] dev-libs/dbus-glib-0.98 [0.92]
[ebuild     U  ] x11-libs/pango-1.29.4 [1.28.4]
[ebuild  N     ] dev-libs/libgusb-0.1.3  USE="-static-libs"
[ebuild     U  ] media-libs/gst-plugins-base-0.10.35 [0.10.32] USE="introspection*"
[ebuild     U  ] app-text/poppler-0.18.4-r1 [0.14.5-r1] USE="introspection%* tiff%*"
[ebuild  N     ] net-libs/glib-networking-2.30.2  USE="gnome libproxy ssl"
[ebuild     U  ] dev-cpp/cairomm-1.10.0 [1.8.6]
[ebuild     U  ] net-libs/libsoup-2.36.1-r1 [2.32.2] USE="introspection* -samba%"
[ebuild  N     ] media-plugins/gst-plugins-faac-0.10.22
[ebuild  N     ] media-plugins/gst-plugins-faad-0.10.22
[ebuild  N     ] media-plugins/gst-plugins-dts-0.10.22  USE="orc"
[ebuild   R    ] gnome-base/libglade-2.6.4
[ebuild     U  ] app-text/ghostscript-gpl-9.05-r1 [8.71-r6] USE="dbus%* -idn% -static-libs%"
[ebuild   R    ] media-gfx/gtkimageview-1.6.4  USE="-static-libs%"
[ebuild     U  ] net-libs/webkit-gtk-1.6.3-r200 [1.2.7] USE="introspection* spell%* -webgl%"
[ebuild     U  ] dev-python/pygtk-2.24.0-r2 [2.22.0-r1]
[ebuild  N     ] media-gfx/imagemagick-6.7.6.4  USE="X bzip2 cxx djvu jpeg lcms openmp pango perl png svg tiff truetype xml zlib -autotrace -corefonts -fftw -fontconfig -fpx -graphviz -gs -hdri -jbig -jpeg2k -lqr -lzma -opencl -openexr -q32 -q64 -q8 -raw -static-libs -test -webp -wmf"
[ebuild  N     ] media-video/dvdauthor-0.6.18
[ebuild   R    ] dev-python/pygtkglext-1.1.0
[ebuild     U  ] sys-auth/polkit-0.104-r1 [0.101-r1] USE="introspection* (-systemd)"
[ebuild     U  ] sys-auth/consolekit-0.4.5_p20120320 [0.4.4] USE="acl%*"
[ebuild     U  ] sys-auth/pambase-20101024-r2 [20101024] USE="consolekit* gnome-keyring*"
[ebuild  N     ] x11-misc/colord-0.1.18  USE="gusb introspection udev -doc -examples -scanner -vala"
[ebuild  NS    ] x11-libs/gtk+-3.2.4-r1 [2.24.5-r1] USE="colord introspection (-aqua) -cups -debug -doc -examples (-packagekit) -test -vim-syntax -xinerama"
[ebuild     U  ] gnome-extra/polkit-gnome-0.105 [0.101-r1]
[ebuild     U  ] gnome-base/gconf-2.32.4 [2.32.0-r1] USE="introspection*"
[ebuild     U  ] gnome-base/libgnomekbd-2.32.0-r1 [2.32.0]
[ebuild  N     ] gnome-base/dconf-0.10.0  USE="X -doc -vala"
[ebuild     U  ] media-libs/libcanberra-0.28-r5 [0.26] USE="gnome%* gtk3%* pulseaudio* udev%*"
[ebuild  N     ] media-plugins/gst-plugins-pulse-0.10.30
[ebuild   R    ] media-libs/swfdec-0.8.4  USE="pulseaudio*"
[ebuild     U  ] net-libs/gtk-vnc-0.5.0-r1 [0.4.2-r2] USE="gtk3%* introspection* pulseaudio%* -python* -vala%"
[ebuild     U  ] media-plugins/gst-plugins-meta-0.10-r7 [0.10-r4] USE="aac%* dts%* mp3%* pulseaudio* -dv% -http% -libvisual% -mms% -musepack% -v4l% -vcd% -vpx% -wavpack%"
[ebuild     U  ] gnome-extra/gnome-media-2.32.0-r1 [2.32.0] USE="aac%* flac%* mp3%* pulseaudio* vorbis%* -speex% -twolame%"
[ebuild   R    ] x11-libs/libgksu-2.0.12-r1
[ebuild   R    ] dev-libs/libgweather-2.30.3  USE="-python*"
[ebuild     U  ] dev-libs/totem-pl-parser-2.32.6-r1 [2.32.3] USE="introspection* quvi%* -archive%"
[ebuild     U  ] gnome-extra/evolution-data-server-2.32.3-r2 [2.32.2]
[ebuild     U  ] x11-libs/qt-core-4.8.1-r3 [4.7.2-r1] USE="(-c++0x) -icu% (-qpa)"
[ebuild     U  ] x11-libs/qt-script-4.8.1 [4.7.2] USE="(-c++0x) (-qpa)"
[ebuild     U  ] x11-libs/qt-dbus-4.8.1 [4.7.2] USE="(-c++0x) (-qpa)"
[ebuild     U  ] x11-libs/qt-gui-4.8.1-r1 [4.7.2] USE="gif%* xv%* (-c++0x) (-qpa)"
[ebuild     U  ] x11-libs/qt-sql-4.8.1 [4.7.2] USE="(-c++0x) (-qpa)"
[ebuild     U  ] x11-libs/qt-qt3support-4.8.1 [4.7.2] USE="(-c++0x) (-qpa)"
[ebuild   R    ] dev-python/notify-python-0.1.1-r2
[ebuild     U  ] gnome-base/gnome-settings-daemon-2.32.1-r2 [2.32.1] USE="pulseaudio*"
[ebuild     U  ] mail-client/evolution-2.32.3-r1 [2.32.2] USE="-connman% -python*"
[ebuild     U  ] media-video/totem-2.32.0-r2 [2.32.0] USE="-python*"
[ebuild     U  ] gnome-base/nautilus-2.32.2.1-r2 [2.32.2.1] USE="introspection*"
[ebuild     U  ] app-cdr/brasero-2.32.1-r1 [2.32.1] USE="dvd%* introspection* -vcd%"
[ebuild     U  ] app-text/evince-2.32.0-r4 [2.32.0-r2] USE="introspection* ps%*"
[ebuild     U  ] gnome-base/gnome-panel-2.32.1-r3 [2.32.1-r1] USE="introspection*"
[ebuild     U  ] dev-util/glade-3.8.2 [3.8.1]
[ebuild     U  ] gnome-base/gdm-2.20.11-r1 [2.20.11]
[ebuild     U  ] app-emulation/virtualbox-4.1.12 [4.1.4]
[ebuild     U  ] app-emulation/virtualbox-extpack-oracle-4.1.12 [4.1.4]
[blocks B      ] >x11-libs/qt-sql-4.7.2-r9999 (">x11-libs/qt-sql-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] <x11-libs/qt-core-4.8.1 ("<x11-libs/qt-core-4.8.1" is blocking x11-libs/qt-script-4.8.1, x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-dbus-4.8.1, x11-libs/qt-sql-4.8.1, x11-libs/qt-qt3support-4.8.1)
[blocks B      ] >x11-libs/qt-core-4.7.2-r9999 (">x11-libs/qt-core-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] <x11-libs/qt-qt3support-4.8.1 ("<x11-libs/qt-qt3support-4.8.1" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-dbus-4.8.1, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1)
[blocks B      ] >x11-libs/qt-qt3support-4.7.2-r9999 (">x11-libs/qt-qt3support-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] >x11-libs/qt-gui-4.7.2-r9999 (">x11-libs/qt-gui-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] <x11-libs/qt-sql-4.8.1 ("<x11-libs/qt-sql-4.8.1" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-dbus-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-qt3support-4.8.1)
[blocks B      ] <x11-libs/qt-opengl-4.8.1 ("<x11-libs/qt-opengl-4.8.1" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-qt3support-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-sql-4.8.1, x11-libs/qt-script-4.8.1, x11-libs/qt-dbus-4.8.1)
[blocks B      ] <x11-libs/qt-dbus-4.8.1 ("<x11-libs/qt-dbus-4.8.1" is blocking x11-libs/qt-script-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-sql-4.8.1, x11-libs/qt-qt3support-4.8.1)
[blocks B      ] >x11-libs/qt-script-4.7.2-r9999 (">x11-libs/qt-script-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] >x11-libs/qt-dbus-4.7.2-r9999 (">x11-libs/qt-dbus-4.7.2-r9999" is blocking x11-libs/qt-opengl-4.7.2)
[blocks B      ] <x11-libs/qt-script-4.8.1 ("<x11-libs/qt-script-4.8.1" is blocking x11-libs/qt-gui-4.8.1-r1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-dbus-4.8.1, x11-libs/qt-sql-4.8.1, x11-libs/qt-qt3support-4.8.1)
[blocks B      ] <x11-libs/qt-gui-4.8.1 ("<x11-libs/qt-gui-4.8.1" is blocking x11-libs/qt-script-4.8.1, x11-libs/qt-core-4.8.1-r3, x11-libs/qt-dbus-4.8.1, x11-libs/qt-sql-4.8.1, x11-libs/qt-qt3support-4.8.1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

  (x11-libs/qt-script-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-script-4.7.2[-aqua,-debug] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)

  (x11-libs/qt-script-4.8.1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-script-4.8.1[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.1-r1::gentoo, ebuild scheduled for merge)

x11-libs/qt-core:4

  (x11-libs/qt-core-4.8.1-r3::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.8.1[aqua=,c++0x=,debug=,qpa=,qt3support=] required by (x11-libs/qt-sql-4.8.1::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (x11-libs/qt-core-4.7.2-r1::gentoo, installed) pulled in by
    ~x11-libs/qt-core-4.7.2[-aqua,-debug,glib,qt3support] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)
    (and 5 more with the same problem)

dev-libs/glib:2

  (dev-libs/glib-2.28.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.30.1:2 required by (net-libs/gtk-vnc-0.5.0-r1::gentoo, ebuild scheduled for merge)
    (and 7 more with the same problem)

dev-python/pygtk:2

  (dev-python/pygtk-2.24.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/pygtk-2.24:2 required by (dev-python/notify-python-0.1.1-r2::gentoo, ebuild scheduled for merge)

  (dev-python/pygtk-2.22.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-dbus:4

  (x11-libs/qt-dbus-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-dbus-4.7.2[-aqua,-debug] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)

  (x11-libs/qt-dbus-4.8.1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-dbus-4.8.1[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.1-r1::gentoo, ebuild scheduled for merge)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.36.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.33.6:2.4[introspection?] required by (net-libs/webkit-gtk-1.6.3-r200::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.32.2::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.32.2 required by (net-libs/libsoup-gnome-2.32.2::gentoo, installed)

media-libs/gst-plugins-base:0.10

  (media-libs/gst-plugins-base-0.10.32::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/gst-plugins-base-0.10.35::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/gst-plugins-base-0.10.33 required by (media-plugins/gst-plugins-pulse-0.10.30::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

x11-libs/qt-sql:4

  (x11-libs/qt-sql-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-sql-4.7.2[-aqua,-debug,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)

  (x11-libs/qt-sql-4.8.1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.8.1[aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-4.8.1::gentoo, ebuild scheduled for merge)

media-libs/gstreamer:0.10

  (media-libs/gstreamer-0.10.32-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/gstreamer-0.10.35::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/gstreamer-0.10.34:0.10[introspection?] required by (media-libs/gst-plugins-base-0.10.35::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

x11-libs/pango:0

  (x11-libs/pango-1.29.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.29.0[introspection?] required by (x11-libs/gtk+-3.2.4-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/pango-1.28.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-gui-4.7.2[accessibility,-aqua,-debug,qt3support] required by (x11-libs/qt-qt3support-4.7.2::gentoo, installed)
    (and 2 more with the same problem)

  (x11-libs/qt-gui-4.8.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.8.1[aqua=,c++0x=,debug=,glib=,qpa=,qt3support] required by (x11-libs/qt-core-4.8.1-r3::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

gnome-base/gconf:2

  (gnome-base/gconf-2.32.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/gconf-2.32.4::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gconf-2.6.1:2[introspection?] required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, ebuild scheduled for merge)
    >=gnome-base/gconf-2:2[introspection?] required by (app-text/evince-2.32.0-r4::gentoo, ebuild scheduled for merge)

gnome-base/nautilus:0

  (gnome-base/nautilus-2.32.2.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/nautilus-2.10[introspection?] required by (app-text/evince-2.32.0-r4::gentoo, ebuild scheduled for merge)

  (gnome-base/nautilus-2.32.2.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

sys-apps/dbus:0

  (sys-apps/dbus-1.4.20::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.4.16 required by (dev-libs/dbus-glib-0.98::gentoo, ebuild scheduled for merge)

  (sys-apps/dbus-1.4.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-qt3support:4

  (x11-libs/qt-qt3support-4.8.1::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-qt3support-4.8.1[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-gui-4.8.1-r1::gentoo, ebuild scheduled for merge)

  (x11-libs/qt-qt3support-4.7.2::gentoo, installed) pulled in by
    ~x11-libs/qt-qt3support-4.7.2[-aqua,-debug] required by (x11-libs/qt-gui-4.7.2::gentoo, installed)

media-plugins/gst-plugins-meta:0.10

  (media-plugins/gst-plugins-meta-0.10-r4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-plugins/gst-plugins-meta-0.10-r7::gentoo, ebuild scheduled for merge) pulled in by
    >=media-plugins/gst-plugins-meta-0.10-r6:0.10[dvd?,vcd?] required by (app-cdr/brasero-2.32.1-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr


How do I resolve it?

I want to stay with GTK+2/GNOME 2....

Thank you.
Back to top
View user's profile Send private message
popsUlfr
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2011
Posts: 80

PostPosted: Tue May 29, 2012 10:19 am    Post subject: Reply with quote

Ah, it's pulling in upgrades as welll...
What does
Code:
emerge -uavDN world

say?
If you can emerge right away then just proceed with the world upgrade then retry to run revdep-rebuild.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Tue May 29, 2012 6:30 pm    Post subject: Reply with quote

Hi,
Please see above. I want to stay with GTK+2/GNOME 2.

Now, "revdep-rebuild" generated following command:
Code:

emerge --complete-graph=y --oneshot   app-cdr/brasero:0 app-text/ghostscript-gpl:0 dev-cpp/cairomm:0 dev-util/glade:3 gnome-base/gdm:0 gnome-base/gnome-panel:0 gnome-base/libglade:2.0 gnome-extra/gnome-media:2 gnome-extra/polkit-gnome:0 mail-client/evolution:2.0 media-gfx/gtkimageview:0 media-libs/gd:2 media-libs/libcanberra:0 media-libs/swfdec:0 net-libs/gtk-vnc:0 net-libs/webkit-gtk:2 x11-libs/cairo:0 x11-libs/gdk-pixbuf:2 x11-libs/libgksu:2 x11-libs/qt-gui:4


Trying to make a manual rebuild I am getting:
Code:

IgorReinCloud igor # emerge -pv --complete-graph=y --oneshot brasero

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] media-libs/lcms-2.3 [1.19] USE="jpeg tiff zlib -doc -static-libs -test" 4,358 kB
[ebuild  N     ] media-libs/libdca-0.0.5-r2  USE="-debug -oss -static-libs" 388 kB
[ebuild  N     ] media-libs/faad2-2.7-r2  USE="-digitalradio -static-libs" 1,111 kB
[ebuild     U  ] media-libs/gstreamer-0.10.35 [0.10.32-r1] USE="introspection* nls -test" 3,522 kB
[ebuild  N     ] dev-libs/fribidi-0.19.2-r2  USE="-static-libs" 654 kB
[ebuild     U  ] media-libs/gst-plugins-base-0.10.35 [0.10.32] USE="introspection* nls orc (-debug%)" 2,718 kB
[ebuild  N     ] media-plugins/gst-plugins-faad-0.10.22  3,457 kB
[ebuild  N     ] media-plugins/gst-plugins-dts-0.10.22  USE="orc" 0 kB
[ebuild  N     ] media-gfx/imagemagick-6.7.6.4  USE="X bzip2 cxx djvu jpeg lcms openmp pango perl png svg tiff truetype xml zlib -autotrace -corefonts -fftw -fontconfig -fpx -graphviz -gs -hdri -jbig -jpeg2k -lqr -lzma -opencl -openexr -q32 -q64 -q8 -raw -static-libs -test -webp -wmf" 7,400 kB
[ebuild  N     ] media-video/dvdauthor-0.6.18  384 kB
[ebuild  N     ] media-plugins/gst-plugins-pulse-0.10.30  3,283 kB
[ebuild     U  ] media-plugins/gst-plugins-meta-0.10-r7 [0.10-r4] USE="X a52 aac%* alsa dts%* dvd flac mp3%* mpeg ogg pulseaudio* vorbis xv -dv% -dvb -ffmpeg -http% -lame -libvisual% -mms% -musepack% -mythtv -oss -taglib -theora -v4l% -vcd% -vpx% -wavpack% (-esd%) (-mad%*) (-v4l2%)" 0 kB
[ebuild     U  ] app-cdr/brasero-2.32.1-r1 [2.32.1] USE="cdr css dvd%* introspection* libburn nautilus -doc -playlist -test -vcd%" 0 kB

Total: 13 packages (4 upgrades, 8 new, 1 in new slot), Size of downloads: 27,270 kB

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


How come "imagemagic is oulling in? Is there a way to exclude it?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2089

PostPosted: Wed May 30, 2012 8:00 am    Post subject: Reply with quote

I opened another thread in "Portage and Programming" forum as this clearly belongs there.

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum