Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postfix-Verständnisproblem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2109
Location: Konradsreuth (Germany)

PostPosted: Sat May 26, 2012 11:11 am    Post subject: Postfix-Verständnisproblem Reply with quote

Hallo allerseits!

Ich bin gerade dabei, einen Postfix-Mailserver aufzusetzen. Sieht so weit ganz gut aus, aber ich habe ein Problem: Für den Versand habe ich einen externen Relay-Host eingerichtet. Jetzt kann ich, abhängig von einer Zeile in master.cf, entweder E-Mails verschicken _oder_ empfangen – aber nicht beides. Für die Postfächer hab ich virtuelle Mailboxen eingerichtet.

Steht in master.cf folgendes:
Code:
smtp      inet  n       -       n       -       -       smtpd

kann ich E-Mails empfangen (z. B. von GMX an mailbox@server.de geschickt). Wird ganz normal einsortiert. Wenn ich aber eine E-Mail verschicken will (mittels 'echo "Test" | mail -s 'Test' adresse@gmx.de'), dann bekomme ich folgendes:
Code:
May 26 12:38:34 [postfix/pickup] ...: uid=0 from=<root>
May 26 12:38:34 [postfix/cleanup] ...: message-id=<...@server.de>
May 26 12:38:34 [postfix/qmgr] ...: from=<root@server.de>, size=240, nrcpt=1 (queue active)
May 26 12:38:34 [postfix/qmgr] warning: connect to transport private/smtp: Connection refused
May 26 12:38:34 [postfix/error] ...: to=<adresse@gmx.de>, relay=none, delay=1.9, delays=1.9/0/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)


Wenn in master.cf folgendes steht:
Code:
smtp      unix  -       -       n       -       -       smtp

Dann funktioniert der Versand:
Code:
May 26 12:27:07 [postfix/pickup] ...: uid=0 from=<root>
May 26 12:27:07 [postfix/cleanup] ...: message-id=<...@server.de>
May 26 12:27:07 [postfix/qmgr] ...: from=<root@server.de>, size=240, nrcpt=1 (queue active)
May 26 12:27:08 [postfix/smtp] ...: to=<adresse@gmx.de>, relay=smtp.relayhost.de[...]:25, delay=3.1, delays=2.3/0.04/0.42/0.38, dsn=2.0.0, status=sent (250 Message ... accepted by anderer_relayhost.de)


Aber ich kann keine E-Mails empfangen – es passiert einfach gar nichts, wenn ich eine E-Mail an den Server schicke. Es steht auch nichts in einem Log.

Sorry für die wahrscheinlich blöde Frage, aber das ist mein erster Mailserver ;-) Muss ich irgendwie lokale User auf virtuelle mappen? Bzw. wie funktioniert überhaupt der Versand von einer virtuellen Adresse aus?

Für Hilfe wäre ich sehr dankbar!
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2109
Location: Konradsreuth (Germany)

PostPosted: Sat May 26, 2012 5:03 pm    Post subject: Reply with quote

Okay, selbst draufgekommen … man muss einfach _beide_ Zeilen in master.cf schreiben …

Dann beschwert sich zwar postmap, dass der Eintrag „smtp“ doppelt da wäre (deswegen habe ich eine Zeile auskommentiert!), aber es geht dann in beide Richtungen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum