Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
having trouble with perl-5.18.2 and perl-cleaner [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 729
Location: Alaska

PostPosted: Wed Apr 02, 2014 5:27 am    Post subject: having trouble with perl-5.18.2 and perl-cleaner [SOLVED] Reply with quote

I tried running depclean and it error-ed out with some perl package conflicts.. perl-ExtUtils-Command requiring perl-5.16. I uninstalled that thinking if I could get past the error, I could then reinstall it. But there was then another conflicting package. I assume I would be going through most of them. So next step was to try perl-cleaner - same type of fail there. (using perl-cleaner --all).

So I masked perl-5.18.2 and I get this error:
Code:
Calculating dependencies... done!
[ebuild     UD ] dev-lang/perl-5.16.3:0/5.16 [5.18.2:0/5.18] USE="berkdb gdbm -debug -doc -ithreads" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3:0/5.16::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-MIME-Base64-3.140.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                             
    (and 2 more with the same problem)

  (dev-lang/perl-5.18.2:0/5.18::gentoo, installed) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-IO-1.280.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SSLeay-1.558:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 8 more with the same problems)


I am running unstable.

Anyone offer advice how to get out of this tail-spin? thanks in advance, JD

[Edit] Hold on, I uninstalled some of the perl things and maybe I got it lined out. I'll mark SOLVED if so.
Back to top
View user's profile Send private message
schrdlu
n00b
n00b


Joined: 01 Nov 2009
Posts: 55
Location: Adelaide Sth Australia

PostPosted: Thu Apr 10, 2014 7:33 am    Post subject: Reply with quote

I had a similar prob rebuilding a dorked amd64 singlecore unit & got around the hassle by rebuilding the listed packages at the bottom of the list. Having completed these I ran perl-cleaner,which went ahead as per the book.
My next hassle is on my dualcore unit update,which doesn't give me a list of packages,just the list of conflicts,Ah well if life was easy I'd probably be dead .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum