Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-0.9.7.8->
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Sun Jan 05, 2014 7:24 pm    Post subject: Reply with quote

I don't use the gnome flag. I kept getting an error that said it couldn't find theme.h in a /metacity-1/private directory.

Code:
x11-wm/compiz
     Available versions: 
     (0.9)  [m](~)0.9.8.6
     (0)    (**)9999{tbz2}[1]
       {+cairo dbus debug fuse gnome gtk kde +svg test}
     Installed versions:  9999{tbz2}[1](02:19:01 AM 01/05/2014)(cairo dbus fuse gtk svg -debug -gnome -kde -test)


Code:
In file included from /var/tmp/portage/x11-wm/compiz-9999/work/compiz/gtk/window-decorator/gwd-metacity-window-decoration-util.c:22:0:
/var/tmp/portage/x11-wm/compiz-9999/work/compiz/gtk/window-decorator/gwd-metacity-window-decoration-util.h:24:47: fatal error: metacity-1/metacity-private/theme.h: No such file or directory
 #include <metacity-1/metacity-private/theme.h>


The metacity installation did install that file and compiz then installed no problem. :)
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Sun Jan 05, 2014 10:32 pm    Post subject: Reply with quote

I was able to upgrade to the 9999.ebuild after eselcting python-2.7 then emerging metacity (even though I run xfce4) buty I cant figure out now how to get fusion-icon support and a window manager. the old setup used emerald and fusion-icon to start compiz. Anyone using this with xfce4 and have it working correctly?
Back to top
View user's profile Send private message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Sun Jan 05, 2014 11:11 pm    Post subject: Reply with quote

The fusion icon has been dropped in these later versions.
For the window manager you need to use emerald 0.9.5, hedmo has it at his github site. The older emerald will segfault with 0.9.x versions.
Here are the pertinent entries in my .xinitrc file:

emerald --replace &
exec compiz --replace
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Mon Jan 06, 2014 12:21 pm    Post subject: Reply with quote

not compiling... i had to change a few things in the ebuild to get it to make it past the configure stage but then it fails undefined reference to symbol 'exp@@GLIBC_2.2.5' i think for me it would best to back track to the old compiz, it was all working on these to boxes just fine.
Back to top
View user's profile Send private message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Mon Jan 06, 2014 9:12 pm    Post subject: Reply with quote

If you decide to continue, see my post 1/3 of the way down page 3 of this thread, posting 7213936 (I don't know how to link to it)
It refers to this as well: http://bugs.funtoo.org/browse/FL-310
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Tue Jan 07, 2014 12:31 pm    Post subject: Reply with quote

well without a working window manager i am not sure and i am too busy at work right now. i am trying to figure it out on a laptop that had all this working fine with the old compiz-8.* in portage. but so far the only thing that builds is the 9999 version from git. the overlay that oleg suggested from desktop-effects fails too, emerald is another problem. i'll keep keep messing with it as i have time. thanks for the links.
Back to top
View user's profile Send private message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Tue Jan 07, 2014 8:43 pm    Post subject: Reply with quote

Sure. You gotta have emerald or to me there is no point in having compiz. I think actually compiz is a desktop manager (or can be, that's what I use it for) and emerald is a window decorator. I dunno, all confuses me.
As that previous post indicates, I also had trouble with the emerald installation. Don't be fooled by my comments on the bug about my HD, I was just tired of fielding comments and went along with the program. The bug was, is and shall be valid. It's the emerald code that doesn't comply with some newer methods, but it can be overcome. As a result of that bug I killed Xchat :) Or maybe it was a follow-up bug with same issues, I forget. Yeah, it was no longer maintained, so the gentoo devs decided it should go, as the Hexchat port of it was maintained and didn't have the problem.
So that was why I documented all of this stuff, for myself as much for others, so I wouldn't forget how to do it.
I encourage you to give it the good fight as the new stuff is a vast improvement over 0.8.8. Faster, smoother, less buggy. Just plain cooler. I have it on ~86 and ~amd64 here, so it can be done.
It would be good to report your results with Oleg's ebuild http://bugs.funtoo.org/browse/FL-951
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Wed Jan 08, 2014 12:12 pm    Post subject: Reply with quote

ok yuyuyak its all working now. it was the ldflags preventing it from compiling and the builds use flag-o-matic so it is possible to edit the ebuild directly and add to an overlay so it can be re-compiled without tinkering from the cli. there is development still ongoing with emerald and more recent git code is out there but i can not source and ebuild already available but i will keep lookin. oh and i havent tried olegs ebuild yet that is from the desktop-effects overlay, you can get it by using layman and then layman -a desktop-effects will sync it for you. i think though you will still need to unmask that version with ** in keywords

EDIT: https://gitorious.org/emerald-overlays/pages/Home this is what i saw on the web.... this is all wrong, this is just an overlay named emerald. has nothing unfortunately to do with the wm.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Sun Jan 12, 2014 8:39 am    Post subject: Reply with quote

rommel wrote:
it was the ldflags preventing it from compiling and the builds use flag-o-matic so it is possible to edit the ebuild directly and add to an overlay so it can be re-compiled without tinkering from the cli.


rommel

how did you fix the ebuild? i re-compiled emerald yesterday and had the same problem as you.i tryed to put flag-o-matic at the end of the inherit line
but no go.

regards hedmo
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Sun Jan 12, 2014 7:43 pm    Post subject: Reply with quote

here is the whole ebuild , but i only did what you already stated you tried. so i added flag-o-omatic then added the append-ldflag line under src_prepare

Code:
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-wm/emerald/emerald-0.8.4-r2.ebuild,v 1.4 2011/09/14 20:47:24 ssuominen Exp $

EAPI="3"

inherit autotools flag-o-matic
#eutils

THEMES_RELEASE=0.5.2

DESCRIPTION="Emerald Window Decorator"
HOMEPAGE="http://www.compiz.org/"
SRC_URI="https://github.com/hedmo/emerald/emerald-0.9.5.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""

# NOTE: emerald-0.9.5 can not bee downloaden as it chould.
RESTRICT="fetch strip"


PDEPEND="~x11-themes/emerald-themes-${THEMES_RELEASE}"

RDEPEND="
        >=x11-libs/gtk+-2.8.0:2
        >=x11-libs/libwnck-2.30.7
        >=x11-wm/compiz-${PV}
"

DEPEND="${RDEPEND}
        >=dev-util/intltool-0.35
        >=dev-util/pkgconf-0.19
        >=sys-devel/gettext-0.15
"



 pkg_nofetch() {
        echo
        eerror "Please go to: http://cgit.compiz.org/fusion/decorators/emerald/"
        eerror
        eerror "and download the emerald-0.9.5.tar.gz"
        eerror " package for you"
        eerror "After downloading it, put the .tar.gz into:"
        eerror " ${DISTDIR}"
        echo
}


 src_prepare() {
          intltoolize --automake --copy --force || die
           eautoreconf || die "eautoreconf failed"
          #Secure linking needed
          append-ldflags -Wl,-lm,-ldl
   }
   
   src_configure() {
           econf --disable-mime-update || die "econf failed"
   }
   
   src_install() {
           emake DESTDIR="${D}" install || die "emake install failed"
   }
 
   pkg_postinst() {
           ewarn "DO NOT report bugs to Gentoo's bugzilla"
           einfo "Please DO NOT report bugs at ALL"
         einfo "This is a home made ebuild"
           einfo "Thank you on behalf of Hedmo"
   }
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Tue Jan 14, 2014 5:07 pm    Post subject: Reply with quote

rommel wrote:
here is the whole ebuild , but i only did what you already stated you tried. so i added flag-o-omatic then added the append-ldflag line under src_prepare



thanks!!! i have updated my git now

regards hedmo
Back to top
View user's profile Send private message
kanyck
n00b
n00b


Joined: 06 Jan 2013
Posts: 15
Location: St.Petersburg, Russia

PostPosted: Tue Feb 25, 2014 12:17 pm    Post subject: Reply with quote

Hi guys,
Having read all this stuff, I'm lost a little bit...
Do I understand correctly that:
- 0.9.9 and later works fine without issues that kept me on 0.8.8 last time I tried to upgrade (Dbus-related crashes, window positioning & wallpapers not working)
- 0.9.10 and 0.9.11 would need metacity installed to build?

UPD: looked into ebuilds - there is metacity dependency indeed. Looks wierd, but...

BTW, is there any reason to use 0.9.11, because
Quote:
Bugs targeted: 151 New, 15 Incomplete, 5 Invalid, 66 Confirmed, 134 Triaged, 28 In Progress, 22 Fix Committed, 1 Fix Released


0.9.10.0 looks less buggy (at least according to bugtracker). Is it any better than 0.9.9? And what about 0.9.10.2 and 0.9.10.3? Looks like some more bugs are fixed there but not merged upstream?

Any suggestions? Issues?
Back to top
View user's profile Send private message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Sun Mar 02, 2014 12:28 am    Post subject: Reply with quote

Hi Kanyck.
I don't use dbus plugin in compiz if that's what you mean, so can't say. Wallpapers kinda work, but not right. Improved over 9.9, but still not right. Window positioning works fine for me, I have presets that resize and reposition windows if that's what you mean. I have issues resizing windows manually but I don't think it's compiz, it began when I had 9.9 but had been working properly for months before. I think it's my nvidia-drivers/mesa/emerald theme, something in there. Lots of "glass", if I switch to a less fancy theme it goes away. The metacity dependency began somewhere in the late 9.9 versions, just install it, it's small enough and never gets loaded. I think probably I could uninstall after compiz gets installed, haven't tried it.
Yeah, I saw that about the bugs too. I've used 9.9, 9.10 and now 9.11. I don't see any more problems with 9.11 than with the other 2. Obviously there are, as evidenced at launchpad, must be things I don't use. Some of the plugins that were missing in 9.9 came back in 9.10 and still more in 9.11. I think the wallpapers were missing in 9.10, when 9.11 had them I was excited, but not usable for me. All of the 9.x series work far superior to the ancient 8.8 to me, as Spilsbury et. al rewrote them in C (was python). Faster, smoother.
Hope that helps, won't hurt to try it.
Here's compiz stuff excerpted from my .xsession-errors:
Code:
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
compizconfig - Error: error occurred during scandir: No such file or directory
compiz (core) - Info: Loading plugin: composite
** Message: Found lang C
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: opengl
compiz (core) - Info: Starting plugin: opengl
Compiz (opengl) - Info: GLX_EXT_buffer_age is supported
compiz (core) - Info: Loading plugin: imgjpeg
compiz (core) - Info: Starting plugin: imgjpeg
compiz (core) - Info: Loading plugin: decor
compiz (core) - Info: Starting plugin: decor
compiz (core) - Info: Loading plugin: copytex
compiz (core) - Info: Starting plugin: copytex
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Info: Loading plugin: commands
compiz (core) - Info: Starting plugin: commands
compiz (core) - Info: Loading plugin: vpswitch
compiz (core) - Info: Starting plugin: vpswitch
compiz (core) - Info: Loading plugin: titleinfo
compiz (core) - Info: Starting plugin: titleinfo
compiz (core) - Info: Loading plugin: shelf
compiz (core) - Info: Starting plugin: shelf
compiz (core) - Info: Loading plugin: screenshot
compiz (core) - Info: Starting plugin: screenshot
compiz (core) - Info: Loading plugin: resize
compiz (core) - Info: Starting plugin: resize
compiz (core) - Info: Loading plugin: regex
compiz (core) - Info: Starting plugin: regex
compiz (core) - Info: Loading plugin: put
compiz (core) - Info: Starting plugin: put
compiz (core) - Info: Loading plugin: place
compiz (core) - Info: Starting plugin: place
compiz (core) - Info: Loading plugin: obs
compiz (core) - Info: Starting plugin: obs
compiz (core) - Info: Loading plugin: move
compiz (core) - Info: Starting plugin: move
compiz (core) - Info: Loading plugin: mousepoll
compiz (core) - Info: Starting plugin: mousepoll
compiz (core) - Info: Loading plugin: imgpng
compiz (core) - Info: Starting plugin: imgpng
compiz (core) - Info: Loading plugin: grid
compiz (core) - Info: Starting plugin: grid
compiz (core) - Info: Loading plugin: fadedesktop
compiz (core) - Info: Starting plugin: fadedesktop
compiz (core) - Info: Loading plugin: ezoom
compiz (core) - Info: Starting plugin: ezoom
compiz (core) - Info: Loading plugin: extrawm
compiz (core) - Info: Starting plugin: extrawm
compiz (core) - Info: Loading plugin: animation
compiz (core) - Info: Starting plugin: animation
compiz (core) - Info: Loading plugin: notification
compiz (core) - Info: Starting plugin: notification
compiz (core) - Info: Loading plugin: wobbly
compiz (core) - Info: Starting plugin: wobbly
compiz (core) - Info: Loading plugin: winrules
compiz (core) - Info: Starting plugin: winrules
compiz (core) - Info: Loading plugin: fade
no daemon yet
compiz (core) - Info: Starting plugin: fade
compiz (core) - Info: Loading plugin: cube
compiz (core) - Info: Starting plugin: cube
compiz (core) - Info: Loading plugin: wizard
compiz (core) - Info: Starting plugin: wizard
compiz (core) - Info: Loading plugin: trailfocus
compiz (core) - Info: Starting plugin: trailfocus
compiz (core) - Info: Loading plugin: switcher
compiz (core) - Info: Starting plugin: switcher
compiz (core) - Info: Loading plugin: scale
compiz (core) - Info: Starting plugin: scale
compiz (core) - Info: Loading plugin: rotate
compiz (core) - Info: Starting plugin: rotate
compiz (core) - Info: Loading plugin: opacify
compiz (core) - Info: Starting plugin: opacify
compiz (core) - Info: Loading plugin: cubeaddon
compiz (core) - Info: Starting plugin: cubeaddon
compiz (core) - Info: Loading plugin: bench
compiz (core) - Info: Starting plugin: bench
compiz (decor) - Warn: No default decoration found, placement will not be correct
Back to top
View user's profile Send private message
kanyck
n00b
n00b


Joined: 06 Jan 2013
Posts: 15
Location: St.Petersburg, Russia

PostPosted: Sun Mar 02, 2014 9:06 am    Post subject: Reply with quote

Hi yuyuyak,

Thank you for your opinion. Meanwhile I've installed it to try. Now on 0.9.10. Dbus seem to work -- at least nothing crashes))) I don't use it much after all.
Window placement works without special efforts. However I noticed a strange thing -- when I open Libreoffice at full screen, I can't do anything with the window - neither right click on window decorations nor buttons work - but if I shrink it using Alt/F5, it starts to work as expected. Probably I should upgrade emerald to 0.6.0...
Metacity pulls something else with it but I'm afraid it's inevitable now. Most probably one may remove it after compiz is installed but it will break future upgrades, if any. Have to be properly masked then.
Another thing I noticed than it seem to set different (wrong?) DPI -- fonts became somewhat smaller and colored halos appeared on some letters. Will investigate this.
Back to top
View user's profile Send private message
yuyuyak
n00b
n00b


Joined: 23 Nov 2012
Posts: 33
Location: United States

PostPosted: Mon Mar 03, 2014 5:26 am    Post subject: Reply with quote

Quote:
Window placement works without special efforts. However I noticed a strange thing -- when I open Libreoffice at full screen, I can't do anything with the window - neither right click on window decorations nor buttons work - but if I shrink it using Alt/F5, it starts to work as expected. Probably I should upgrade emerald to 0.6.0...

I just tried Libreoffice (I assume you mean Writer), none of the problems you mention, so it's probably something else. BTW, the emerald that works with all the 0.9.x versions is emerald-0.9.5. Rommel posted a handy working ebuild above. 0.8.8 will simply fail.
There are alot of bugs in various gtk themes and I think most emerald themes are just converted gtk themes (could be wrong). The fellow that does spacefm goes on about it at length.
Quote:
Another thing I noticed than it seem to set different (wrong?) DPI -- fonts became somewhat smaller and colored halos appeared on some letters. Will investigate this.

Again, don't see anything like that, but should be simple to fix, at least the DPI. Tweaking compiz is 1/2 the fun :P
I think it may be possible to modify the ebuild to get rid of the metacity dependency. Was going to try that today, but took hours to remember: on my 32 bit machine, gotta use -gtk or it fails configure. Don't know why, same ebuild does fine on amd64. wnck_window_has_name - not found. It's something to do with the ebuild, cmake-utils it appears, because I can configure it directly in a directory no problem. Well, no biggie, I use emerald anyhow.

edit: Hmm, you don't have Intel graphics do you? I have cheapy eee with Intel gm945 and I have had colored halos in some places for months now. Buttons, and weird places, some icons, not others, even a small rectangle on the upper window decoration. It's a backup, experiment machine for me, so I don't get too concerned. Yes, it does compiz just fine 8)
Back to top
View user's profile Send private message
kanyck
n00b
n00b


Joined: 06 Jan 2013
Posts: 15
Location: St.Petersburg, Russia

PostPosted: Mon Mar 03, 2014 7:19 am    Post subject: Reply with quote

I'm not 100% sure, but it looks like Libreoffice issue appeared as of I upgraded compiz. UPD: checked firefox. Behaves the same if started fullscreen.
As for emerald, I mislead you, sorry for that. I meant emerald-themes, of course. Probably themes should be upgraded, too.

With DPI I've had the mess after I brought the working system from my notebook to desktop -- and just forgot to change the values there. Brushed it all up yesterday and it seems to work correctly now.

I'm on radeon graphics. I digged into it a little bit -- it looks like it's proprietary driver to blame. I noticed the same behavior with all thin lines drawn on the screen, not only fonts. Looking forward to open driver to add usable opencl...

And on 64bit -- can't suggest anything but what you're saying surely looks like a ebuild bug.
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 840
Location: halmstad

PostPosted: Tue Mar 04, 2014 5:58 pm    Post subject: Reply with quote

kanyck wrote:

I'm on radeon graphics. I digged into it a little bit -- it looks like it's proprietary driver to blame. I noticed the same behavior with all thin lines drawn on the screen, not only fonts. Looking forward to open driver to add usable opencl...



kanyck

i am using the proprietary driver and do not have any problems,Dbus does not crash,i have no metacity dependency:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] gnome-base/gsettings-desktop-schemas-3.10.1 USE="-introspection" 458 kB
[ebuild N ] gnome-base/libgtop-2.28.5:2 USE="-debug -introspection" 640 kB
[ebuild R #] x11-wm/compiz-9999::hedmo USE="cairo dbus svg -debug -fuse -gnome -gtk -kde {-test}" 0 kB
[ebuild N ] x11-wm/metacity-2.34.13 USE="xinerama {-test}" 1,622 kB

Total: 4 packages (3 new, 1 reinstall), Size of downloads: 2,718 kB

Would you like to merge these packages? [Yes/No] n


Quitting.

mybox hedmo #

and i am reinstalling compiz every time i am updating kde-9999(quite often).
my DE is kde but that flag do not work.my "compiz standalone" is:

xinitrc=

#!/bin/sh
exec
compiz --replace --sm-disable ccp &
emerald --replace &
cairo-dock&
pcmanfm --desktop &
lxpanel

the only problem i have found is 3D Windows.can not get it to work on 3xscreens and i do miss animation add-ons.

regards hedmo
Back to top
View user's profile Send private message
kanyck
n00b
n00b


Joined: 06 Jan 2013
Posts: 15
Location: St.Petersburg, Russia

PostPosted: Wed Mar 12, 2014 9:02 am    Post subject: Reply with quote

Hi hedmo!

I'm on standalone compiz (no DE) and my use flags are +gtk -gnome -- so my use case differs from yours.
Looking into the ebuild - it implicitly pulls metacity only if gnome use flag is set, but compiz fails to build without it -- there were posts hereabove about this issue, and I have it, too.

Plus I still have this weird issue with fullscreen apps - reinstalling the themes did not help, against my hope... and it looks like a theme issue... maybe will try another theme to be sure.
Besides this, compiz 0.9 runs smooth. I also wonder how can I install, say, 0.9.10.2, not 0.9.10.0? There are some bugs fixed there, but I could not find a way to install a minor release, other than x.x.0 - there seems to be no tarballs available. What does "fix committed" really mean? Where can I grab it? Shall I patch it myself somehow?
Or maybe go your way and install -9999 from your repo. Looks like it works fine for many people in spite of multiple bug reports on the tracker.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum