Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why latest stage3 only has Python 3.2? Why???
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
sgao
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 133

PostPosted: Thu Dec 27, 2012 10:11 pm    Post subject: Why latest stage3 only has Python 3.2? Why??? Reply with quote

Pulling down the latest minimal installation iso and stage3 package to install a new box. By a big surprise, I found only Python 3.2 was included in the stage 3 image.

This has caused endless problems to my installation. Never saw such messy installation process before. Bump into segfault, internal error almost at every turn. libxml2, pyqt4, pykde4, you named. Python 3.2 is not compatible with many KDE 4 packages. Why the hell dropping Python 2.x and only including Python 3.x before Python 3.x works with all packages? Even switching back to Python 2.7 and set only uses 2.7, things still fail here and there.

Anyone else experienced this mess?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7938
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu Dec 27, 2012 11:15 pm    Post subject: Reply with quote

Well, no, but, after installing any new version of Python, you should run python-updater. Did you do that?

That's app-admin/python-updater, if you haven't already installed it. :wink:

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Fri Dec 28, 2012 10:58 am    Post subject: Reply with quote

That sounds strange, PYTHON_TARGETS use expand should take care of that IIRC and pull in 2.7.
Do what John suggested, that could help, although it would be strange on a fresh stage3.
Just a few days ago I downloaded and installed stage3-amd64-20121210.tar.bz2 without any trouble,
and python2 got pulled in by some package, no trouble since.
Back to top
View user's profile Send private message
sgao
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 133

PostPosted: Sat Dec 29, 2012 4:57 pm    Post subject: Reply with quote

Python 2.7 is pulled in when installing some package that depends on Python 2.x.

Tried python-updater. It failed rebuilding boost.

How stable Python 3.2 is?
Back to top
View user's profile Send private message
smartass
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 189
Location: right behind you ... (you did turn around, didn't you?)

PostPosted: Sat Dec 29, 2012 7:26 pm    Post subject: Reply with quote

python 3.2 is considered production quality, just some libs haven't been ported to 3 yet.

But giving up and accepting 3 as the only solution to your problem is not a good idea IMHO, because you could have something much uglier going on in your system, the fact that boost wouldn't compile is a warning signal.
I suggest this if you haven't tried yet:

  • check the control sum of the stage you downloaded and unpacked if you haven't deleted it yet ... chances (though thin) are you have a damaged stage
  • try revdep-rebuild, emerge -NDu world, emerge -e system (remeber to use -a or -p and check the output before actually running the merge)... maybe your buildsystem is inconsistent


It's hard to tell what exactly is the problem in your case at this moment, but it's starting to sound like something beyond just python.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum