Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no puedo instalar nada...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
botdotcom
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2012
Posts: 100
Location: where no GTK

PostPosted: Sun May 13, 2012 7:57 pm    Post subject: no puedo instalar nada... Reply with quote

Code:
# emerge razorqt
!!! It seems that /proc is not mounted. You have been warned.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] app-text/poppler-data-0.4.4
[ebuild  N     ] app-arch/cpio-2.11  USE="nls"
[ebuild  N     ] media-libs/freetype-2.4.9-r1  USE="bzip2 -X -auto-hinter -bindist -debug -doc -fontforge -static-libs -utils"
[ebuild  N     ] media-libs/libpng-1.5.10  USE="-apng (-neon) -static-libs"
[ebuild  N     ] app-text/libpaper-1.1.24-r1
[ebuild  N     ] media-libs/tiff-4.0.1-r1  USE="cxx zlib -jbig -jpeg -lzma -static-libs"
[ebuild  N     ] media-libs/lcms-1.19  USE="zlib -jpeg -python -static-libs -tiff"
[ebuild  N     ] app-arch/rpm2targz-9.0.0.4g
[ebuild  N     ] dev-libs/libgpg-error-1.10  USE="nls -common-lisp -static-libs"
[ebuild  N     ] dev-lang/nasm-2.10  USE="-doc"
[ebuild  N     ] perl-core/version-0.940.0
[ebuild  N     ] perl-core/Test-Harness-3.230.0
[ebuild  N     ] virtual/perl-Archive-Tar-1.54
[ebuild  N     ] perl-core/ExtUtils-CBuilder-0.27.03
[ebuild  N     ] perl-core/Perl-OSType-1.2.0  USE="-test"
[ebuild  N     ] perl-core/JSON-PP-2.272.0
[ebuild  N     ] perl-core/CPAN-Meta-YAML-0.4.0
[ebuild  N     ] perl-core/File-Spec-3.31
[ebuild  N     ] perl-core/ExtUtils-Manifest-1.580.0
[ebuild  N     ] perl-core/ExtUtils-Install-1.54
[ebuild  N     ] perl-core/ExtUtils-Command-1.170.0
[ebuild  N     ] perl-core/Test-Simple-0.980.0
[ebuild  N     ] perl-core/IO-1.25
[ebuild  N     ] virtual/perl-File-Temp-0.220.0-r1
[ebuild  N     ] sys-devel/bison-2.4.3  USE="nls -static"
[ebuild  N     ] x11-proto/xproto-7.0.22  USE="-doc"
[ebuild  N     ] x11-proto/xextproto-7.2.0  USE="-doc"
[ebuild  N     ] x11-libs/qt-core-4.7.4-r1  USE="exceptions glib iconv jit ssl (-aqua) -debug -optimized-qmake -pch -private-headers -qt3support"
[ebuild  N     ] x11-libs/xtrans-1.2.6  USE="-doc"
[ebuild  NS    ] dev-lang/python-2.7.2-r3 [3.2.2] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst"
[ebuild  N     ] virtual/perl-version-0.940.0
[ebuild  N     ] x11-proto/inputproto-2.0.2
[ebuild  N     ] x11-proto/renderproto-0.11.1
[ebuild  N     ] media-fonts/font-util-1.2.0
[ebuild  N     ] x11-misc/util-macros-1.17
[ebuild  N     ] virtual/perl-File-Spec-3.31
[ebuild  N     ] x11-proto/kbproto-1.0.5
[ebuild  N     ] virtual/perl-ExtUtils-CBuilder-0.27.03
[ebuild  N     ] virtual/perl-JSON-PP-2.272.0
[ebuild  N     ] virtual/perl-CPAN-Meta-YAML-0.4.0
[ebuild  N     ] x11-proto/xineramaproto-1.2.1
[ebuild  N     ] dev-util/desktop-file-utils-0.20-r1  USE="-emacs"
[ebuild  N     ] x11-proto/damageproto-1.2.1
[ebuild  N     ] x11-proto/compositeproto-0.4.2
[ebuild  N     ] sys-apps/dbus-1.4.20  USE="-X -debug -doc (-selinux) -static-libs -test"
[ebuild  N     ] x11-proto/fontsproto-2.1.1  USE="-doc"
[ebuild  N     ] x11-proto/randrproto-1.3.2
[ebuild  N     ] app-arch/libarchive-3.0.3  USE="acl bzip2 e2fsprogs iconv lzma zlib -expat -nettle -static-libs -xattr"
[ebuild  N     ] x11-proto/xf86bigfontproto-1.2.0
[ebuild  N     ] dev-libs/libpthread-stubs-0.3  USE="-static-libs"
[ebuild  N     ] dev-libs/libgcrypt-1.4.6  USE="-static-libs"
[ebuild  N     ] media-libs/libjpeg-turbo-1.2.0-r1  USE="-java -static-libs"
[ebuild  N     ] virtual/perl-Test-Harness-3.230.0-r2
[ebuild  N     ] virtual/perl-Perl-OSType-1.2.0
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.580.0-r1
[ebuild  N     ] virtual/perl-ExtUtils-Install-1.54
[ebuild  N     ] virtual/perl-ExtUtils-Command-1.170.0-r2
[ebuild  N     ] virtual/perl-Test-Simple-0.980.0-r1
[ebuild  N     ] virtual/perl-IO-1.25
[ebuild  N     ] x11-proto/xf86vidmodeproto-2.3.1
[ebuild  N     ] dev-util/gtk-doc-am-1.18
[ebuild  N     ] virtual/yacc-0
[ebuild  N     ] virtual/jpeg-0  USE="-static-libs"
[ebuild  N     ] dev-util/cmake-2.8.7-r5  USE="ncurses -emacs -qt4 -test -vim-syntax"
[ebuild  N     ] x11-libs/qt-script-4.7.4  USE="exceptions iconv jit (-aqua) -debug -pch -private-headers"
[ebuild  N     ] x11-libs/libICE-1.0.7  USE="ipv6 -doc -static-libs"
[ebuild  N     ] x11-libs/qt-dbus-4.7.4  USE="exceptions (-aqua) -debug -pch"
[ebuild  N     ] x11-libs/libfontenc-1.1.0  USE="-static-libs"
[ebuild  N     ] x11-proto/fixesproto-5.0
[ebuild  N     ] dev-libs/libxslt-1.1.26-r3  USE="crypt -debug -python -static-libs"
[ebuild  N     ] x11-proto/xcb-proto-1.6-r2
[ebuild  N     ] x11-libs/libXdmcp-1.1.0  USE="-doc -static-libs"
[ebuild  N     ] x11-libs/libXau-1.0.6  USE="-static-libs"
[ebuild  N     ] perl-core/ExtUtils-ParseXS-2.22.05
[ebuild  N     ] perl-core/Module-Metadata-1.0.6
[ebuild  N     ] perl-core/Parse-CPAN-Meta-1.440.100
[ebuild  N     ] perl-core/Version-Requirements-0.101.20
[ebuild  N     ] dev-python/pyxdg-0.19
[ebuild  N     ] x11-libs/pixman-0.24.0  USE="(-altivec) (-iwmmxt) -mmx (-neon) -sse2 -static-libs"
[ebuild  N     ] virtual/perl-Parse-CPAN-Meta-1.440.100-r2
[ebuild  N     ] x11-libs/libSM-1.2.0  USE="ipv6 uuid -doc -static-libs"
[ebuild  N     ] x11-libs/libXfont-1.4.4  USE="ipv6 -doc -static-libs"
[ebuild  N     ] x11-libs/libxcb-1.7  USE="-doc (-selinux) -static-libs"
[ebuild  N     ] virtual/perl-ExtUtils-ParseXS-2.22.05
[ebuild  N     ] virtual/perl-Module-Metadata-1.0.6
[ebuild  N     ] virtual/perl-Version-Requirements-0.101.20-r2
[ebuild  N     ] x11-libs/libX11-1.4.4  USE="ipv6 -doc -static-libs -test"
[ebuild  N     ] x11-libs/libXext-1.3.0  USE="-doc -static-libs"
[ebuild  N     ] x11-libs/libXrender-0.9.6  USE="-static-libs"
[ebuild  N     ] x11-libs/libXfixes-5.0  USE="-static-libs"
[ebuild  N     ] x11-libs/libXt-1.1.1  USE="-static-libs"
[ebuild  N     ] x11-apps/xprop-1.2.1
[ebuild  N     ] x11-libs/libXcursor-1.1.12  USE="-static-libs"
[ebuild  N     ] x11-libs/libXrandr-1.3.2  USE="-static-libs"
[ebuild  N     ] x11-libs/libXcomposite-0.4.3-r1  USE="-doc -static-libs"
[ebuild  N     ] x11-libs/libXdamage-1.1.3  USE="-static-libs"
[ebuild  N     ] x11-libs/libXmu-1.1.0  USE="ipv6 -doc -static-libs"
[ebuild  N     ] x11-libs/libXi-1.4.3-r1  USE="-doc -static-libs"
[ebuild  N     ] x11-libs/libXinerama-1.1.1  USE="-static-libs"
[ebuild  N     ] x11-apps/xset-1.2.2
[ebuild  N     ] media-libs/fontconfig-2.8.0-r1  USE="-doc"
[ebuild  N     ] app-admin/eselect-fontconfig-1.1
[ebuild  N     ] media-fonts/dejavu-2.33  USE="-X -fontforge"
[ebuild  N     ] virtual/ttf-fonts-1
[ebuild  N     ] x11-libs/libXft-2.2.0  USE="-static-libs"
[ebuild  N     ] app-text/poppler-0.18.4-r1  USE="cxx introspection lcms utils xpdf-headers -cairo -cjk -curl -debug -doc -jpeg -jpeg2k -png -qt4 -tiff"
[ebuild  N     ] media-fonts/urw-fonts-2.4.9  USE="-X"
[ebuild  N     ] x11-libs/cairo-1.10.2-r2  USE="X glib svg (-aqua) -debug -directfb -doc (-drm) (-gallium) -opengl (-openvg) (-qt4) -static-libs -xcb"
[ebuild  N     ] dev-libs/gobject-introspection-1.30.0-r2  USE="-doc -test"
[ebuild  N     ] x11-libs/pango-1.29.4  USE="X introspection -debug -doc -test"
[ebuild  N     ] x11-wm/openbox-3.5.0-r1  USE="nls session -debug -imlib -startup-notification -static-libs"
[ebuild  N     ] net-print/cups-1.4.8-r1  USE="acl filters jpeg pam png ssl threads tiff -X -dbus -debug -gnutls -java -kerberos -ldap -perl -php -python -slp -static-libs -xinetd" LINGUAS="-da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW"
[ebuild  N     ] app-text/ghostscript-gpl-9.04-r4  USE="cups -X -bindist -dbus -djvu -gtk -idn -jpeg2k -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW"
[ebuild  N     ] net-print/foomatic-filters-4.0.15  USE="cups -dbus"
[ebuild  N     ] x11-libs/qt-gui-4.7.4-r1  USE="accessibility cups exceptions glib (-aqua) -dbus -debug -egl -gtkstyle -mng -nas -nis -pch -private-headers -qt3support -raster -tiff -trace -xinerama"
[ebuild  N     ] perl-core/ExtUtils-MakeMaker-6.620.0
[ebuild  N     ] virtual/perl-ExtUtils-MakeMaker-6.620.0
[ebuild  N     ] perl-core/CPAN-Meta-2.112.621
[ebuild  N     ] virtual/perl-CPAN-Meta-2.112.621
[ebuild  N     ] perl-core/Module-Build-0.380.0
[ebuild  N     ] virtual/perl-Module-Build-0.380.0-r2
[ebuild  N     ] dev-perl/File-BaseDir-0.30.0  USE="-test"
[ebuild  N     ] dev-perl/File-DesktopEntry-0.40.0  USE="-test"
[ebuild  N     ] dev-perl/File-MimeInfo-0.150.0  USE="-test"
[ebuild  N     ] x11-misc/xdg-utils-1.1.0_rc1_p20120319  USE="perl -doc"
[ebuild  N    ~] x11-wm/razorqt-0.4.1-r2  USE="-doc -policykit"

The following keyword changes are necessary to proceed:
#required by razorqt (argument)
=x11-wm/razorqt-0.4.1-r2 ~x86

The following USE changes are necessary to proceed:
#required by x11-wm/openbox-3.5.0-r1, required by x11-wm/razorqt-0.4.1-r2, required by razorqt (argument)
=x11-libs/pango-1.29.4 X
#required by x11-libs/pango-1.29.4, required by x11-wm/openbox-3.5.0-r1, required by x11-wm/razorqt-0.4.1-r2, required by razorqt (argument)
=x11-libs/cairo-1.10.2-r2 X

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



eso es solo un ejemplo desde chroot,ahora imaginense sin X's ni navegaor ni nada...necesito ese WM y xorg-server pero igual sale q hay USEs q hay q cambiar y keywords cambios y autounmask...
_________________
http://images2.wikia.nocookie.net/__cb20070325035909/uncyclopedia/images/a/a3/Long-March.jpg
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Sun May 13, 2012 8:08 pm    Post subject: Reply with quote

Quote:
# emerge razorqt
!!! It seems that /proc is not mounted. You have been warned.

mount -t proc none ./proc/

Quote:
The following keyword changes are necessary to proceed:
#required by razorqt (argument)
=x11-wm/razorqt-0.4.1-r2 ~x86

echo "=x11-wm/razorqt ~x86" >> /etc/portage/package.keywords

Quote:
The following USE changes are necessary to proceed:
#required by x11-wm/openbox-3.5.0-r1, required by x11-wm/razorqt-0.4.1-r2, required by razorqt (argument)
=x11-libs/pango-1.29.4 X
#required by x11-libs/pango-1.29.4, required by x11-wm/openbox-3.5.0-r1, required by x11-wm/razorqt-0.4.1-r2, required by razorqt (argument)
=x11-libs/cairo-1.10.2-r2 X

echo "x11-libs/pango X" >> /etc/portage/package.use
echo "x11-libs/cairo X" >> /etc/portage/package.use

Aunque la USE X tal vez sea más interesante añadirla a /etc/make.conf El handbook puede parecerte extenso y aburrido, pero sirve para adquirir la base mínima que te permitirá entender como funciona gentoo y que debe de hacerse en caso de problemas al emerger paquetes.
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
botdotcom
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2012
Posts: 100
Location: where no GTK

PostPosted: Sun May 13, 2012 8:14 pm    Post subject: Reply with quote

eres un hacha! pero me sigue molestando este ~x86
Code:
The following keyword changes are necessary to proceed:
#required by razorqt (argument)
=x11-wm/razorqt-0.4.1-r2 ~x86


Code:
/etc/make.conf

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
VIDEO_CARDS="intel"
USE="qt"


_________________
http://images2.wikia.nocookie.net/__cb20070325035909/uncyclopedia/images/a/a3/Long-March.jpg
Back to top
View user's profile Send private message
agdg
Guru
Guru


Joined: 15 Aug 2010
Posts: 320

PostPosted: Sun May 13, 2012 10:53 pm    Post subject: Reply with quote

Al comando le sobra un =. El comando correcto es:
echo "x11-wm/razorqt ~x86" >> /etc/portage/package.keywords
_________________
make install . es
Noticias, apuntes y pequeños tutoriales sobre GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum