Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
introspection blocks[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 405
Location: Near /dev/urandom | /dev/null

PostPosted: Fri Jul 13, 2012 5:35 pm    Post subject: introspection blocks[SOLVED] Reply with quote

Hey all, I've just decided I'm jumping into ~amd64, so I've added a ACCEPT_KEYWORD="~amd64" to my make.conf, however, upon trying to update, I've found this blockage:
emerge --update --deep --ask world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ~] dev-libs/gobject-introspection-common-1.32.1
[ebuild U ] sys-kernel/linux-headers-3.4-r1 [3.1]
[ebuild U ] dev-lang/v8-3.10.8.20 [3.10.8.19]
[ebuild U ~] gnome-base/librsvg-2.36.1 [2.34.2]
[ebuild U ] www-client/chromium-20.0.1132.57 [20.0.1132.43]
[ebuild U ] virtual/jdk-1.6.0-r1 [1.6.0]
[ebuild U ] media-libs/libsdl-1.2.15-r2 [1.2.15]
[blocks B ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(dev-libs/gobject-introspection-1.30.0-r2::gentoo, installed) pulled in by
>=dev-libs/gobject-introspection-0.6.3 required by (media-libs/gstreamer-0.10.35::gentoo, installed)
>=dev-libs/gobject-introspection-0.6.2 required by (sys-auth/polkit-0.104-r1::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-0.1.18::gentoo, installed)
>=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gconf-2.32.4::gentoo, installed)
>=dev-libs/gobject-introspection-0.10.1 required by (x11-libs/gtk+-3.2.4-r1::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.36.1-r1::gentoo, installed)
dev-libs/gobject-introspection required by (sys-fs/udev-171-r6::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-gnome-2.36.1::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.30.1-r3::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.6.3-r300::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.6.3-r200::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.12 required by (x11-libs/libnotify-0.7.5::gentoo, installed)
>=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.2.0::gentoo, installed)
>=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-2.32.2.1-r2::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.12 required by (sys-apps/accountsservice-0.6.22::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r203::gentoo, installed)
>=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.35::gentoo, installed)
>=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.24.1-r1::gentoo, installed)
>=dev-libs/gobject-introspection-1.29 required by (dev-python/pygobject-3.0.4::gentoo, installed)
>=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.10-r1::gentoo, installed)
>=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
>=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.1::gentoo, ebuild scheduled for merge)
dev-libs/gobject-introspection required by (sys-power/upower-0.9.16::gentoo, installed)
>=dev-libs/gobject-introspection-1 required by (x11-misc/lightdm-1.2.2-r3::gentoo, installed)

(dev-libs/gobject-introspection-common-1.32.1::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/gobject-introspection-common required by (gnome-base/librsvg-2.36.1::gentoo, ebuild scheduled for merge)



Any ideas?
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.


Last edited by ZeuZ_NG on Sun Jul 15, 2012 7:33 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4658
Location: Saint Amant, Acadiana

PostPosted: Fri Jul 13, 2012 8:55 pm    Post subject: Reply with quote

Remove blocking package?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 405
Location: Near /dev/urandom | /dev/null

PostPosted: Sun Jul 15, 2012 4:13 am    Post subject: Reply with quote

Not that easy, as I tried updating poppler, wich went fine, and now I checked what depends on librsvg and I get packages that will break.
Code:

Ignition zeuz # equery depends librsvg
 * These packages depend on librsvg:
gnome-base/gdm-2.20.11-r1 (>=gnome-base/librsvg-1.1.1:2)
gnome-base/gnome-control-center-2.32.1-r1 (>=gnome-base/librsvg-2.0:2)
gnome-base/gnome-light-2.32.1-r2 (>=gnome-base/librsvg-2.32.1:2)
gnome-base/gnome-panel-2.32.1-r3 (gnome-base/librsvg:2)
media-video/vlc-2.0.1 (svg ? >=gnome-base/librsvg-2.9.0)
x11-misc/cairo-dock-3.0.0-r1 (gnome-base/librsvg:2)
x11-plugins/cairo-dock-plugins-3.0.0 (gnome-base/librsvg:2)
x11-themes/gnome-themes-standard-3.2.1 (gnome-base/librsvg:2)

_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Jul 15, 2012 4:50 am    Post subject: Reply with quote

Quote:
[blocks B ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)

Unmerge gobject-introspection.
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 405
Location: Near /dev/urandom | /dev/null

PostPosted: Sun Jul 15, 2012 7:34 am    Post subject: Reply with quote

That I did not for fixing the issue, but this:
Remove it from the world file;
correct my make.conf, because it was missing an 's' in ACCEPT_KEYWORDS...
Thanks for the help guys.
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum