Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem z adobe flash
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
dylon
Guru
Guru


Joined: 21 Mar 2005
Posts: 331
Location: Gliwice

PostPosted: Sat May 26, 2012 7:37 pm    Post subject: Problem z adobe flash Reply with quote

Witam.

Mam od jakiegoś czasu problem z flashem. Jeśli w ustawieniach flasha włączę "włącz przyśpieszanie sprzętowe", to psują mi się kolory na filmach tak, jakby było za dużo któregoś składowego koloru (najczęściej niebieskiego, co widać po twarzach ludzi).

Sprawdziłem kilka wersji adobe flash-a wstecz, ale problem nie zniknął, więc podejrzewam, że to może coś z xorgiem.

Poniżej zamieszczam wycinek xorg.conf - może komuś się rzuci w oczy jakiś nieodpowiedni wpis?
Code:

Section "Files"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/corefonts"
    FontPath        "/usr/share/fonts/cronyx"
    FontPath        "/usr/share/fonts/cyryllic"
    FontPath        "/usr/share/fonts/default"
    FontPath        "/usr/share/fonts/encodings"
    FontPath        "/usr/share/fonts/freefonts"
    FontPath        "/usr/share/fonts/intlfonts"
    FontPath        "/usr/share/fonts/sharefonts"
    FontPath        "/usr/share/fonts/terminus"
    FontPath        "/usr/share/fonts/ttf-bitstream-vera"
    FontPath        "/usr/share/fonts/unifont"
    FontPath        "/usr/share/fonts/75dpi"
    FontPath        "/usr/share/fonts/100dpi"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/lib/X11/fonts/local/"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/Speedo/"
    FontPath        "/usr/lib/X11/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/TrueType/"
    FontPath        "/usr/lib/X11/fonts/freefont/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
    Load           "dri"        # Double buffer extension
    Load           "dbe"
    Load           "extmod"
    Load           "wfb"
    Load           "xtrap"
    Load           "record"
    Load           "glx"
EndSection

Section "Device"
        Identifier     "GF9600GT"
        Driver         "nvidia"
        VendorName     "nVidia Corporation"
        BoardName      "G94 [GeForce 9600 GT]"
        Option         "HWcursor" "On"
        Option         "CursorShadow"
        Option         "CursorShadowAlpha" "32"
        Option         "CursorShadowXOffset" "3"
        Option         "CursorShadowYOffset" "3"
        Option         "TwinView" "True"
        Option         "MetaModes" "1920x1080,1600x1280,1280x1024,1024x768"
        Option         "NoLogo" "true"
        Option         "TwinViewOrientation" "CRT-1 RightOf CRT-0"
        Option         "Composite" "Enable"
        Option         "RenderAccel" "True"
        Option         "TripleBuffer" "true"
        Option         "BackingStore" "true"
        Option         "UseEdidDpi" "FALSE"
        Option         "AddARGBGLXVisuals" "true"
        Option         "DPI" "96 x 96"
        Option         "AccelMethod" "EXA"
        Option         "MigrationHeuristic" "greedy
EndSection

Section "Screen"
        Identifier     "monitor"
        Device         "GF9600GT"
        Monitor        "LG"
        DefaultDepth    24
        Option         "NoLogo" "true"
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1920x1080_75 +0+0"
        SubSection     "Display"
                Depth       24
        EndSubSection
EndSection

Section "Extensions"
        Option         "Composite" "Enable"
        Option         "RENDER" "Enable"
        Option         "Damage" "Enable"
EndSection

_________________
Maciej Dylski
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sat May 26, 2012 8:32 pm    Post subject: Reply with quote

U mnie i u masy ludzi na #gentoo-.pl to samo.

To stary i znany bug, nic nie zrobisz prócz wyłączenia owego przyśpieszenia sprzętowego.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 496

PostPosted: Sat May 26, 2012 11:10 pm    Post subject: Reply with quote

Napisalibyście, która dokladnie wersja flasha.
Bo u mnie jak na razie chodzi normalnie zarówno na sterze Nvidia 295.49 jak i na 302.11.
Tylko ja używam Grsecurity - więc może flash się boi wkurzać taki system :)

Pryka wrote:
U mnie i u masy ludzi na #gentoo-.pl to samo.

To stary i znany bug, nic nie zrobisz prócz wyłączenia owego przyśpieszenia sprzętowego.


@Pryka

Pewien jesteś?

Pozdrawiam
8)


Last edited by Jacekalex on Sat Jun 02, 2012 1:14 am; edited 1 time in total
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 177

PostPosted: Sun May 27, 2012 10:39 am    Post subject: Reply with quote

Miałem kiedyś dokładnie ten sam problem (za dużo niebieskiego). Ustąpił on samoistnie przy jakimś uaktualnieniu, niestety nie pamiętam o jakie pakiety chodziło.
Jest za to inny bug flasha, który wcześniej też występował: czasami (nie analizowałem dokładnie warunków) obraz animacji z jednej karty "przebija" na inne karty w niektórych miejscach (chyba tam gdzie kolor tła jest biały lub przezroczysty?), dodatkowo oprócz części przeznaczonej na treść HTML przebija też na pasek adresu.

Mam włączone przyspieszenie sprzętowe w opcjach flasha, poniżej emerge --info i konfig X, przeglądarka to firefox 12.0.
Code:
Portage 2.2.0_alpha108 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.15-r2, 3.4.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.4.0-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.1
Timestamp of tree: Sun, 27 May 2012 01:00:01 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo Lokalne roslin seden kde
Installed sets:
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8-sse3 -O2 -pipe -DNDEBUG -DG_DISABLE_ASSERT -mmmx -m3dnow -msse -msse2 -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8-sse3 -O2 -pipe -DNDEBUG -DG_DISABLE_ASSERT -mmmx -m3dnow -msse -msse2 -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl/ http://gentoo.telcom.net.ua/ http://gentoo.mneisen.org/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="pl"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/repl /var/lib/layman/roslin /var/lib/layman/seden /var/lib/layman/kde"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac acl acpi alsa amd64 archive branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cuda cups custom-cflags custom-optimization cxx dbus declarative djvu dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran g3dvl gdbm gif gphoto2 iconv java jpeg kde kipi kpathsea lcms libnotify lzma lzo mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses network nls nodrm nptl nsplugin ntfs nvidia ogg opengl openmp optimization optimized-qmake pam pango pcre pdf phonon plasma png policykit ppds pppd python3 qt3support qt4 readline reiserfs sdl session spell sse sse2 sse3 ssl startup-notification svg symlink tcpd threads tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xcomposite xml xorg xulrunner xv xvfb xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64 arm" QEMU_USER_TARGETS="i386 x86_64 arm" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

www-plugins/adobe-flash-11.2.202.235 was built with the following:
USE="64bit (consolekit) (multilib) (policykit) vdpau -32bit -kde -sse2check"


x11-drivers/nvidia-drivers-295.53 was built with the following:
USE="acpi (consolekit) (multilib) (policykit) tools"

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Fri Mar  6 01:04:17 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
#    Load           "type1"
#    Load           "freetype"
    Load           "glx"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       31.0 - 81.0
    VertRefresh     60.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option      "AddARGBGLXVisuals"     "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Sun May 27, 2012 5:44 pm    Post subject: Reply with quote

Jacekalex wrote:
Napisalibyście, która dokladnie wersja flasha.
Bo u mnie jak na razie chodzi normalnie zarówno na sterzer Nvidia 295.49 jak i na 302.11.
Tylko ja używam Grsecurity - więc może flash się boi wkurzać taki system :)

Pryka wrote:
U mnie i u masy ludzi na #gentoo-.pl to samo.

To stary i znany bug, nic nie zrobisz prócz wyłączenia owego przyśpieszenia sprzętowego.


@Pryka

Pewien jesteś?

Pozdrawiam
8)


Pewien jestem, bo bug jak nie był poprawiony tak nie jest, a to tylko rozwiązanie na okrętkę. Lepiej i szybciej wyłączyć wsparcie sprzętowe.
Back to top
View user's profile Send private message
dylon
Guru
Guru


Joined: 21 Mar 2005
Posts: 331
Location: Gliwice

PostPosted: Sun May 27, 2012 6:02 pm    Post subject: Reply with quote

Jacekalex wrote:


Pewien jesteś?



Dzięki. Podpowiedzi w linku pomogły.

Pryka wrote:

Pewien jestem, bo bug jak nie był poprawiony tak nie jest, a to tylko rozwiązanie na okrętkę. Lepiej i szybciej wyłączyć wsparcie sprzętowe.


Na moim (dość leciwym) sprzęcie, wyłączenie wspomagania skutkuje oglądaniem filmów w rozdziałce max 480p.
Gdyby jeszcze dało się zmusić html5 do używania wspomagania to byłoby super :)

[EDIT]

Jednak ten sposób ma wady - teraz często widuję komunikat: "The Adobe Flash plugin has crashed" :(

[/EDIT]
_________________
Maciej Dylski
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum