Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED)Brak ikony regulacji dźwięku w tray'u.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Mon Jul 30, 2012 4:00 pm    Post subject: (SOLVED)Brak ikony regulacji dźwięku w tray'u. Reply with quote

Używam Gnome light. Stwierdziłem że lepiej samemu wszystko od podstaw dostosowywać bez zbędnych śmieci.

Mam taki mały problem. Nie jest on tak ważny ale na pewno ułatwił by mi życie. A mianowicie po instalacji ALSA i innych takich brakuje mi ikonki do regulacji (pogłaśniania) dźwięku. Jakoś się obędę ale czasami gdy potrzeba szybko wyciszyć dzwięki to jest mały problem i muszę włączać program "Gnome Alsa Mixer" Co jest nie co nie wygodne.
Wiem że jest ikonka kontrolująca ten program ale opisu na włączenie jej na necie nie znalazłem. Czy jest jakiś sposób by ją załączyć?
Na razie zainstalowałem "Wolume Ico" Ale nie spełnia moich oczekiwań. Nie pokazuje się pasek przewijania w którym mógł bym łatwo dostosować głośność.


Last edited by maxim.251 on Sat Sep 22, 2012 6:23 am; edited 1 time in total
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Wed Aug 01, 2012 7:03 am    Post subject: Reply with quote

Nie wiem jakiej wersji Gnome używasz (2.x czy już 3.x), ale zakładam że 2.x bo w 3.x defaultowo panel ma kontrolę głośności.
Upewnij się czy masz zainstalowane :
Code:
gnome-base/gnome-applets

I jeżeli tak to prawolik na panelu -> dodaj applet i tam będzie regulator głośności.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Wed Aug 01, 2012 8:14 am    Post subject: Reply with quote

Właśnie w tym sęk że już to zrobiłem, zainstalowałem wszystkie programy apleto podobne.
W menu panelu gdzie mogę dodawać ikonki jest tam WolumeControl. Ale wo gule się nie uruchamia.
Może coś ze sterownikiem? Chociaż stery bardzo ładnie działają. Z Alsa Mixer mogę robić regulację dowoli. Słuchawki też działają.

I tak, to jest wersja Gnome 2.3 bo 3 mi się nie podoba z tym shelem.
Może to nie jest pytanie do tego posta, ale teoretycznie rozwiązał by mój problem.
A czy jest możliwość zainstalować sobie Gnome 3 bez tego shela? Żeby mi nie wyskakiwał boczny panel? Tylko mieć normalnie normalny tradycyjny pasek menu?
Jeśli tak to proszę o sugestie jak to zrobić lub czego nie instalować.

Dodam Tylko że instalowałem gnome-light. Przynajmniej nie mam śmietnika w menu program, ale zdaje sobie sprawę z tego że wtedy mogę napotkać na problemy przy instalacji indywidualnych pakietów.

Hih, zabawna sprawa, teraz to mi zegar zniknął. Pojawiła się chmurka że ikona w aplecie jest już nie dostępna. :/
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Wed Aug 01, 2012 10:07 am    Post subject: Reply with quote

a) w kwestii appletu odpal może z terminala applet przez
Code:
gnome-volume-control-applet

(zaznaczam, że piszę z pamięci nazwę) i zobacz z czym mu jest źle (możesz tu wkleić log).
b) Gnome 3 ma opcję fallback mode (wybieraną z poziomu GDM przy logowaniu), która bardziej przypomina Gnome 2.x - panel itd.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Wed Aug 01, 2012 10:51 am    Post subject: Reply with quote

A jak zainstalować tego gnome 3 lub co instalować by nie mieć problemów z ikonami? I nie instalować niepotrzebnych mi pakietów? Bo nie mam pewności, ale wpisując same GNOME w emerge to instaluje chyba metapakiet...

Ten pakiet już nie istnieje, lub program go nie widzi. A jeszcze inny problem mam z tym że przez pewne flagi wogule nie mogę zainstalować gnome-shell.

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "net-misc/curl[ssl,curl_ssl_openssl]" has unmet requirements.
- net-misc/curl-7.27.0-r2::gentoo USE="ldap ssl -ares -idn -ipv6 -kerberos -metalink -rtmp -ssh -static-libs -test -threads" CURL_SSL="nss openssl -axtls -cyassl -gnutls -polarssl"

  The following REQUIRED_USE flag constraints are unsatisfied:
    ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )

  The above constraints are a subset of the following complete expression:
    threads? ( !ares ) ssl? ( exactly-one-of ( curl_ssl_axtls curl_ssl_cyassl curl_ssl_gnutls curl_ssl_openssl curl_ssl_nss curl_ssl_polarssl ) )

(dependency required by "net-libs/liboauth-0.9.7[curl,-nss]" [ebuild])
(dependency required by "gnome-extra/evolution-data-server-3.2.3-r2[gnome-online-accounts]" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.2.2.1" [ebuild])
(dependency required by "gnome-shell" [argument])


Okazało się że miałem włączone dwie flagi maskujące "~x86 i x86" Wyłączyłem ją i instalacja apletów ruszyła.
I stanęła przy właśnie głośności, pogodzie, i zegarze. NIe umiem tego rozwiązać i chyba zacznę zastanawiać się nad przeniesieniem na gnome3.


Last edited by maxim.251 on Wed Aug 01, 2012 11:32 am; edited 1 time in total
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Wed Aug 01, 2012 11:28 am    Post subject: Reply with quote

Najlepiej dodaj gnome-light do package.keywords, a potem co Ci emerge będzie mówiło podczas mergowania gnome-light (odmaskowywanie kolejnych pakietów, ustawianie flag USE itd.)
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Wed Aug 01, 2012 11:34 am    Post subject: Reply with quote

Ok spróbuję.

Udało mi się wykombinować z pakietami jakie blokowały mi instalacje gnome-applets. Teraz instaluje wersje na ~x86.
Musiałem odinstalować 2 pakiety, by na ich miejsce ze emergować nowe. Po za tym instalując gnome-applets dodało mi do instalacji panel z nowej wersji i menu. To wszystko robiłem poza xorgiem. Mam nadzieje że te pakiety nie będą się gryzły z resztą systemu.
Jak już wspominałem, nie chciałem instalować całego shela, bo to za dużo pakietów na raz się ładowało. A o metapakiecie gnome nawet nie chcę słyszeć :P I mam nadzieje że ikonki powrócą.
Szkoda że zespół gnoma tak usilnie próbuje odejść od pomysłu gnome2. I wciskają shela który jest nie praktyczny i przy stwarza więcej nerwów w użytkowaniu. Po skompilowaniu pakietów dam znać jak działa i czy pomogło.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Wed Aug 01, 2012 1:14 pm    Post subject: Reply with quote

HURA! Udało się. Zainstalowałem panel z gnome 3 ale system pozostał z Gnome2. Nie wiem czy to dobrze, ale problem z ikonami w tray chyba będzie rozwiązany. Nadal nie mam głośności, w tayu, ale przynajmniej mam całą resztę ikonek.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 490

PostPosted: Sat Sep 08, 2012 10:58 pm    Post subject: Reply with quote

Code:
qlist -IvUqC gnome-panel  applet gnome-media
dev-python/gnome-applets-python-2.32.0
gnome-base/gnome-applets-2.32.1.1 gnome gstreamer ipv6 policykit
gnome-base/gnome-panel-2.32.1-r3 bonobo introspection
gnome-extra/gnome-media-2.32.0-r1 flac mp3 vorbis
gnome-extra/sensors-applet-2.2.7-r1 dbus hddtemp libnotify lm_sensors video_cards_nvidia
net-analyzer/netspeed_applet-0.16


I ikonka regulacji głośności jest na swoim miejscu, na normalnym panelu Gnome-2.32,
działa też regulacja przyciskami multimedialnymi z klawiatury.

Pozdrawiam
8)


Last edited by Jacekalex on Sat Dec 22, 2012 6:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Fri Sep 21, 2012 1:46 pm    Post subject: Reply with quote

Tak, dziękuję. Wtedy pomieszałem gałęzie stabilnej i niestabilnej, i jak puźniej instalowałem inne programy to kolidowały z stabilnymi programami, tak że w końcu znikały mi ikonki z tray'a. Teraz instalowałem od nowa system i użyłem tylko stabilnej gałęzi, i już nie było żadnych problemów.
Jeszcze raz dziekuję za uwagę i czas.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum