Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Razer Imperator
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
HTS
Guru
Guru


Joined: 20 Feb 2006
Posts: 395
Location: Bristol, UK

PostPosted: Tue Mar 01, 2011 2:31 am    Post subject: Razer Imperator Reply with quote

Hey guys,

Just got a Razer Imperator gaming mouse and thought I would share some settings which worked well for me.
I booted windows and installed the Razer configuration utility to set the DPI to 5600 DPI and polling rate to 1000Hz for games (I don't use the top buttons to switch DPI profiles as I use those for gaming macros).

Booting Linux with those settings obviously makes the mouse pointer SUPER fast.

The best way to fix this is to use xinput to find the right values.
use:
xinput list
to find the device

and:
xinput listprops [device]
to discover the supported properties.

I hate pointer acceleration so I basically only played with ConstantDeceleration.
Once you found the right values store them in your xorg.conf. Here is my mouse section for reference.

Code:
Section "InputClass"
   Identifier "mouse"
   MatchIsPointer "on"
   MatchDevicePath "/dev/input/event*"
   Driver "evdev"
   Option "AutoServerLayout" "on"
   Option "AccelerationProfile" "0"
   Option "ConstantDeceleration" "3.0"
   Option "AccelVelocityScaling" "1.0"
EndSection


Enjoy your super smooth mouse in Gentoo!
_________________
64bit Gentoo on dual Xeon X5650 (24 ht cores), 18GB DDR3 Ram, nVidia Quadro 2000, 128GB Crucial SSD
Back to top
View user's profile Send private message
popsUlfr
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2011
Posts: 80

PostPosted: Tue Mar 01, 2011 8:52 am    Post subject: Reply with quote

Hi HTS, this works nicely for my Imperator too.

You wouldn't have a Razer Keyboard lying around, would you? :P
I have a Razer Reclusa and am having some sort of conflicting situation with the very Imperator mouse. It's driving me mad...

But anyway nice config. :)
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Tue Mar 01, 2011 9:52 am    Post subject: Reply with quote

Moved from Desktop Environments to Documentation, Tips & Tricks as it fits better here.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
HTS
Guru
Guru


Joined: 20 Feb 2006
Posts: 395
Location: Bristol, UK

PostPosted: Tue Mar 01, 2011 6:56 pm    Post subject: Reply with quote

Thanks tomk.
Sorry popsUlfr I do not have the keyboard yet but might well get it at some point as I'm running out of macro buttons ;)
_________________
64bit Gentoo on dual Xeon X5650 (24 ht cores), 18GB DDR3 Ram, nVidia Quadro 2000, 128GB Crucial SSD
Back to top
View user's profile Send private message
mephist0
Tux's lil' helper
Tux's lil' helper


Joined: 19 Sep 2005
Posts: 92
Location: Germany, near Frankfurt/Main

PostPosted: Tue Apr 24, 2012 5:15 pm    Post subject: input --list -> xinput --list Reply with quote

Thanks alot mate!

I think it doesn't work with the Gnome 3 preferences is because the Razer mouse is listed twice by xinput --list.


Code:


xinput --list
Virtual core pointer                       id=2   [master pointer  (3)]
   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
   ↳ HID 046a:0023                              id=10   [slave  pointer  (2)]
   ↳ Razer Razer Imperator                      id=11   [slave  pointer  (2)]
   ↳ Razer Razer Imperator                      id=12   [slave  pointer  (2)]
Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ HID 046a:0023                              id=9   [slave  keyboard (3)]

_________________
Life sux, but graphics are awesome !

A Gamer who found a new hobby: photography
Back to top
View user's profile Send private message
jupiter126
n00b
n00b


Joined: 31 Aug 2012
Posts: 3

PostPosted: Fri Aug 31, 2012 10:48 am    Post subject: almost perfect Reply with quote

Thanks for this nice config HTS.

It came in handy when I had to add
Option "AutoAddDevices" "OFF"
to my xorg for my keyboard to work flawlessly.

Somehow the combination of both configs is not working perfectly as I lost the back/forward functionality of the mouse's buttons in browsers.
Do these still work for you or did you find another trick to make them work?
Back to top
View user's profile Send private message
HTS
Guru
Guru


Joined: 20 Feb 2006
Posts: 395
Location: Bristol, UK

PostPosted: Fri Sep 21, 2012 10:20 am    Post subject: Reply with quote

Hey jupiter,

I remapped the back/forward buttons to gaming macros so can't easily test this right now. If I can backup the mouse config I'll try it.
_________________
64bit Gentoo on dual Xeon X5650 (24 ht cores), 18GB DDR3 Ram, nVidia Quadro 2000, 128GB Crucial SSD
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum