Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kmail2 deletes body of IMAP emails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1529
Location: Edinburgh, Scotland

PostPosted: Fri Apr 27, 2012 6:59 pm    Post subject: Kmail2 deletes body of IMAP emails Reply with quote

Hi all,

I stumbled upon an extremely troubling problem.

I have used kmail to get my university emails off an IMAP server for some time now. However, after a recent update, something occasional causes the entire body of the email to be gone. The header is fine, but the message is blank. Worst of all, it's also blank if I try looking at it via webmail. I have tried sending myself messages with text in the body and the same behavior occurs.

The problem seems to be cured after deleting and recreating the IMAP account, though the blank mails are still blank.

Any ideas?

Best,

Alex
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Sat Apr 28, 2012 11:41 am    Post subject: Re: Kmail2 deletes body of IMAP emails Reply with quote

evoweiss wrote:

Any ideas?

Change KMail to something that is not bugged over all boundaries?
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1529
Location: Edinburgh, Scotland

PostPosted: Sat Apr 28, 2012 12:50 pm    Post subject: Re: Kmail2 deletes body of IMAP emails Reply with quote

gorkypl wrote:
evoweiss wrote:

Any ideas?

Change KMail to something that is not bugged over all boundaries?


The alternatives, for my purposes, are not viable. I guess this is why I keep use Alpine for email on my home computer.

Best,

Alex
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2403
Location: UK

PostPosted: Sat Apr 28, 2012 3:13 pm    Post subject: Reply with quote

I don't have any fanboyism issues against KDE stuff (I'm using it right now), but the one consistent message I see everywhere is that kmail2 is horribly broken. I'd tend to agree...
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1529
Location: Edinburgh, Scotland

PostPosted: Sat Apr 28, 2012 5:02 pm    Post subject: Reply with quote

Ant P. wrote:
I don't have any fanboyism issues against KDE stuff (I'm using it right now), but the one consistent message I see everywhere is that kmail2 is horribly broken. I'd tend to agree...


I've definitely come to that conclusion. I filed a bug report in the hope that something as serious as this bug will get fixed.

https://bugs.kde.org/show_bug.cgi?id=298962

Best,

Alex
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Sun Apr 29, 2012 12:24 pm    Post subject: Reply with quote

Ant P. wrote:
I don't have any fanboyism issues against KDE stuff (I'm using it right now), but the one consistent message I see everywhere is that kmail2 is horribly broken. I'd tend to agree...

Exactly my point. I was supporting KDE for many years, and have been using it constantly since 1.x until 4.something.
When i moved from KMail to claws-mail (due to the terminal state of KMail) and from Kile to vim there was no other reason to use KDE anymore, unfortunately.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4681
Location: Saint Amant, Acadiana

PostPosted: Sun Apr 29, 2012 2:34 pm    Post subject: Reply with quote

I'm no KDE fan, but how can Kmail delete bodies and leave headers in IMAP ... ? Something gotta be wrong on IMAP side, too.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 444
Location: Kraków, PL

PostPosted: Mon Apr 30, 2012 9:35 am    Post subject: Reply with quote

Jaglover wrote:
I'm no KDE fan, but how can Kmail delete bodies and leave headers in IMAP ... ?

I can't see why it won't be possible.
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4122
Location: Houston, Republic of Texas

PostPosted: Tue May 01, 2012 5:55 am    Post subject: Reply with quote

gorkypl wrote:
Jaglover wrote:
I'm no KDE fan, but how can Kmail delete bodies and leave headers in IMAP ... ?

I can't see why it won't be possible.


largely because nothing in the protocol itself would give a client this kind of capability
IMAP is not a protocol for editing stored messages. It is a protocol for fetching stored messages in their entirety. Ponder for a moment what a mail client would have to do - within the confines of the IMAP protocol - to exhibit this behaviour.

I'm more inclined to blame buggered MIME formatting that causes MUA's to not read anything past the header. For example, if a message does not properly terminate the header with CRLF CRLF, technically the body in such a case would become a part of the header.

Also worth noting many mail clients will store message headers, but not message bodies, depending on runtime configuration. In such a case a misbehaving IMAP server may be able to stat the file, but may not be able to open/fopen the file, returning zero bytes and leaving the mail client only able to display what it has in cache.

Could be any number of things, but kmail modifying the message contents is somewhere near the bottom of likely possibilities - not statistically impossible, just very very improbable, no matter how buggered kmail may be.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
stelinux
Tux's lil' helper
Tux's lil' helper


Joined: 02 Nov 2004
Posts: 85

PostPosted: Mon May 07, 2012 11:14 am    Post subject: Reply with quote

I've the same problem and after I delete all my filters the KMail behavior return fine.
_________________
stelinux on i7 950 12GB 1600 8/8/8
gentoo 10.0/desktop
Back to top
View user's profile Send private message
12345moon12345
n00b
n00b


Joined: 24 Dec 2006
Posts: 27

PostPosted: Mon May 07, 2012 2:12 pm    Post subject: Reply with quote

Kmail...?
On 3 seperate occasions in the last 3 years it lost all or part of my mail.
With each improvement things got slower.
I switched to sylpheed and was amazed by its speed, stability and simplicity in use.
So my conclusion: Kmal sucks and I won't check Kmail out for several years...
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2109
Location: Near Toronto

PostPosted: Mon May 07, 2012 2:39 pm    Post subject: Reply with quote

Quote:
I switched to sylpheed


That's interesting - how did you migrate your kmail local mail
to sylpheed if I may ask?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4681
Location: Saint Amant, Acadiana

PostPosted: Mon May 07, 2012 8:19 pm    Post subject: Reply with quote

You can always fire up an IMAP server if everything else fails.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
g.e.n.t.u.x.
Guru
Guru


Joined: 21 Aug 2006
Posts: 410
Location: Berlin

PostPosted: Wed May 09, 2012 1:06 pm    Post subject: Reply with quote

In my case kmail2 generate a copie of an incomming email every second with a empty body but all information in the emaillist are the same. in one circumstance 2 processes of that generates this copie of the email. i think it is the process they look for new emails.

greetz
_________________
Human being isnt a default setted feature.
Back to top
View user's profile Send private message
mounty1
Guru
Guru


Joined: 06 Jul 2006
Posts: 505
Location: Queensland

PostPosted: Thu Nov 15, 2012 7:58 pm    Post subject: kmail2 just did it for me Reply with quote

Just deleted most of my IMAP-held inbox. This is at 4.9.3. Well, it could be dovecot's fault I suppose, but you choose. Compiling Thunderbird now.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum