Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Brak myszy i klawiatury w X
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
madman
Apprentice
Apprentice


Joined: 11 Mar 2004
Posts: 161
Location: Lodz, Poland

PostPosted: Fri Apr 20, 2012 10:17 am    Post subject: Brak myszy i klawiatury w X Reply with quote

Jak w temacie - po aktualizacji systemu nie dziala mysz i klawiatura w X. Oczywiście przekompilowałem
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-keyboard
x11-drivers/xf86-input-mouse

Kilka informacji:
Code:
uname -a
Linux evil 3.3.2-gentoo #2 SMP Thu Apr 19 10:28:58 CEST 2012 x86_64 AMD Phenom(tm) II X4 B55 Processor AuthenticAMD GNU/Linux

Code:
grep INPUT /etc/make.conf
INPUT_DEVICES="keyboard mouse evdev"

Code:
grep DEVTMPFS /usr/src/linux/.config
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y

Code:
grep -i mouse /var/log/Xorg.0.log
[ 91330.848] (==) fglrx(0): Silken mouse enabled
[ 91331.133] (==) fglrx(1): Silken mouse enabled

Code:
grep -i keyboard /var/log/Xorg.0.log
[ 91331.156] (II) Initializing built-in extension XKEYBOARD

Code:
cat /etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        Screen         "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
        Option      "Xinerama" "on"
        Option      "Clone" "off"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "PreferredMode"   "1440x900"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:5:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-1"
        Driver      "fglrx"
        BusID       "PCI:1:5:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-1"
        Device     "aticonfig-Device[0]-1"
        Monitor    "aticonfig-Monitor[0]-1"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

_________________
Kto jest twoim autorytetem moralnym i dlaczego jest nim JPII ?
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2821

PostPosted: Fri Apr 20, 2012 10:45 am    Post subject: Reply with quote

W /var/log/Xorg.0.log powinno byc napisane dlaczego nie masz inputow.
_________________
BitBucket -- better-initramfs to address many usecases and linux's limitations.
Back to top
View user's profile Send private message
madman
Apprentice
Apprentice


Joined: 11 Mar 2004
Posts: 161
Location: Lodz, Poland

PostPosted: Fri Apr 20, 2012 11:04 am    Post subject: Reply with quote

Słuszna uwaga - powinno.
Xorg.0.log:
http://pastebin.com/v1GCxGAt
_________________
Kto jest twoim autorytetem moralnym i dlaczego jest nim JPII ?
Back to top
View user's profile Send private message
dylon
Guru
Guru


Joined: 21 Mar 2005
Posts: 331
Location: Gliwice

PostPosted: Sat Apr 21, 2012 6:20 pm    Post subject: Reply with quote

Miałem taki sam problem. Okazało się, że bruździł tu udev. Od wersji 182 nie działa min. klawiatura,mysz i np. eth . Nie miałem na razie czasu bawić się z jego zmienionymi skryptami, więc wróciłem do 171 a wyższe zamaskowałem :)
_________________
Maciej Dylski
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum