Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[revdep-rebuild] problem sur des programmes pas dans portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bdouxx
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2009
Posts: 91

PostPosted: Fri Apr 20, 2012 7:46 am    Post subject: [revdep-rebuild] problem sur des programmes pas dans portage Reply with quote

Bonjour

j'ai installé 2 logiciels propriétaires en dehors de portage ( beyond-compare et codewarrior), mais maintenant j'ai cela:
Code:
# revdep-rebuild -i
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 40% ]  *   broken /usr/lib64/beyondcompare/ext/bcompare_ext_kde.i386.so (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkio.so.5)
[ 44% ]  *   broken /usr/lib64/bplvisualclx.so.6.9.0 (requires bplrtl.so.6.9)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /usr/lib64/beyondcompare/ext/bcompare_ext_kde.i386.so not owned by any package is broken !!!
 *   /usr/lib64/beyondcompare/ext/bcompare_ext_kde.i386.so -> (none)
 *  !!! /usr/lib64/bplvisualclx.so.6.9.0 not owned by any package is broken !!!
 *   /usr/lib64/bplvisualclx.so.6.9.0 -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr


Mais je ne vois pas trop ce que je suis censé faire pour corriger ce probleme,
Code:
# locate libQtCore.so.4
/usr/lib64/qt4/libQtCore.so.4
/usr/lib64/qt4/libQtCore.so.4.8
/usr/lib64/qt4/libQtCore.so.4.8.1

# locate libQtGui.so.4
/usr/lib64/qt4/libQtGui.so.4
/usr/lib64/qt4/libQtGui.so.4.8
/usr/lib64/qt4/libQtGui.so.4.8.1

# locate libkdecore.so.5
/usr/lib64/libkdecore.so.5
/usr/lib64/libkdecore.so.5.8.0

# locate libkio.so.5 
/usr/lib64/libkio.so.5
/usr/lib64/libkio.so.5.8.0

# locate bplrtl.so.6.9 
/usr/lib64/bplrtl.so.6.9.0
/usr/local/Freescale/CodeWarrior_MCU_10.2/Drivers/pemicro/libusb_64_32/lib/bplrtl.so.6.9.0
/usr/local/Freescale/CodeWarrior_MCU_10.2/Drivers/pemicro/windriver_32/windriver/lib/bplrtl.so.6.9.0


Avez vous une idée?
Merci
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5281
Location: ~Brussels - Belgique

PostPosted: Fri Apr 20, 2012 8:23 am    Post subject: Reply with quote

J'ai une idée : ces blobs binaires se basent sur des dépendances de librairies trop anciennes par rapport à Portage.

Il faudrait que tu mettes des dépendances vers des versions explicites, mais ça va te freezer ces versions globalement.

Pour beyond Compare, j'ai une alternative : Meld.

Et pour CodeWarrior, je te propose de créer un chroot rien que pour lui, ou une machine virtuelle.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum