Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problem z dok. pdf druk. z jednego z banków na M
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
olejseba
n00b
n00b


Joined: 04 Sep 2005
Posts: 62

PostPosted: Sun Apr 01, 2012 8:41 pm    Post subject: [SOLVED] Problem z dok. pdf druk. z jednego z banków na M Reply with quote

Witam.
Mam problem z dokumentem "potwierdzenie przelewu" drukowanym do pdfa z jednego z naszych banków. Problem polega na tym że w Adobe Reader pojawiają się kropki zamiast liter, a w innych przeglądarkach np. "ePdfViewer" zamiast polskich liter są krzaki. Problem wynika z tego że acrobat for Linux nie posiada czcionek Tahoma, a w innych przeglądarkach mimo że mam poustawiane środowisko to mam krzaki. Pewnie bankowi wdrożeniowcy postarali się by pdf'y były czytelne tylko na windzie(2 miesiące temu nie było tego problemu, a pdfy zupełnie inaczej skonstruowane).
Pozdrawiam SOL


Last edited by olejseba on Mon Apr 09, 2012 11:26 am; edited 4 times in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2836

PostPosted: Sun Apr 01, 2012 10:29 pm    Post subject: Reply with quote

PDFy z potwierdzeniem sa zaczarowane. Rozne problemy z nimi mialem, np. potwierdzenia z jednego banku (tego na M) czy np. faktury elektroniczne z playa. Na Linuksie czesto gubi znak, zmienia fonty, za to na windowsach wywala spoolera, czy to XP, Vista czy 7, po probie wydrukowania takiego dokumentu system informuje, ze nie ma zadnej zainstalowanej drukarki, trzeba wylaczyc usluge 'spooler', zaorac katalog z plikami do wydruku (spool, gdzies w %windir%) i wystartowac ponownie. Przerabialem to wielokrotnie, rozne komputery, rozne systemy.

Proponuje napisac do banku, ze maja pdfy w wersji demo.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 492

PostPosted: Sat Apr 07, 2012 1:31 am    Post subject: Reply with quote

Ten Evince:
Quote:
app-text/evince-2.32.0-r3 dbus debug djvu dvi gnome gnome-keyring introspection nautilus t1lib tiff
otwiera potwierdzenia z mBanku bez problemu, też drukuje prawidłowo.

Pozdrawiam
8)
Back to top
View user's profile Send private message
gexcite
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2005
Posts: 103

PostPosted: Sat Apr 07, 2012 1:27 pm    Post subject: Reply with quote

Jacekalex wrote:
Ten Evince:
Quote:
app-text/evince-2.32.0-r3 dbus debug djvu dvi gnome gnome-keyring introspection nautilus t1lib tiff
otwiera potwierdzenia z mBanku bez problemu, też drukuje prawidłowo.

Pozdrawiam
8)


Tak, rozumiem że jako użytkownicy Linuksa często pokornie przyznajemy, że nam coś nie działa, bo zrobione pod MS, i szukamy jakiegoś rozwiązania. No ale bez przesady!! Jak nie działa na 3 przeglądarkach to kto ma problem? My czy bank? My czy Play? Łaskawie informuję Play, że nie mogę odczytać i wstrzymuję się z płatnościami do czasu dostarczenia mi "odczytywalnej" informacji. O dziwo zazwyczaj działa :-)
Back to top
View user's profile Send private message
olejseba
n00b
n00b


Joined: 04 Sep 2005
Posts: 62

PostPosted: Sun Apr 08, 2012 6:45 pm    Post subject: Reply with quote

Jacekalex wrote:
Ten Evince:
Quote:
app-text/evince-2.32.0-r3 dbus debug djvu dvi gnome gnome-keyring introspection nautilus t1lib tiff
otwiera potwierdzenia z mBanku bez problemu, też drukuje prawidłowo.

Pozdrawiam
8)

Witam ponownie. Nie udało mi się nic uzyskać w MBanku. Do końca roku zrezygnuję z takiego Banku. Nawet na forum są fanatycy Microsoftu. Co do evince, nie ma takiej możliwości by dobrze czytał całe pdfy. (polskie znaczki stają się chińskie). Wyszukałem w google inne rozwiązanie. Skopiować czcionki z windows. Działa bez problemów. Polecam.
http://www.aboutlinux.info/2005/12/adding-windows-fonts-in-linux.html
Pozdrawiam
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Mon Apr 09, 2012 6:59 am    Post subject: Reply with quote

@olejseba

Nie wystarczy zainstalować media-fonts/corefonts?
Back to top
View user's profile Send private message
olejseba
n00b
n00b


Joined: 04 Sep 2005
Posts: 62

PostPosted: Mon Apr 09, 2012 8:36 am    Post subject: Reply with quote

Pryka wrote:
@olejseba

Nie wystarczy zainstalować media-fonts/corefonts?

No niestety nie wystarczy. Microsoft ma licencje na wiele czcionek używanych przez systemy generujące pdfy np. w MBanku.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 492

PostPosted: Tue Apr 10, 2012 4:48 am    Post subject: Reply with quote

To bardzo ciekawe, ja mam tylko corefonts, a Evince potwierdzenia otwiera prawidłowo.
I nie widziałem w tych potwierdzeniach jakichś extra fontów nie wiadomo skąd.

Również, kiedy takie potwierdzenie potraktuję poleceniem pdftotext - to wychodzi prawidłowy plik tekstowy z Polską czcionką.
Wyglada to tak:
Code:
pdftotext Potwierdzenie\ wykonania\ przelewu.pdf potwierdzenie.txt

A potem:
Code:
head -n5 potwierdzenie.txt
POTWIERDZENIE WYKONANIA PRZELEWU - DUPLIKAT

mBank
mBank, Bankowość Detaliczna BRE Banku SA
90-959 Łódź 2, Skrytka Pocztowa 2108


Więc radziłbym sprawdzić, czy poppler prawidłowo skompilowany:
Ja mam:
Code:
qlist -ICvUq poppler evince
app-text/evince-2.32.0-r3 dbus debug djvu dvi gnome gnome-keyring introspection nautilus t1lib tiff
app-text/poppler-0.16.7 cairo curl cxx introspection jpeg jpeg2k lcms png qt4 utils xpdf-headers
app-text/poppler-data-0.4

To by było na tyle
8)
Back to top
View user's profile Send private message
olejseba
n00b
n00b


Joined: 04 Sep 2005
Posts: 62

PostPosted: Tue Apr 10, 2012 7:43 pm    Post subject: Reply with quote

Jacekalex wrote:
To bardzo ciekawe, ja mam tylko corefonts, a Evince potwierdzenia otwiera prawidłowo.
I nie widziałem w tych potwierdzeniach jakichś extra fontów nie wiadomo skąd.

Również, kiedy takie potwierdzenie potraktuję poleceniem pdftotext - to wychodzi prawidłowy plik tekstowy z Polską czcionką....................................................


Witam to co napisałeś mam poinstalowane tak jak ty. Dodatkowo na RedHat'ach ubuntu i SuSe jest ten sam problem. Wynika on z prostej przyczyny obecne pdfy nie mają wbudowanych fontów do ciała pliku tak jak to było w przeszłości.

Code:

Jest:
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
Verdana                              CID TrueType      no  no  yes     21  0
ArialMT                              CID TrueType      no  no  yes     20  0
Tahoma-Bold                          CID TrueType      no  no  yes     17  0
Helvetica                            Type 1            no  no  no      18  0
Arial-BoldMT                         CID TrueType      no  no  yes     19  0
Tahoma                               CID TrueType      no  no  yes     23  0
Verdana-Bold                         CID TrueType      no  no  yes     22  0


A było tak nazwy fontow te same ale ich typy różne  obsługa emb sub uni i SUBSET była teraz niema.

lenovo UXSOLSYSTEM # pdffonts zus-07-2011.pdf
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
SUBSET+TahomaBold                    CID TrueType      yes yes yes     17  0
SUBSET+ArialMT                       CID TrueType      yes yes yes     19  0
Helvetica                            Type 1            no  no  no      22  0
SUBSET+Tahoma                        CID TrueType      yes yes yes     18  0
SUBSET+VerdanaBold                   CID TrueType      yes yes yes     21  0
SUBSET+ArialBoldMT                   CID TrueType      yes yes yes     20  0
SUBSET+Verdana                       CID TrueType      yes yes yes     23  0
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 177

PostPosted: Tue Apr 10, 2012 10:57 pm    Post subject: Reply with quote

Może przyda się komuś info jak rozwiązać ten problem bez dostępu do plików windowsa.
Brakujące czcionki (pomimo instalacji corefonts) to Tahoma i Tahoma-Bold można je ściągnąć np. stąd: http://fontzone.net/?q=tahoma

Dodawanie np. zgodnie z podanym wcześniej przez autora tematu linkiem, ale ZTCW można też wrzucać fonty do ~/.fonts dla pojedynczego usera. Przy czym u mnie nie utworzył się plik opisywany fonts.cache-1 (ani żaden inny oprócz fonts.dir) więc pominąłem krok z jego edycją.
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 492

PostPosted: Wed Apr 11, 2012 3:02 am    Post subject: Reply with quote

Temat dotyczył Potwierdzeń z banku na M?

Code:
 pdffonts Potwierdzenie\ wykonania\ przelewu.pdf
name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
SUBSET+Verdana                       CID TrueType      yes yes yes     14  0
SUBSET+ArialMT                       CID TrueType      yes yes yes     12  0
SUBSET+Tahoma                        CID TrueType      yes yes yes     15  0
Helvetica                            Type 1            no  no  no      11  0
SUBSET+VerdanaBold                   CID TrueType      yes yes yes     16  0
SUBSET+ArialBoldMT                   CID TrueType      yes yes yes     13  0
SUBSET+TahomaBold                    CID TrueType      yes yes yes     18  0
SUBSET+ArialMT                       CID TrueType      yes yes yes     17  0

Czcionek z poza portage nie instalowałem, być może jakieś dociągnął Libreoffice-bin.

Ariala i Verdanę mam na 100% (z instalatora corefonts)

Pozdro
8)
Back to top
View user's profile Send private message
znal
Apprentice
Apprentice


Joined: 12 Jul 2007
Posts: 177

PostPosted: Wed Apr 11, 2012 9:53 am    Post subject: Reply with quote

U mnie (potwierdzenie wygenerowane wczoraj) wynik pdffonts jest taki pierwszy co napisał olejseba. Czyli czcionki nie są (już) osadzone w PDFie (emb=no).
Żaden z zainstalowanych u mnie pakietów nie dostarcza właściwych fontów Tahoma.

Można mieć to obsłużone przez portage - istnieje ebuild: http://gpo.zugaina.org/media-fonts/tahoma ale on wymaga ręcznego pobrania plików ttf.
Wine co prawda zawiera te 2 pliki ttf, ale nie są to te same pliki co na podanej przeze mnie stronie, po ich dołożeniu tak aby były dostępne (domyślnie znajdują się /usr/share/wine/fonts) dalej miałem krzaki w podglądzie PDFa.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum