Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hyper-V VM and Hardened Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 355

PostPosted: Tue Mar 11, 2014 7:30 pm    Post subject: Hyper-V VM and Hardened Gentoo Reply with quote

Hi there @all

I searched a lot about this Problem, but didn't really find anything about it.

I use Gentoo in 2 HyperV VMs under Windows 8.1. The first one is only to Provide a Desktop through vnc, for Security Reasons (Malware, etc. pp.) i use it for surfing in the Internet. The second one is only experimental (First it only should be a distcc-host for my real hardened system, which works fine as long as i use a normal kernel) and should replace the first VM in the Future when i solved this Problem.

The Problem is that the hardened Kernel hangs when he load the HyperV vmbus module (Integrated into the Kernel) or (If i use the pii ata module integrated in the kernel to access the ide disk in the vm) it seems to load but nothing really works.

At this moment the VM runs with a gentoo-sources-3.13.3 kernel, i want to use the hardened-3.13.3 or newer kernel.

Does anybody know this Problem, is there a workaround or is there no solution for this Problem and i have to contact Microsoft (Or one of their Forums) ?

*EDIT* I have not included logfiles since i have none from loading the modules (Could make one) and the kernel freezes don't provide logs. If someone needs specific logfile i will provide them.

*EDIT2* Even during Kernel bootup the kernel freezes directly when it loads the vmbus part, have spent much time to verify this because there is no text about it on screen, it freezes directly after the output of the driver which loads before it (Integrated in the kernel, needed different configurations to find this out).

Even when i make the hyperv part of the kernel as modules and "hack" the piix driver to load the HyperV ide storage (To boot up comletely, when the whole hyperv thing is compiled as modules), there is no output in dmesg from the vmbus module, only lsmod shows me that it is loaded (Which is not true because it doesn't work, when i load another hyperv module (storage) it won't work).

I hope this are enough information about the Problem.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 355

PostPosted: Mon Mar 17, 2014 10:46 pm    Post subject: Reply with quote

Ok, silly me :D

Have set the grsec configuration option to automatic and choose guest an xen, now it runs like hell :D
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 355

PostPosted: Thu Mar 20, 2014 12:04 pm    Post subject: Reply with quote

http://pastebin.com/pzSKskxF

Here is the working Kernel Configuration file.

It is a Custom Patched (Bfq, Fbcondecor, Optimization Patch from geek-sources, exfat patchset) 3.13.6-Hardened Kernel.

The .config is Optimized for an Amd 8350-FX Processor.

Hope this Thread will help someone who has got an equal Problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum