Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Help] Trouble about cpufreqd
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sat Mar 10, 2012 8:24 pm    Post subject: [Help] Trouble about cpufreqd Reply with quote

after installing the gentoo from minimal stage, I am trying to configure my system by following power management guide
http://www.gentoo.org/doc/en/power-management-guide.xml
but in the end I didn't succeed in swithing cpufreqd on

Quote:
*** buffer overflow detected ***: /usr/sbin/cpufreqd terminated
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail+0x37)[0x7f48240f66f7]
/lib64/libc.so.6(+0xee510)[0x7f48240f4510]
/lib64/libc.so.6(+0xeeb8b)[0x7f48240f4b8b]
/usr/sbin/cpufreqd(main+0x7be)[0x403cde]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f482402809d]
/usr/sbin/cpufreqd[0x402ec9]
======= Memory map: ========
00400000-0040b000 r-xp 00000000 08:0a 2778284 /usr/sbin/cpufreqd
0060a000-0060b000 r--p 0000a000 08:0a 2778284 /usr/sbin/cpufreqd
0060b000-0060c000 rw-p 0000b000 08:0a 2778284 /usr/sbin/cpufreqd
0060c000-0062d000 rw-p 00000000 00:00 0 [heap]
7f4823df0000-7f4823e05000 r-xp 00000000 08:0a 3050567 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libgcc_s.so.1
7f4823e05000-7f4824004000 ---p 00015000 08:0a 3050567 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libgcc_s.so.1
7f4824004000-7f4824005000 r--p 00014000 08:0a 3050567 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libgcc_s.so.1
7f4824005000-7f4824006000 rw-p 00015000 08:0a 3050567 /usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.3/libgcc_s.so.1
7f4824006000-7f4824188000 r-xp 00000000 08:0a 1970007 /lib64/libc-2.13.so
7f4824188000-7f4824388000 ---p 00182000 08:0a 1970007 /lib64/libc-2.13.so
7f4824388000-7f482438c000 r--p 00182000 08:0a 1970007 /lib64/libc-2.13.so
7f482438c000-7f482438d000 rw-p 00186000 08:0a 1970007 /lib64/libc-2.13.so
7f482438d000-7f4824392000 rw-p 00000000 00:00 0
7f4824392000-7f4824397000 r-xp 00000000 08:0a 2775811 /usr/lib64/libcpufreq.so.0.0.0
7f4824397000-7f4824596000 ---p 00005000 08:0a 2775811 /usr/lib64/libcpufreq.so.0.0.0
7f4824596000-7f4824597000 r--p 00004000 08:0a 2775811 /usr/lib64/libcpufreq.so.0.0.0
7f4824597000-7f4824598000 rw-p 00005000 08:0a 2775811 /usr/lib64/libcpufreq.so.0.0.0
7f4824598000-7f482459a000 r-xp 00000000 08:0a 1970230 /lib64/libdl-2.13.so
7f482459a000-7f482479a000 ---p 00002000 08:0a 1970230 /lib64/libdl-2.13.so
7f482479a000-7f482479b000 r--p 00002000 08:0a 1970230 /lib64/libdl-2.13.so
7f482479b000-7f482479c000 rw-p 00003000 08:0a 1970230 /lib64/libdl-2.13.so
7f482479c000-7f48247bb000 r-xp 00000000 08:0a 1969945 /lib64/ld-2.13.so
7f48249ae000-7f48249b1000 rw-p 00000000 00:00 0
7f48249ba000-7f48249bb000 rw-p 00000000 00:00 0
7f48249bb000-7f48249bc000 r--p 0001f000 08:0a 1969945 /lib64/ld-2.13.so
7f48249bc000-7f48249bd000 rw-p 00020000 08:0a 1969945 /lib64/ld-2.13.so
7f48249bd000-7f48249be000 rw-p 00000000 00:00 0
7fffbcd76000-7fffbcd97000 rw-p 00000000 00:00 0 [stack]
7fffbcdff000-7fffbce00000 r-xp 00000000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
* start-stop-daemon: failed to start `/usr/sbin/cpufreqd'
* ERROR: cpufreqd failed to start


I've verified that acpi-cpu, and laptop-mode-tools are on.

I also tried cpufrequtils too. but it returned
Quote:
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
no or unknown cpufreq driver is active on this CPU
maximum transition latency: 4294.55 ms.
analyzing CPU 1:
no or unknown cpufreq driver is active on this CPU
maximum transition latency: 4294.55 ms.


same issue was discussed here with no solution.
http://forums.gentoo.org/viewtopic-t-901642-start-0.html

How could I do?

Thank you
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sat Mar 10, 2012 11:52 pm    Post subject: Reply with quote

pd1986,

When you ran cpufreq-info did you have cpufrequtils loaded? If not add it to boot -> rc-update add cpufrequtils boot

Check if it's running with -> rc-update show|grep cpufrequtils

There may be an issue with libc.so.6. Try -> ldd $(which cpufreq-info) - your output should look like this:

root@gentoo-gateway home # ldd $(which cpufreq-info)
linux-vdso.so.1 => (0x00007fff67360000)
libcpufreq.so.0 => /usr/lib64/libcpufreq.so.0 (0x00007f6350919000)
libc.so.6 => /lib64/libc.so.6 (0x00007f635058e000)
/lib64/ld-linux-x86-64.so.2 (0x00007f6350b1f000)

Also check your .config settings. Mine are

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m
CONFIG_X86_PCC_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ=m

Also a revdep-rebuild never hurts.

Hope this helps :wink:
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sun Mar 11, 2012 8:58 am    Post subject: Reply with quote

BillWho wrote:
pd1986,

When you ran cpufreq-info did you have cpufrequtils loaded? If not add it to boot -> rc-update add cpufrequtils boot

Check if it's running with -> rc-update show|grep cpufrequtils

There may be an issue with libc.so.6. Try -> ldd $(which cpufreq-info) - your output should look like this:

root@gentoo-gateway home # ldd $(which cpufreq-info)
linux-vdso.so.1 => (0x00007fff67360000)
libcpufreq.so.0 => /usr/lib64/libcpufreq.so.0 (0x00007f6350919000)
libc.so.6 => /lib64/libc.so.6 (0x00007f635058e000)
/lib64/ld-linux-x86-64.so.2 (0x00007f6350b1f000)

Also check your .config settings. Mine are

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=m
CONFIG_CPU_FREQ_GOV_USERSPACE=m
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=m
CONFIG_X86_PCC_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ=m

Also a revdep-rebuild never hurts.

Hope this helps :wink:


Thanks for your response
I am sorry, the outcome of cpufrequtils is that before I recompiled kernel. so right now, cpufrequtils works.
but I still have troubles with cpufreqd, I prefer using this because it seems more powerful than cpufrequtils, for instance it has configurations for battery.

outcome of ldd
Quote:
linux-vdso.so.1 => (0x00007fffdde7f000)
libcpufreq.so.0 => /usr/lib64/libcpufreq.so.0 (0x00007f6122077000)
libc.so.6 => /lib64/libc.so.6 (0x00007f6121ceb000)
/lib64/ld-linux-x86-64.so.2 (0x00007f612227d000)


There truly be some little differences between my .config and yours which are
"CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set"

my .config
Quote:
...
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_STAT=m
# CONFIG_CPU_FREQ_STAT_DETAILS is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y

#
# x86 CPU frequency scaling drivers
#
# CONFIG_X86_PCC_CPUFREQ is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_POWERNOW_K8=m
CONFIG_X86_SPEEDSTEP_CENTRINO=m
CONFIG_X86_P4_CLOCKMOD=m


I ran revdep-rebuild too, cpufreqd still can't start
Do you have any other ideas?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Mar 11, 2012 2:52 pm    Post subject: Reply with quote

pd1986,

I browsed the bug writeup on this and if the version wasn't bumped, for whatever reason, then try reemerging it after deleting the file from DISTDIR otherwise portage will keep using the local copy.

Another thing you can try if that doesn't work is mask sys-power/cpufreqd-2.4.2-r1 and emerge sys-power/cpufreqd-2.4.2 to see if that version works. Downgrading glibc was also mentioned as a possible remedy, but I would not recommend pursuing that avenue.

There's nothing else I can think of past this.

Good luck with it :wink:
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sun Mar 11, 2012 3:29 pm    Post subject: Reply with quote

BillWho:
BillWho wrote:
pd1986,

I browsed the bug writeup on this and if the version wasn't bumped, for whatever reason, then try reemerging it after deleting the file from DISTDIR otherwise portage will keep using the local copy.

Another thing you can try if that doesn't work is mask sys-power/cpufreqd-2.4.2-r1 and emerge sys-power/cpufreqd-2.4.2 to see if that version works. Downgrading glibc was also mentioned as a possible remedy, but I would not recommend pursuing that avenue.

There's nothing else I can think of past this.

Good luck with it :wink:

I tryied that. unmerging cpufreqd, deleting the file in DISTDIR and reemerging again. it still doen't work. the version is already 2.4.2, but not 2.4.2-r1
Given the lack of gentoo experience, downgrading glibs seems more complicated. I've no idea about it.
Well, let it pass. I wll use cpufrequtils instead. Thank you again.
Back to top
View user's profile Send private message
WvR
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2011
Posts: 139
Location: Tsuruga, Japan

PostPosted: Mon Mar 12, 2012 12:09 am    Post subject: Reply with quote

There is indeed some issue with cpufreqd which makes it highly unlikely that it will work on recent Gentoo installations. Something with a filename path being coded in the wrong way in cpufreqd. Unless the maintainer of cpufreqd fixes that bug there is nothing we can do to make cpufreqd work.

So it seems that you may be able to do the following:

Code:
# cd /usr/portage/distfiles
# rm -rf *
# cd
# emerge --sync
# emerge cpufreqd


This may solve your problem. If it doesn't, then you'll have to use cpufrequtils, or similar software depending on your specific computer.
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1641

PostPosted: Mon Mar 12, 2012 2:36 am    Post subject: Reply with quote

Are you on stable? According to this bug, upgrading to -r1 might help. See if that works for you too.
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Mon Mar 12, 2012 8:25 am    Post subject: Reply with quote

Etal wrote:
Are you on stable? According to this bug, upgrading to -r1 might help. See if that works for you too.

Sorry, what do you mean by "on stable", you mean for use or for cpufreq?
for cpufreq, I ran cpufreqd-2.4.2, it should be the stable version.
according to the gentoo package description, il seems that 2.4.2-r1 is unstable. by the way, I installed cpufrequtils, but I don't know if it works properly.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Mon Mar 12, 2012 1:28 pm    Post subject: Reply with quote

pd1986,

How you can check if cpufrequtiles is working properly.

cpufreq-info -o | grep ^CPU

root@gentoo-gateway conf.d # cpufreq-info -o | grep ^CPU
CPU 0 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 1 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 2 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 3 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand

Don't forget to set the governor in /etc/conf.d/cpufrequtils

# /etc/conf.d/cpufrequtils: config file for /etc/init.d/cpufrequtils

# Options when starting cpufreq (given to the `cpufreq-set` program)
START_OPTS="--governor ondemand"
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1641

PostPosted: Mon Mar 12, 2012 4:26 pm    Post subject: Reply with quote

pd1986 wrote:
Etal wrote:
Are you on stable? According to this bug, upgrading to -r1 might help. See if that works for you too.

Sorry, what do you mean by "on stable", you mean for use or for cpufreq?
for cpufreq, I ran cpufreqd-2.4.2, it should be the stable version.
according to the gentoo package description, il seems that 2.4.2-r1 is unstable. by the way, I installed cpufrequtils, but I don't know if it works properly.


Yes, that's what I meant. Try adding "=sys-power/cpufreqd-2.4.2-r1" to /etc/portage/package.keywords, and update to it.
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Mon Mar 12, 2012 11:10 pm    Post subject: Reply with quote

BillWho wrote:
pd1986,

How you can check if cpufrequtiles is working properly.

cpufreq-info -o | grep ^CPU

root@gentoo-gateway conf.d # cpufreq-info -o | grep ^CPU
CPU 0 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 1 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 2 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand
CPU 3 900000 kHz ( 50 %) - 1800000 kHz (100 %) - ondemand

Don't forget to set the governor in /etc/conf.d/cpufrequtils

# /etc/conf.d/cpufrequtils: config file for /etc/init.d/cpufrequtils

# Options when starting cpufreq (given to the `cpufreq-set` program)
START_OPTS="--governor ondemand"

Thanks, I know that too. But what I meant is whether cpufrequtils could change the governor profile when I connect the AC adapter or not. I tried disconnecting the ac adapter. it seems that the governor is always ondemand. does that mean we need to change that manually?
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Mon Mar 12, 2012 11:14 pm    Post subject: Reply with quote

Etal wrote:
pd1986 wrote:
Etal wrote:
Are you on stable? According to this bug, upgrading to -r1 might help. See if that works for you too.

Sorry, what do you mean by "on stable", you mean for use or for cpufreq?
for cpufreq, I ran cpufreqd-2.4.2, it should be the stable version.
according to the gentoo package description, il seems that 2.4.2-r1 is unstable. by the way, I installed cpufrequtils, but I don't know if it works properly.


Yes, that's what I meant. Try adding "=sys-power/cpufreqd-2.4.2-r1" to /etc/portage/package.keywords, and update to it.


Thanks. I triedcpufreqd-2.4.2-r1 a while ago. cpufreqd can start. but when I check the status, it returns "status:crashed". It's really unstable. :)
Back to top
View user's profile Send private message
WvR
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2011
Posts: 139
Location: Tsuruga, Japan

PostPosted: Mon Mar 12, 2012 11:57 pm    Post subject: Reply with quote

pd1986 wrote:
Thanks, I know that too. But what I meant is whether cpufrequtils could change the governor profile when I connect the AC adapter or not. I tried disconnecting the ac adapter. it seems that the governor is always ondemand. does that mean we need to change that manually?


You set cpufrequtils to "ondemand" - this is the most sensible setting in all circumstances. If you want to change the cpufrequtils settings with the presence or absence of the AC adapter, you have to look into the ACPI settings. I don't know if cpufrequtils is aware of ACPI. I'd say, check the manuals :D I use cpufrequtils with "ondemand" on all my computers in all cases, and in my experience it works very well.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Mar 13, 2012 2:38 am    Post subject: Reply with quote

Quote:
But what I meant is whether cpufrequtils could change the governor profile when I connect the AC adapter or not.


check into acpid (man acpid) on how to execute a script resulting from an event.

The script can execute this line -> for p in $(sed -n '/processor/p' /proc/cpuinfo|cut -d: -f2); do cpufreq-set -c ${p} -g powersave;done
That's the only way I know of doing it.

For now you can run that line in the terminal for a quick change.. :wink:

Good luck
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Thu Mar 15, 2012 11:33 pm    Post subject: Reply with quote

Ok, I understand. Hope that there won't be some problem. Thanks.
Back to top
View user's profile Send private message
Lezard
n00b
n00b


Joined: 30 May 2007
Posts: 7

PostPosted: Sun Mar 25, 2012 7:10 pm    Post subject: Reply with quote

I have the same problem with cpufreqd when running the /etc/init.d script. When I run it from the command line it starts flawlessly.

Because I have a T400 I applied the patch in this bug: https://bugs.gentoo.org/show_bug.cgi?id=346399

I really like cpufreqd because I can monitor the temperature of my system and the programs that are running (like folding at home)

I added the command in the local.start script :)

I hope that helps
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sun Mar 25, 2012 7:51 pm    Post subject: Reply with quote

Lezard wrote:
I have the same problem with cpufreqd when running the /etc/init.d script. When I run it from the command line it starts flawlessly.

Because I have a T400 I applied the patch in this bug: https://bugs.gentoo.org/show_bug.cgi?id=346399

I really like cpufreqd because I can monitor the temperature of my system and the programs that are running (like folding at home)

I added the command in the local.start script :)

I hope that helps


crashed again.
after checking the message, it shows

Mar 25 21:36:31 PD cpufreqd: acpi_battery_init : Couldn't open BAT attributes
Mar 25 21:36:31 PD cpufreqd: get_class_device_attribute: couldn't open /sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT/current_now (No such file or directory)

it seems that there is a problem with the workings of acpi on my laptop.
There are always acpi issues on my laptop, not only with that but also with my fan working....
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Mar 25, 2012 11:31 pm    Post subject: Reply with quote

pd1986,

That directory is created by acpid. Do you have sys-power/acpid installed and acpid in the boot runlevel?

Also check your configuration's HID_SUPPORT
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Mon Mar 26, 2012 7:52 am    Post subject: Reply with quote

BillWho wrote:
pd1986,

That directory is created by acpid. Do you have sys-power/acpid installed and acpid in the boot runlevel?

Also check your configuration's HID_SUPPORT


yes, acpid is installed, and put in the boot runlevel. HID_SUPPORT is chosen as built-in too.
I don't know where the problem is.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2583

PostPosted: Mon Mar 26, 2012 12:28 pm    Post subject: Reply with quote

Let's start with some basics...

What kind of CPU do you have? Your initial post makes it look like you have a dual-core, but something later looks like quad-core. Nothing yet has told me the brand. Could you post the results of "cat /proc/cpuinfo"?

I also notice that it looks like your kernel config shotguns the cpufreq drivers, but have you preloaded anything in "/etc/conf.d/modules"? You're not going to get anything to run for frequency modulation if the right driver isn't loaded first. (I bumped into this one just this weekend, because the 3.x kernel series effectively "lost" a digit, and I forget to update my module configuration every "one-tenth" kernel update.)

Finally, even though something like cpufreqd is more capable, I had been opting for the simpler cpufreq-utils and found "ondemand" to be quite reliable. So much so in fact that I've taken to just setting ondemand to my default governor, and don't bother running cpufreq-utils any more, though it's still installed and cpufreq-info is handy to have around. Now that I mention it, I could get around my /etc/conf.d/modules update problem by just building powernow-k8 into the kernel instead of as a module.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Wed Mar 28, 2012 9:34 pm    Post subject: Reply with quote

depontius wrote:
Let's start with some basics...

What kind of CPU do you have? Your initial post makes it look like you have a dual-core, but something later looks like quad-core. Nothing yet has told me the brand. Could you post the results of "cat /proc/cpuinfo"?

I also notice that it looks like your kernel config shotguns the cpufreq drivers, but have you preloaded anything in "/etc/conf.d/modules"? You're not going to get anything to run for frequency modulation if the right driver isn't loaded first. (I bumped into this one just this weekend, because the 3.x kernel series effectively "lost" a digit, and I forget to update my module configuration every "one-tenth" kernel update.)

Finally, even though something like cpufreqd is more capable, I had been opting for the simpler cpufreq-utils and found "ondemand" to be quite reliable. So much so in fact that I've taken to just setting ondemand to my default governor, and don't bother running cpufreq-utils any more, though it's still installed and cpufreq-info is handy to have around. Now that I mention it, I could get around my /etc/conf.d/modules update problem by just building powernow-k8 into the kernel instead of as a module.


sorry to reply late, I was very busy in the last several days, and I just updated the kernel version hoping that the problem would be solved, Unfortunately it's not.

it's dual-core, here is the cat /proc/cpuinfo
Quote:
# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T6500 @ 2.10GHz
stepping : 10
microcode : 0xa07
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts
bogomips : 4190.01
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Intel(R) Core(TM)2 Duo CPU T6500 @ 2.10GHz
stepping : 10
microcode : 0xa07
cpu MHz : 2100.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dts
bogomips : 4189.94
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:


this is information about my .config about "cpufreq"
Quote:
# grep -i "cpufreq" .config
# CONFIG_X86_PCC_CPUFREQ is not set
CONFIG_X86_ACPI_CPUFREQ=y


I add nothing in /etc/conf.d/modules,
lsmod returns the modules that is installed automatically, like sound card driver, fcitx(asian input method).

it seems that the modulation works well with the preinstalled cpufreq driver (acpi-cpufreq)
after updating the kernel, nothing is fixed. Neither cpufreqd nor fan problem
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2583

PostPosted: Thu Mar 29, 2012 2:27 pm    Post subject: Reply with quote

pd1986 wrote:

this is information about my .config about "cpufreq"
Quote:
# grep -i "cpufreq" .config
# CONFIG_X86_PCC_CPUFREQ is not set
CONFIG_X86_ACPI_CPUFREQ=y


I add nothing in /etc/conf.d/modules,
lsmod returns the modules that is installed automatically, like sound card driver, fcitx(asian input method).

it seems that the modulation works well with the preinstalled cpufreq driver (acpi-cpufreq)
after updating the kernel, nothing is fixed. Neither cpufreqd nor fan problem


You have the acpi cpufreq driver built right into the kernel, so you need not load any module. That makes this sound like a cpufreqd configuration problem. Have you tried using cpufrequtils as an alternative, just to make sure modulation is working properly?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Thu Mar 29, 2012 2:36 pm    Post subject: Reply with quote

depontius wrote:
pd1986 wrote:

this is information about my .config about "cpufreq"
Quote:
# grep -i "cpufreq" .config
# CONFIG_X86_PCC_CPUFREQ is not set
CONFIG_X86_ACPI_CPUFREQ=y


I add nothing in /etc/conf.d/modules,
lsmod returns the modules that is installed automatically, like sound card driver, fcitx(asian input method).

it seems that the modulation works well with the preinstalled cpufreq driver (acpi-cpufreq)
after updating the kernel, nothing is fixed. Neither cpufreqd nor fan problem


You have the acpi cpufreq driver built right into the kernel, so you need not load any module. That makes this sound like a cpufreqd configuration problem. Have you tried using cpufrequtils as an alternative, just to make sure modulation is working properly?


You mean that I should installed it as module? This method really makes the alsa find my sound card driver, but not sure if it works for cpufreq
I didn't install cpufrequtils, but when I installed cpufreqd, it installed automatically cpufrequtils with the version different from the that if I install cpufrequtils independently.

I think I'm pretty sure that the modulation is working. I checked it when I compiled libreoffice. the frequency varied by itself.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2583

PostPosted: Thu Mar 29, 2012 7:25 pm    Post subject: Reply with quote

pd1986 wrote:

You mean that I should installed it as module? This method really makes the alsa find my sound card driver, but not sure if it works for cpufreq
I didn't install cpufrequtils, but when I installed cpufreqd, it installed automatically cpufrequtils with the version different from the that if I install cpufrequtils independently.

I think I'm pretty sure that the modulation is working. I checked it when I compiled libreoffice. the frequency varied by itself.


Sounds like you got cpu frequency modulation properly configured and working. I wouldn't change to a module, in fact I'm thinking now that I should move mine from module to in-kernel, since I always use it. I'm not sure what your problem is, at this point.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Thu Mar 29, 2012 7:42 pm    Post subject: Reply with quote

depontius wrote:
pd1986 wrote:

You mean that I should installed it as module? This method really makes the alsa find my sound card driver, but not sure if it works for cpufreq
I didn't install cpufrequtils, but when I installed cpufreqd, it installed automatically cpufrequtils with the version different from the that if I install cpufrequtils independently.

I think I'm pretty sure that the modulation is working. I checked it when I compiled libreoffice. the frequency varied by itself.


Sounds like you got cpu frequency modulation properly configured and working. I wouldn't change to a module, in fact I'm thinking now that I should move mine from module to in-kernel, since I always use it. I'm not sure what your problem is, at this point.


so cpufreqd is not necessary?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum