Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-libs/talloc-2.0.5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Reinder
n00b
n00b


Joined: 27 Aug 2004
Posts: 47
Location: Netherlands

PostPosted: Sun Mar 06, 2011 10:09 am    Post subject: sys-libs/talloc-2.0.5 Reply with quote

while doing "emerge --update --deep --newuse world" talloc got some errors, what can I do to solve this?

Code:
# emerge -pqv =sys-libs/talloc-2.0.5
[ebuild     U ] sys-libs/talloc-2.0.5 [2.0.1-r1] USE="python%* -compat (-doc%) (-static-libs%*) (-swig%)"


Code:
# cat build.log
 * Package:    sys-libs/talloc-2.0.5
 * Repository: gentoo
 * Maintainer: patrick@gentoo.org samba@gentoo.org
 * USE:        elibc_glibc kernel_linux python userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking talloc-2.0.5.tar.gz to /var/tmp/portage/sys-libs/talloc-2.0.5/work
>>> Source unpacked in /var/tmp/portage/sys-libs/talloc-2.0.5/work
>>> Preparing source in /var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5 ...
CCFLAGS="-O2 -march=i686 -pipe" LINKFLAGS="-Wl,-O1 -Wl,--as-needed" "/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/buildtools/bin/waf" --prefix=/usr --libdir=/usr/lib  configure
/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/wscript: error: Traceback (most recent call last):
  File "/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/buildtools/bin/.waf3-1.5.19-64e3c2006c565edf6967cdbf2812184e/wafadmin/Utils.py", line 199, in load_module
    exec(compile(code,file_path,'exec'),module.__dict__)
  File "/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5/wscript", line 20, in <module>
    import wafsamba, samba_dist, Options
  File "./buildtools/wafsamba/wafsamba.py", line 28, in <module>
    import samba_dist
  File "./buildtools/wafsamba/samba_dist.py", line 134
    except Exception, e:
                    ^
SyntaxError: invalid syntax

 * ERROR: sys-libs/talloc-2.0.5 failed (configure phase):
 *   configure failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2404:  Called waf-utils_src_configure
 *   environment, line 2989:  Called die
 * The specific snippet of code:
 *       CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "--libdir=${EPREFIX}/usr/$(get_libdir)" "$@" configure || die "configure failed"
 *
 * If you need support, post the output of 'emerge --info =sys-libs/talloc-2.0.5',
 * the complete build log and the output of 'emerge -pqv =sys-libs/talloc-2.0.5'.
 * The complete build log is located at '/var/tmp/portage/sys-libs/talloc-2.0.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/talloc-2.0.5/temp/environment'.
 * S: '/var/tmp/portage/sys-libs/talloc-2.0.5/work/talloc-2.0.5'
Back to top
View user's profile Send private message
Rexilion
Veteran
Veteran


Joined: 17 Mar 2009
Posts: 1044

PostPosted: Sun Mar 06, 2011 12:16 pm    Post subject: Reply with quote

Hello,

Could you please show me the output of the following command (as root):

Code:
eselect python list


It could be that you have a newer version of python activated which is not suitable for this version of talloc.
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Sun Mar 06, 2011 12:18 pm    Post subject: Reply with quote

Report a bug [and|or] mask the version?

//edit: :D

http://bugs.gentoo.org/show_bug.cgi?id=354587

Code:
# eselect python list

python 3 should not be default (not ready yet)
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
Reinder
n00b
n00b


Joined: 27 Aug 2004
Posts: 47
Location: Netherlands

PostPosted: Sun Mar 06, 2011 12:33 pm    Post subject: Reply with quote

Rexilion wrote:
Hello,

Could you please show me the output of the following command (as root):

Code:
eselect python list


It could be that you have a newer version of python activated which is not suitable for this version of talloc.


Code:
# eselect python list
Available Python interpreters:
  [1]   python2.6
  [2]   python3.1 *


So I should change this to the python 2.6?
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Sun Mar 06, 2011 12:38 pm    Post subject: Reply with quote

Jupp, check "eselect news list"...

Quote:
Python 3 is a new major version of Python and is intentionally incompatible
with Python 2. Many external modules have not been ported yet to Python 3,
so Python 2 still needs to be installed. You can benefit from having Python 3
installed without setting Python 3.1 as main active version of Python.
Currently you should not set Python 3.1 as main active version of Python.
When setting it becomes recommended, a separate news item will be created
to notify users.

_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
Reinder
n00b
n00b


Joined: 27 Aug 2004
Posts: 47
Location: Netherlands

PostPosted: Sun Mar 06, 2011 12:43 pm    Post subject: Reply with quote

Thanks for the help all, it's compiling again :)
Back to top
View user's profile Send private message
davidm
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2009
Posts: 121
Location: US

PostPosted: Thu Mar 10, 2011 9:40 pm    Post subject: Reply with quote

Interesting. I encountered the same error while doing a new install from scratch (I'm giving Gentoo another shot, this time on my main desktop). I saw the news item but did not think it would automatically select the new python itself. I am running global ~x86 though so perhaps that is as intended?
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2336
Location: /home/zach

PostPosted: Fri Mar 11, 2011 1:02 am    Post subject: Reply with quote

As far as I know, that is the intended result. However, as previously stated in this thread, python-3.* is not ready yet, so the best bet is to eselect a 2.* version of python for the time being.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 669

PostPosted: Fri Mar 11, 2011 4:37 pm    Post subject: Reply with quote

Don't feel bad. Some recent stage3 builds had python 3.1 set as the default system python. Bit me too.
_________________
My political bias.
Back to top
View user's profile Send private message
wolf_99
Apprentice
Apprentice


Joined: 22 Oct 2003
Posts: 213

PostPosted: Fri Mar 02, 2012 4:42 pm    Post subject: Reply with quote

Getting a different error:

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-libs/talloc-2.0.7::gentoo, ebuild scheduled for merge) pulled in by
sys-libs/talloc required by (net-fs/samba-3.5.11::gentoo, installed)

Any ideas?
_________________
To err is human. To really fuck up, use a computer.
Back to top
View user's profile Send private message
Trog Dog
Apprentice
Apprentice


Joined: 04 Aug 2007
Posts: 282

PostPosted: Fri Mar 02, 2012 10:55 pm    Post subject: Reply with quote

unmerge talloc, then rerun your previous command, then follow up with revdep-rebuild (to be sure) - the new version of talloc will get pulled in
_________________
CIC1=CC=C(C2=N[C@@H](CC(OC(C)(C)C)=O)C3=NN=C(C)N3C4=C2C(C)=C(C)S4)C=C1
Back to top
View user's profile Send private message
wolf_99
Apprentice
Apprentice


Joined: 22 Oct 2003
Posts: 213

PostPosted: Tue Apr 10, 2012 10:33 am    Post subject: Reply with quote

unmerging talloc did the trick!

Thanks.
_________________
To err is human. To really fuck up, use a computer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum