Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DRI on alpha XP1000
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Mon Oct 08, 2007 1:35 pm    Post subject: DRI on alpha XP1000 Reply with quote

I have a Radeon 9100 (r200 based) video card in my XP1000. It has 64 MB of RAM on it. DRI is working just fine with this card, but it's not the fastest thing in the world. (About 580 fps in glxgears).

Does anyone know what is the newest/fastest video card that works with DRI on Alpha platforms? There surely must be something better than this radeon 9100...

TIA
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)


Last edited by Lupin_the_3rd on Fri Oct 12, 2007 4:43 am; edited 1 time in total
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2395

PostPosted: Tue Oct 09, 2007 2:18 pm    Post subject: Reply with quote

the xorg drivers should tell you which chips they support.
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Tue Oct 09, 2007 2:40 pm    Post subject: Reply with quote

alex.blackbit wrote:
the xorg drivers should tell you which chips they support.


Quite true, although that's a completely different thing from which boards work with DRI or not, which was my question.
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Mon Mar 24, 2008 4:17 am    Post subject: Reply with quote

Sorry to bring up a dead thread, but I saw the question wasn't answered.

Wikipedia has a table of Radeon cores. http://en.wikipedia.org/wiki/Comparison_of_ATI_Graphics_Processing_Units#Radeon_R200_series

I assume your box only has PCI slots (ie, no AGP). If this is the case, then R200 Radeons are the newest you can get. From that chart, it looks like the Radeon 9100 is the fastest available card. (Radeon 9100 is also extremely hard to find)

Edit: no they're not. See below

Have you tried running Quake 3? If so, how does it perform?


Last edited by mattst88 on Wed Apr 02, 2008 8:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Mon Mar 24, 2008 3:24 pm    Post subject: Reply with quote

Yes, I do have a PCI Radeon 9100. (No AGP on this machine) It works well with DRI and gets very nice FPS on the GLX screen savers. I have not tried Quake3 or any other games.
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Wed Apr 02, 2008 8:34 pm    Post subject: Reply with quote

It seems there are R500 based PCI Radeons. News to me.

http://products.amd.com/en-us/GraphicCardFilter.aspx <-- Select Bus Type: PCI

There are X1050, X1300, and X1550 Radeons!

Search eBay for "x1550 pci -express -'pci-e'" to find X1550s.

Now, R500 3D support is still in development, and radeonfb wont work with R500s, but once support is there, they may be faster than a 9100. The hardware itself obviously is faster and supports many more features.

I bought a DS20L (Dual 833 MHz, 2GB RAM) and an X1550 PCI card. Once I get them and school affords me enough time to tinker, I'll let you know how it goes.

On another note, EXA is completely supported on R500, along with textured video. Kernel level modesetting for all Radeons should be finished in the next year, and by then 3D support for R500 should be at a level comparable to that of R300/R400 currently.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Mon May 12, 2008 6:12 pm    Post subject: Reply with quote

I've had some trouble with the X1550. See bugs:

http://bugzilla.kernel.org/show_bug.cgi?id=10652
http://bugs.freedesktop.org/show_bug.cgi?id=15520
http://bugs.freedesktop.org/show_bug.cgi?id=15699
http://bugs.freedesktop.org/show_bug.cgi?id=15521

In light of this, I bought a Radeon 9100 (250 MHz core and memory) with 64 MB RAM. Using the following xorg.conf settings, glxgears reports in the neighborhood of 750 FPS.

Code:
        Option "RenderAccel" "on"
        Option "AccelMethod" "EXA"
        Option "AccelDFS" "on"
        Option "EnablePageFlip" "on"
        Option "ColorTiling" "on"
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Mon Dec 31, 2012 6:01 am    Post subject: Reply with quote

mattst88 wrote:
I've had some trouble with the X1550. See bugs:

http://bugzilla.kernel.org/show_bug.cgi?id=10652
http://bugs.freedesktop.org/show_bug.cgi?id=15520
http://bugs.freedesktop.org/show_bug.cgi?id=15699
http://bugs.freedesktop.org/show_bug.cgi?id=15521

In light of this, I bought a Radeon 9100 (250 MHz core and memory) with 64 MB RAM. Using the following xorg.conf settings, glxgears reports in the neighborhood of 750 FPS.

Code:
        Option "RenderAccel" "on"
        Option "AccelMethod" "EXA"
        Option "AccelDFS" "on"
        Option "EnablePageFlip" "on"
        Option "ColorTiling" "on"


Arise thread! Come back from the dead! :lol:

Browsing those bug report links, they all appear to have been resolved? I'm still using Radeon 9100 in both my XP1000's. Is it safe to upgrade to an X1550 or even an HD 2400 now? It seems the bugs have all been worked out, and the card should "just work" as the 9100 does?
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1658
Location: Berlin, Germany

PostPosted: Mon Dec 31, 2012 5:50 pm    Post subject: Reply with quote

I think one major bug remains https://bugs.freedesktop.org/show_bug.cgi?id=26403

The fastest PCI Radeon cards are the 5450s from Club3D, PowerColor and HIS. And there is a PCI GeForce 8400 from Sparkle. But they are not sold into all markets and are quite expensive.
Back to top
View user's profile Send private message
mattst88
Developer
Developer


Joined: 28 Oct 2004
Posts: 362

PostPosted: Fri Jan 11, 2013 2:06 am    Post subject: Reply with quote

Lupin_the_3rd wrote:
Arise thread! Come back from the dead! :lol:

Browsing those bug report links, they all appear to have been resolved? I'm still using Radeon 9100 in both my XP1000's. Is it safe to upgrade to an X1550 or even an HD 2400 now? It seems the bugs have all been worked out, and the card should "just work" as the 9100 does?


Yeah, Kernel modesetting works. I've seen people with 5450s :)
_________________
My 1U Dual 833 MHz Alphaserver DS20L
The AlphaLinux.org Wiki
Back to top
View user's profile Send private message
LinuxFreakus
n00b
n00b


Joined: 23 Jan 2004
Posts: 30

PostPosted: Sat Jan 26, 2013 3:59 pm    Post subject: Reply with quote

I've had an old Radeon 9250 thats been laying around for a while, I have never been able to get it working in my AS1200 though because it does not support SRM firmware newer than what I've got on there already.

Just scored an ES40 on ebay for $190 shipped which I'm quite excited about. I am hoping the 9250 will work in there :)

I'll know more once I've had time to get it up and running, but I'll confirm in here one way or another.
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Sat Jan 26, 2013 5:53 pm    Post subject: Reply with quote

$190 shipped for an ES40? Wow. I'm guessing the auction price was $1, with $189 in shipping? :lol: Those things are way big and heavy.
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
LinuxFreakus
n00b
n00b


Joined: 23 Jan 2004
Posts: 30

PostPosted: Sat Jan 26, 2013 7:23 pm    Post subject: Reply with quote

Lupin_the_3rd wrote:
$190 shipped for an ES40? Wow. I'm guessing the auction price was $1, with $189 in shipping? :lol: Those things are way big and heavy.


Hehe, I know... no reserve and it said free shipping... seller might be regretting that now, but its not my problem :)

It says the weight is 180 lbs, which is not too terrible, the specs on the hp site say some configurations can be up to 260 lbs. I ordered a large generator from amazon last year and got free shipping with amazon prime... thing was so heavy the UPS guy was cursing at me when it came.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum