Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.4.0
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 478
Location: Scotland

PostPosted: Mon Jul 16, 2012 12:39 pm    Post subject: Reply with quote

UPDATE

I have unmasked the gnome-3.4.2 packages in portage. (Dodgy I know)
But so far I have not had any problems.
3.4.2 is working well.
Gnome-Documents-0.4.2 still doesn't work, and Desktop search shell just freezes as soon as you enter a search term, or click on a icon.
But apart from that, all is good. Kinda. :lol:
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 351
Location: Stockholm, Sweden

PostPosted: Wed Aug 08, 2012 8:40 am    Post subject: Reply with quote

I've been using Gnome 3.* for a couple of months now, and it's working great for me. No huge regressions or instabilities, I think I'm still on 3.2, but some packages might have been updated to 3.4.

Seems like 3.4.2 is in portage now, marked as unstable but not masked. Weird, I think all of Gnome 3.4 was masked for me three weeks ago (but I don't see signs of that in the Changelog).
http://en.znurt.org/gnome-base/gnome-shell

EDIT: Hmm, but on the official package it states it's still masked. I don't understand why Znurt doesn't mark it as masked..
http://packages.gentoo.org/package/gnome-base/gnome-shell
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 478
Location: Scotland

PostPosted: Wed Aug 08, 2012 4:47 pm    Post subject: Reply with quote

Yep about half the 3.4.2 packages are still masked.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1952
Location: Poland

PostPosted: Thu Aug 09, 2012 8:05 am    Post subject: Reply with quote

Anybody would like to share unmask file?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Thu Aug 09, 2012 8:26 am    Post subject: Reply with quote

mbar wrote:
Anybody would like to share unmask file?


there you go, i just used the main mask as you can see :

Code:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=app-accessibility/accerciser-3.4*
=app-accessibility/at-spi2-atk-2.4*
=app-accessibility/at-spi2-core-2.4*
=app-accessibility/orca-3.4*
=app-admin/gnome-system-log-3.4*
=app-crypt/gcr-3.4*
=app-crypt/seahorse-3.4*
=app-dicts/gnome-dictionary-3.4*
=app-misc/tracker-0.14*
>=dev-libs/folks-0.6.8
=dev-libs/libgdata-0.12*
=dev-libs/totem-pl-parser-3*
=dev-util/gnome-devel-docs-3.4*
=dev-python/pyatspi-2.4*
=gnome-base/gdm-3.4*
=gnome-base/gnome-control-center-3.4*
=gnome-base/gnome-core-apps-3.4*
=gnome-base/gnome-core-libs-3.4*
=gnome-base/gnome-desktop-3.4*
=gnome-base/gnome-extra-apps-3.4*
=gnome-base/gnome-fallback-3.4*
=gnome-base/gnome-3.4*
=gnome-base/gnome-keyring-3.4*
=gnome-base/gnome-light-3.4*
=gnome-base/gnome-menus-3.4*
=gnome-base/gnome-panel-3.4*
=gnome-base/gnome-power-manager-3.4*
=gnome-base/gnome-session-3.4*
=gnome-base/gnome-settings-daemon-3.4*
=gnome-base/gnome-shell-3.4*
=gnome-base/libgnome-keyring-3.4*
=gnome-base/libgnomekbd-3.4*
=gnome-base/nautilus-3.4*
=gnome-extra/evolution-data-server-3.4*
=gnome-extra/evolution-ews-3.4*
=gnome-extra/evolution-exchange-3.4*
=gnome-extra/evolution-groupwise-3.4*
=gnome-extra/gnome-color-manager-3.4*
=gnome-extra/gnome-contacts-3.4*
=gnome-extra/gnome-documents-0.4*
=gnome-extra/gnome-games-3.4*
=gnome-extra/gnome-search-tool-3.4*
=gnome-extra/gnome-shell-extensions-3.4*
>=gnome-extra/gnome-tweak-tool-3.3
=gnome-extra/gnome-user-docs-3.4*
=gnome-extra/gnome-utils-3.4*
=gnome-extra/mousetweaks-3.4*
=gnome-extra/nautilus-tracker-tags-0.14*
=gnome-extra/seahorse-nautilus-3.4*
=gnome-extra/sushi-0.4*
=mail-client/evolution-3.4*
=media-gfx/gnome-font-viewer-3.4*
=media-gfx/gnome-screenshot-3.4*
=media-video/cheese-3.4*
=media-video/totem-3.4*
=net-im/empathy-3.4*
=net-libs/gnome-online-accounts-3.4*
>=net-libs/telepathy-farstream-0.2
=net-wireless/gnome-bluetooth-3.4*
=sys-apps/baobab-3.4*
=x11-libs/libcryptui-3.4*
=x11-libs/libwnck-3.4*
>=x11-wm/metacity-2.34.2
=x11-wm/mutter-3.4*
>=x11-themes/zukitwo-shell-2012.04.24
# New clutter API breaks almost everything
=media-libs/cogl-1.10*
=media-libs/clutter-1.10*
=media-libs/clutter-gtk-1.2*
=media-libs/clutter-gst-1.5*
=media-libs/clutter-gst-1.6*
# Needs gst-plugins-flac-0.10.31 + commit 265a5bfa to write seekable flac files
=media-sound/sound-juicer-3.4*


install first the new clutter, which will break a few packages, and install the rest afterwards.

cheers
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1952
Location: Poland

PostPosted: Fri Aug 10, 2012 3:46 am    Post subject: Reply with quote

thanks, what about mx? it was breaking the 3.4 build from the gnome-overlay for me (I also had to emerge it at the beginning).

EDIT: I see that mx isn't upgraded in portage.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Fri Aug 10, 2012 7:32 am    Post subject: Reply with quote

no problems here with mx, i have 1.4.2 installed :

Code:
Keywords for x11-libs/mx:
         |                           | u     | 
         | a a             p     s   | n     | 
         | l m   h i m m   p s   p   | u s   | r
         | p d a p a 6 i p c 3   a x | s l   | e
         | h 6 r p 6 8 p p 6 9 s r 8 | e o   | p
         | a 4 m a 4 k s c 4 0 h c 6 | d t   | o
---------+---------------------------+-------+-------
  1.1.12 | o ~ o o o o o o o o o o ~ | # 1.0 | gentoo
   1.2.1 | o ~ o o o o o o o o o o ~ | #     | gentoo
   1.3.1 | o ~ o o o o o o o o o o ~ | #     | gentoo
[I]1.4.2 | ~ ~ o o o o o ~ o o o o ~ | o     | gentoo


cheers
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 351
Location: Stockholm, Sweden

PostPosted: Fri Aug 17, 2012 2:31 pm    Post subject: Reply with quote

http://dev.gentoo.org/~nirbheek/gnome/3.4/status.html

Any chance that list will ever get updated? It would be nice. 5 packages needing update, and that's almost 3 months ago.
Code:

gst-plugins-base    0.10.35    0.10.36    0.10.36
gst-plugins-good    0.10.30    0.10.31    0.10.31
gstreamer           0.10.35    0.10.36    0.10.36
libgdata            0.12.0     0.13.0     0.12.0


This information still seems valid though. The only package that has been updated (but is still hardmasked) is Aisleriot. Not the most exciting update.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 566

PostPosted: Fri Aug 17, 2012 11:03 pm    Post subject: Reply with quote

Yes, I'm wondering about the status of gnome 3.4 (and gstreamer too) as well. Is there anything that non-devs can do to help speed things along? Gentoo is really behind with regards to gnome.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 351
Location: Stockholm, Sweden

PostPosted: Sat Aug 18, 2012 10:32 am    Post subject: Reply with quote

epsilon72 wrote:
Yes, I'm wondering about the status of gnome 3.4 (and gstreamer too) as well. Is there anything that non-devs can do to help speed things along? Gentoo is really behind with regards to gnome.


I guess updating the ebuild in our own local overlay and testing it out would be one thing we all could do. Then just submit it in bugzilla as a version bump request (unless there already is one, which there might be). Usually updating an ebuild is just renaming it to the new version and running ebuild *.ebuild digest.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 463
Location: London, UK

PostPosted: Tue Aug 21, 2012 8:22 pm    Post subject: Reply with quote

gringo wrote:
no problems here with mx, i have 1.4.2 installed :
cheers


Me too. Totem didn't install, but rebuilding mx (also version 1.4.2) solved it. All fine now.
used the unmask file posted earlier.

Mons
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 351
Location: Stockholm, Sweden

PostPosted: Tue Aug 28, 2012 8:35 pm    Post subject: Reply with quote

Seems like they've gone for version 3.5.5 straight away...

Code:
[U] gnome-base/gnome-shell
     Available versions:  (~)3.2.2.1 [M](~)3.4.1 [M](~)3.4.2 (~)3.5.5[1] **9999[1] {{+bluetooth +networkmanager systemd}}
     Installed versions:  3.2.2.1(14:37:01 2012-03-11)(bluetooth networkmanager)
     Homepage:            http://live.gnome.org/GnomeShell
     Description:         Provides core UI functions for the GNOME 3 desktop


It is via gnome-overlay though.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum