Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved}pulseaudio: Daemon startup failed.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
troglodytus
n00b
n00b


Joined: 10 Sep 2011
Posts: 33

PostPosted: Wed Aug 29, 2012 12:20 am    Post subject: [Solved}pulseaudio: Daemon startup failed. Reply with quote

I'm trying to run pavucontrol but when i try to do so it says the pulseaudio server hasn't started
when i try to run pulseaudio --start i get this

E: [pulseaudio] main.c: Daemon startup failed.


When i try to run pulseaudio without any parameters i get this
pulseaudio
W: [pulseaudio] module.c: module-combine is deprecated: Please use module-combine-sink instead of module-combine!
W: [pulseaudio] module-combine.c: We will now load module-combine-sink. Please make sure to remove module-combine from your configuration.
E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

is there anything i can do to get the daemon started?


Last edited by troglodytus on Sat Sep 01, 2012 7:37 am; edited 1 time in total
Back to top
View user's profile Send private message
jgascon
Apprentice
Apprentice


Joined: 08 Dec 2006
Posts: 252

PostPosted: Wed Aug 29, 2012 7:31 pm    Post subject: Re: pulseaudio: Daemon startup failed. Reply with quote

It seems that the problem is here:

Quote:

E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.


Have you checked whether the dbus and consolekit services are started?

Code:

localhost ~ # /etc/init.d/dbus status
 * status: started
localhost ~ # /etc/init.d/consolekit status
 * status: started
Back to top
View user's profile Send private message
troglodytus
n00b
n00b


Joined: 10 Sep 2011
Posts: 33

PostPosted: Sat Sep 01, 2012 7:39 am    Post subject: Thanks for the reply Reply with quote

followed your instructions and found out consolekit wasn't installed on the machine. After doing that pulse audio starts up fine
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum