Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Diablo 3]Unexpected error (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 22, 2012 5:47 pm    Post subject: [Diablo 3]Unexpected error (résolu) Reply with quote

Bonsoir à tous,

Je viens vers vous pour un souci avec mon installation de Diablo 3. J'ai suivi tous les conseils du site de wine (patcher wine, installer vcrun 2008, etc.) mais j'ai toujours un message "the application encountered an unexpected error" lorsque je lance une partie (c'est-à-dire que je me connecte bien au serveur, je choisi mon personnage, je clique sur "jouer" et ça plante pendant le chargement).
J'ai essayé d'installer dans un wineprefix propre (WINEARCH=32bits WINEPREFIX=~/.wine-diablo), puis d'installer vcrun2008 et enfin de mettre msvcp90 et msvcr90 sur "native" mais rien n'y fait, toujours ce message d'erreur. J'ai pensé que le problème pouvait venir du fait que j'utilise le driver libre ati (xf86-video-ati) au lieu du propriétaire, mais le jeu n'affiche aucun message disant que je dois mettre à jour et toutes les cinématiques passent sans difficulté. Du côté du terminal, aucun message intéressant a priori. Les dernier messages sont les suivants :
Code:
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:dbghelp:elf_search_auxv can't find symbol in module
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wininet:CommitUrlCacheEntryInternal entry already in cache - don't know what to do!
Handle Event: "auth validation event"
Handle Event: "auth validation event"
Registered Periodic Event: "shutdown event" with a resolution of 10000 and a start delay of 0
Handle Event: "shutdown event"
Handle Event: "auth validation event"
Agent is shutting down


Je ne vois plus dans quelle direction chercher...
Ma carte graphique :
Code:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570]

Un emerge --info au cas où :
Code:
KevinPC linux # emerge --info
Portage 2.1.10.62 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.15-r2, 3.3.5-gentoo x86_64)
=================================================================
System uname: Linux-3.3.5-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 22 May 2012 08:15:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo kde-sunset wirelay arcon mozilla sekyfsr AzP miramir x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0 --with-bdeps y"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ rsync://de-mirror.org/gentoo/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="fr fr_FR"
MAKEOPTS="-j5 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset /var/lib/layman/wirelay /var/lib/layman/arcon /var/lib/layman/mozilla /var/lib/layman/sekyfsr /var/lib/layman/AzP /var/lib/layman/miramir /usr/local/portage"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 amr bash-completion berkdb bluetooth branding bzip2 cdda cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx dbus djvu dri dvd dvdr encode ffmpeg flac fortran ftp gdbm gif gimp gphoto2 gpm gtk handbook iconv imap ipv6 jack java jpeg lcms mad mime mmx mng modules mozilla mp3 mpeg msn mudflap multilib mysql ncurses nls nptl nsplugin ogg opencore-amr opengl openmp pam pcre pdf perl php png pppd python rar raw readline scanner session smp source speex spell sql sse sse2 ssl svg symlink tcpd tiff truetype type1 unicode usb v4l v4l2 vcd videos webkit wifi xcomposite xml xorg xscreensaver xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

La version de wine :
Code:
KevinPC linux # emerge -av wine

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] app-emulation/wine-9999  USE="X alsa cups gecko gnutls gphoto2 jpeg lcms mp3 ncurses nls opengl oss perl png samba scanner ssl threads truetype v4l win32 win64 xcomposite xml -capi -custom-cflags -fontconfig -gsm (-gstreamer) -hardened -ldap -odbc -openal -opencl (-selinux) -test -udisks -xinerama" 31,539 kB

Et la version du driver :
Code:
KevinPC linux # emerge -av xf86-video-ati

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-drivers/xf86-video-ati-6.14.4-r1  1,083 kB


Merci d'avance!

Kevin
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français


Last edited by Kevin57 on Thu Jun 14, 2012 6:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5611
Location: ~Brussels - Belgique

PostPosted: Tue May 22, 2012 7:20 pm    Post subject: Reply with quote

Salut,

As-tu vu ce message : http://forums.gentoo.org/viewtopic-t-923504-highlight-.html ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue May 22, 2012 10:58 pm    Post subject: Reply with quote

Je l'ai parcouru des yeux mais j'avais cru comprendre qu'il reprenait les patchs de wine indiqués sur le site winehq.org, ce n'est pas le cas?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5611
Location: ~Brussels - Belgique

PostPosted: Wed May 23, 2012 6:34 am    Post subject: Reply with quote

Je ne sais pas, je l'ai lu en diagonale, et voyant qu'il parlait du même jeu que toi, j'ai donné le lien.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed May 23, 2012 9:13 am    Post subject: Reply with quote

Je viens de le lire plus en détail, je pense qu'il utilise simplement les patchs mais j'essaierai tout de même. En attendant, si quelqu'un d'autre a une idée, je suis preneur!
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Wed May 23, 2012 11:30 am    Post subject: Reply with quote

Personnellement, je l'ai installé à l'aide de playonlinux, il y a un script d'install sur la version git qui installe toutes les dépendances nécessaires et un wine patché.
POL permet aussi de lancer le jeu.

Par contre j'ai entendu parlé de problémes avec des cartes graphiques ATI/AMD
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed May 23, 2012 11:33 am    Post subject: Reply with quote

J'ai le même bug avec POL.

Edit : J'ai aussi entendu parler des problème avec les cartes ATI mais comme les cinématiques et les premiers écrans s'affichent sans difficulté, je ne pense pas que ça vienne du GPU, si?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Thu May 24, 2012 8:17 am    Post subject: Reply with quote

je ne sais pas comment il se comporte, c'est un ami sous winwin qui me disait que le jeu refusait de s'installer ou de se lancer (mais je suspecte un peu de pebkac)
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 103

PostPosted: Fri Jun 01, 2012 3:46 pm    Post subject: Reply with quote

en effet, peut etre a regarder du coté ati, car j'ai fait l'install hier soir
et le jeu tourne bien, par contre, j'ai une carte nvidia.

wine 1.5.5 + les 4 patch.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Jun 02, 2012 4:49 pm    Post subject: Reply with quote

Tu utilises la version qui est sur l'overlay wine-diablo3?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 103

PostPosted: Mon Jun 04, 2012 8:22 am    Post subject: Reply with quote

Non, comme suggéré dans ce message, la version
de portage, avec les 4 patch dans le dossier /etc/portage/patches/app-emulation/wine.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Tue Jun 05, 2012 2:27 pm    Post subject: Reply with quote

OK merci pour l'information, j'essaie ça dès que je récupère mon PC et je reviens donner des nouvelles. Donc pour être bien sûr, tu as pris les 4 liens qui sont sous ce titre :
Quote:
"AcceptEx fix" patchset by Erich Hoover, "third" version (compatible and tested with Wine 1.5.5):

Et tu as aussi pris celui pour l'erreur D3D?
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 103

PostPosted: Wed Jun 06, 2012 8:26 am    Post subject: Reply with quote

Juste les 4 patchs pour AcceptEx fix pour wine 1.5.5
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Thu Jun 14, 2012 6:20 pm    Post subject: Reply with quote

Je n'ai pas pu me servir de mon ordinateur ces dernières semaines. Je viens de faire la mise à jour de wine (1.5.6) et depuis, tout semble marcher (à part le bug de D3D à chaque changement graphique), donc problème résolu. J'avais mal dû patcher wine... Merci tout de même pour l'aide!

Edit : si ça peut dépanner quelqu'un : malgré tout, ça continuait de lagger et de planter pendant le jeu (notamment les portails), même avec le driver proprio. J'ai dû, avec le driver proprio, modifier quelques configurations de wine avec winetricks :
- passer DirectDrawRenderer à gdi
- passer multisampling à enabled (mais je ne pense pas que celui-ci ait eu un grand effet). Depuis, tout semble marcher!
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum