Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Klawiatura i polskie znaki
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
dead_parrot
n00b
n00b


Joined: 26 Mar 2012
Posts: 12
Location: /EU/PL

PostPosted: Wed Mar 28, 2012 7:14 pm    Post subject: [SOLVED] Klawiatura i polskie znaki Reply with quote

Cześć,

Jestem świeżym użytkownikiem Gentoo, dlatego na początek proszę o wyrozumiałość. :oops:

Mam problem z lokalizacją systemu, a konkretnie z polsimi znakami na klawiaturze. Wynik locale wygląda u mnie następująco
Code:

LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=


Mapowanie klawiatury w xorg.conf wygląda następująco
Code:

Section "InputDevice"
<------>Identifier  "Keyboard0"
<------>Driver      "kbd".
<------>Option "XkbLayout"    "pl"
EndSection


no a polskich znaków nie ma. Pojawiają sie dopiero po zrobieniu
Code:

setxkbmap pl


Rozumiem, że można powyższe poleceniu wywołać w skryptach startowych, ale chciałbym zrozumiec co jest obecnie nie tak. Macie może jakieś pomysły co zrobiłem nie tak? Będę wdzięczny za wszelkie uwagi.

Pozdrawiam


Last edited by dead_parrot on Sat Mar 31, 2012 12:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2826

PostPosted: Wed Mar 28, 2012 8:19 pm    Post subject: Reply with quote

zobacz w Xorg.0.log czy Ci czasem nie ustawia klawiatury innym sterownikiem np. evdev i wtedy konfiguracja dla kbd nie smiga[/code].

Ja nie mam w ogole xorg.conf, mam za to /etc/X11/xorg.conf.d/ katalog a w nim plik keyboard.conf z:

Code:

Section "InputClass"
   Identifier   "keyboard-all"
   Option    "XkbOptions"  "lv3:ralt_switch_multikey"
   Driver      "evdev"
   Option      "XkbRules"  "xorg"
   Option      "XkbModel"  "pc105"
   Option      "XkbLayout" "pl"

   MatchIsKeyboard   "on"
EndSection


Powinno smigac.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
dead_parrot
n00b
n00b


Joined: 26 Mar 2012
Posts: 12
Location: /EU/PL

PostPosted: Thu Mar 29, 2012 7:09 pm    Post subject: Reply with quote

Dzięki! Wygląda na to, że miałeś rację. Skopiowałem Twoją konfigurację i śmiga. Musiałem tylko usunać

Code:

InputDevice    "Keyboard0" "CoreKeyboard"


z Section "ServerLayout".


Pytanie mam jeszcze takie, dlaczego nie chciało mi działać jak sobie tylko podmieniłem sterownik na evdev jak niżej:

Code:

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "evdev"
   Option "XkbLayout"    "pl"
EndSection

?
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2826

PostPosted: Thu Mar 29, 2012 8:06 pm    Post subject: Reply with quote

Pewnie matchiskeyboard jest istotne, dodaj SOLVED do tytulu tematu.

Swoja droga, jak nie masz nic konkretnego ustawione w xorg.conf to wywal go.

Ja mam kilka plikow z konfiguracja inputow jak keyboard, mouse, synaptic (touchpad) czy nvidia.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum