Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]emerge ibus error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Mon Mar 12, 2012 10:37 am    Post subject: [solved]emerge ibus error Reply with quote

ibus-1.3.9 works ok before.
But it does not work anymore after I update my system.(ibus-1.4.1)
So I uninstall it, and I want to reinstall it ..
But error happens:
Code:

Package ibus-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `ibus-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ibus-1.0' found
In file included from /var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1/src/ibus.h:28:0,
                 from <stdin>:4:
./ibusshare.h:39:18: fatal error: glib.h: No such file or directory
compilation terminated.
Error while processing the source.
make[4]: *** [IBus-1.0.gir] Error 1
make[4]: Leaving directory `/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1'
make: *** [all] Error 2
 * ERROR: app-i18n/ibus-1.4.1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =app-i18n/ibus-1.4.1',
 * the complete build log and the output of 'emerge -pqv =app-i18n/ibus-1.4.1'.
 * The complete build log is located at '/var/tmp/portage/app-i18n/ibus-1.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-i18n/ibus-1.4.1/temp/environment'.
 * S: '/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1'

>>> Failed to emerge app-i18n/ibus-1.4.1, Log file:

>>>  '/var/tmp/portage/app-i18n/ibus-1.4.1/temp/build.log'

 * Messages for package app-i18n/ibus-1.4.1:

 * ERROR: app-i18n/ibus-1.4.1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of 'emerge --info =app-i18n/ibus-1.4.1',
 * the complete build log and the output of 'emerge -pqv =app-i18n/ibus-1.4.1'.
 * The complete build log is located at '/var/tmp/portage/app-i18n/ibus-1.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-i18n/ibus-1.4.1/temp/environment'.



the output of emerge --info =app-i18n/ibus-1.4.1
Code:

nehc nehc # emerge --info =app-i18n/ibus-1.4.1
Portage 2.1.10.44 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-Intel-R-_Core-TM-_i3-2100_CPU_@_3.10GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 12 Mar 2012 07:45:02 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://mirrors.sohu.com/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.cn.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio python* qt3support readline sdl session socialweb sound spell sqlite sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Then I download the source code(ibus-1.4.1) , try to compile ibus from source code.
And I got this:
Code:

ibus-1.4.1 # make
make  all-recursive
make[1]: Entering directory `/home/nehc/Downloads/ibus-1.4.1'
Making all in src
make[2]: Entering directory `/home/nehc/Downloads/ibus-1.4.1/src'
  GEN    ibusmarshalers.h
  GEN    ibusmarshalers.c
  GEN    ibusenumtypes.h
  GEN    ibusenumtypes.c
make  all-recursive
make[3]: Entering directory `/home/nehc/Downloads/ibus-1.4.1/src'
Making all in .
make[4]: Entering directory `/home/nehc/Downloads/ibus-1.4.1/src'
  CC     ibusshare.lo
  CC     ibusobject.lo

..............................

  CC     ibusutil.lo
  CC     ibusmarshalers.lo
  CC     ibusenumtypes.lo
  CCLD   libibus-1.0.la
  GISCAN IBus-1.0.gir
Package ibus-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `ibus-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ibus-1.0' found
In file included from /home/nehc/Downloads/ibus-1.4.1/src/ibus.h:28:0,
                 from <stdin>:4:
./ibusshare.h:39:18: fatal error: glib.h: No such file or directory
compilation terminated.
Error while processing the source.
make[4]: *** [IBus-1.0.gir] Error 1
make[4]: Leaving directory `/home/nehc/Downloads/ibus-1.4.1/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/nehc/Downloads/ibus-1.4.1/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/nehc/Downloads/ibus-1.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nehc/Downloads/ibus-1.4.1'
make: *** [all] Error 2


Thanks !


Last edited by rootor on Wed Mar 14, 2012 5:34 am; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5263

PostPosted: Mon Mar 12, 2012 1:36 pm    Post subject: Reply with quote

When I do eix ibus, I don't see a version less than 1.2.0. What does eix ibus show for you? Have you synced lately?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
jtshs256
n00b
n00b


Joined: 25 Mar 2011
Posts: 17

PostPosted: Mon Mar 12, 2012 1:52 pm    Post subject: Reply with quote

workaround:
Code:
USE="-introspection" emerge -1O ibus
emerge ibus
Back to top
View user's profile Send private message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Mon Mar 12, 2012 2:06 pm    Post subject: exi? Reply with quote

audiodef wrote:
When I do eix ibus, I don't see a version less than 1.2.0. What does eix ibus show for you? Have you synced lately?


exi?

sorry, I can't understand ...
Back to top
View user's profile Send private message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Mon Mar 12, 2012 2:07 pm    Post subject: thanks ,but ... Reply with quote

jtshs256 wrote:
workaround:
Code:
USE="-introspection" emerge -1O ibus
emerge ibus


The same error as emerge ibus ...

The same error as compile from source code .
Back to top
View user's profile Send private message
jtshs256
n00b
n00b


Joined: 25 Mar 2011
Posts: 17

PostPosted: Mon Mar 12, 2012 2:15 pm    Post subject: Reply with quote

what about:
Code:
PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 856
Location: Here and Away Again

PostPosted: Mon Mar 12, 2012 2:48 pm    Post subject: Re: exi? Reply with quote

rootor wrote:
audiodef wrote:
When I do eix ibus, I don't see a version less than 1.2.0. What does eix ibus show for you? Have you synced lately?


exi?

sorry, I can't understand ...

It is a tool to search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more.

Code:
app-portage/eix
     Available versions:  0.23.3-r1 0.23.10 ~0.24.0 ~0.25.0 {debug +dep doc nls optimization security sqlite strong-optimization tools zsh-completion}
     Installed versions:  0.23.10(11.09.39 07.03.2012)(nls sqlite -debug -doc -optimization -security -strong-optimization -tools -zsh-completion)
     Homepage:            http://eix.berlios.de
     Description:         Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more

Alternative way for the question could be, what version(s) of ibus does

Code:
emerge --search ibus

list for you?

And the other question there, when was the last time you did

Code:
emerge --sync

though from your --info it can be seen that the time-stamp of your tree is from today.
Moreover the build-log indeed speaks of ibus-1.4.1 which is the only version in Portage, so it's not that it's emerging ibus-1.0. Not really sure what that pkg-config path is all about.

Either way, what my eyes get drawn into more than that, is:

Code:
fatal error: glib.h: No such file or directory

What version(s) of

Code:
dev-libs/glib

do you have installed?

Perhaps this is nowhere near the issue, though.
jtshs256 is probably more on the right track, as the part from the log before this error does seem funky.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Tue Mar 13, 2012 1:37 am    Post subject: Re: exi? Reply with quote

Chiitoo wrote:


Alternative way for the question could be, what version(s) of ibus does

Code:
emerge --search ibus

list for you?

Code:

nehc # emerge --search ibus
Searching...   
[ Results for search key : ibus ]
[ Applications found : 28 ]

*  app-i18n/ibus
      Latest version available: 1.4.1
      Latest version installed: [ Not Installed ]
      Size of files: 1,444 kB
      Homepage:      http://code.google.com/p/ibus/
      Description:   Intelligent Input Bus for Linux / Unix OS
      License:       LGPL-2.1
....



Quote:

And the other question there, when was the last time you did

Code:
emerge --sync

though from your --info it can be seen that the time-stamp of your tree is from today.
Moreover the build-log indeed speaks of ibus-1.4.1 which is the only version in Portage, so it's not that it's emerging ibus-1.0. Not really sure what that pkg-config path is all about.

I di it 2012/03/12 13:30

Quote:

Either way, what my eyes get drawn into more than that, is:

Code:
fatal error: glib.h: No such file or directory

What version(s) of

Code:
dev-libs/glib

do you have installed?

Yeah, I have installed dev-libs/glib
Here is the search result:

Code:

# emerge --search glib
....

*  dev-libs/glib
      Latest version available: 2.30.2
      Latest version installed: 2.30.2
      Size of files: 6,069 kB
      Homepage:      http://www.gtk.org/
      Description:   The GLib library of C routines
      License:       LGPL-2

....

*  sys-libs/glibc
      Latest version available: 2.13-r4
      Latest version installed: 2.13-r4
      Size of files: 16,081 kB
      Homepage:      http://www.gnu.org/software/libc/libc.html
      Description:   GNU libc6 (also called glibc2) C library
      License:       LGPL-2

Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 856
Location: Here and Away Again

PostPosted: Tue Mar 13, 2012 10:25 pm    Post subject: Reply with quote

Alrighty, I did imagine they were all OK but that's something I would have looked into myself, to make sure.
I might still try to re-emerge dev-libs/glib just in case.

Also, did you try what jtshs256 posted above me?

jtshs256 wrote:
what about:
Code:
PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus

_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Wed Mar 14, 2012 5:31 am    Post subject: solved Reply with quote

Chiitoo wrote:


Also, did you try what jtshs256 posted above me?

Code:
PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus



I do
Code:

PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus

And It is find now ... I succeed to install ibus .

Thanks !

But I can not understand why ...
Back to top
View user's profile Send private message
rootor
n00b
n00b


Joined: 05 Dec 2011
Posts: 25

PostPosted: Wed Mar 14, 2012 5:33 am    Post subject: solved Reply with quote

jtshs256 wrote:
what about:
Code:
PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus


Thanks , It is ok !

But why?
Back to top
View user's profile Send private message
dudumomo
n00b
n00b


Joined: 29 Apr 2008
Posts: 42

PostPosted: Sat Mar 17, 2012 3:20 am    Post subject: Reply with quote

jtshs256 wrote:
what about:
Code:
PKG_CONFIG_PATH='/var/tmp/portage/app-i18n/ibus-1.4.1/work/ibus-1.4.1' emerge -O ibus


It did the trick for me !
Thank you !
_________________
Beedbox is a self-hosting distribution project with a web interface to configure all the services.
Join us in this promising project!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum