Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Wifi] AR2413 incompatible avec kernel 3.x voire inférieur ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Sat Mar 10, 2012 8:59 pm    Post subject: [Wifi] AR2413 incompatible avec kernel 3.x voire inférieur ? Reply with quote

Bonjour,

Vous savez comme moi que sur le net, on trouve tout et n'importe quoi, mais surtout n'importe quoi ;)
Il y a quelques semaines, j'ai installé un portable sous Gentoo. Le wifi semblait fonctionner correctement lors de mes essais pendant l'install, puis, après avoir fini toutes mes install/configs, impossible de le faire fonctionner de façon stable. Soit il ne connecte jamais au point d'accès qu'il trouve pourtant, soit s'y connecte après 30 ou 40mn et s'en déconnecte bien vite. J'étais pourtant persuadé de faire tout ce qu'il fallait après avoir lu des tonnes de docs.
Comme ce poste peut pour l'instant rester fixe, je lui plug un cable, et hop, il tourne en ethernet, je n'ai pas plus de temps à perdre sur le sujet.
Sa puce :
Code:
02:05.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
        Subsystem: Atheros Communications Inc. Compex Wireless 802.11 b/g  MiniPCI Adapter, Rev A1 [WLM54G]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at c0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath5k
        Kernel modules: ath5k



Aujourd'hui, j'installe un autre portable, avec puce wifi proche du premier (tjrs ath5k, AR2425). Et là, même sans que je le veuille, et sans je ne ne fasse quoi que ce soit pour, le wifi se connecte (j'installe par ethernet+ssh, je hais les claviers de portable), et reste tout à fait stable.

Sur le coup, ça me vexe un peu de ne jamais être parvenu à le faire fonctionner sur l'autre portable. Et je me mets à chercher des infos sur le AR2413. Je tombe sur un post d'un type qui a exactement le même problème que moi, qui cherche des jours durant ce qu'il fait mal (lui aussi) pour finir par déduire tout heureux qu'il y a incompatibilité entre la puce et le kernel 3.x (l'actuel gentoo-sources étant 3.2.1).

Alors, avant de repartir dans des heures de recherches, de tests, de compilations de noyaux éventuellement inutiles, je me demande si certains d'entre vous auraient eu vent de cette info et si elle est fondée, car je ne trouve rien sur le sujet dans mes recherches. Ça m'éviterait d'y passer encore des heures inutiles.

Je reste bien entendu disposé à vous fournir les infos complémentaires, mais dites-vous bien quand même que oui, les modules sont compilés, qu'ils sont chargées, que les wpa_supplicant et autres sont configurés; que rfkill est testé, etc etc etc...

Merci d'avance.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5444
Location: ~Brussels - Belgique

PostPosted: Sun Mar 11, 2012 8:26 pm    Post subject: Reply with quote

Qu'est-ce comme ordi ?

J'ai un Acer Aspire One, et j'ai du changer des options ASPM via des messages "setpci" ad hoc pour que ma puce wifi ne se déconnecte pas intempestivement.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Mon Mar 12, 2012 1:31 pm    Post subject: Reply with quote

C'est un portable Fujitsu Siemens Amilo.
L'histoire de l'ASPM j'ai lu ça sur des fils, mais il n'y en a même pas mention dans mon lspci.
Sans parler du RFKILL qui est des plus susceptible avec cette puce.
A ma première install, j'étais avec un noyau 2.6.38. Lors de ma récente mise à jour, je suis passé en 3.2.1. J'ai tenté de downgrader au dernier stable 2.6.32 et pas mieux. Même le CD d'install (gentoo 2006.1) que j'avais utilisé ne me donne pas plus de résultat.
Le bouton wifi semble complétement sans effet.
En fait, c'est comme si : soit ça marche parfaitement, soit ce n'est même plus la peine d'essayer pendant des heures. Même un scan trouve le "network is down". Déchargement de module, rfkill et autres sont sans effet.
C'est frustrant.
Si tu t'y connais, et que tu te sens de m'aider. Je peux évidemment te coller ici toutes les infos qui te seraient utiles, et faire les tests nécessaires, mais j'avoue que je décourage un peu depuis le temps que j'y suis.
en attendant :
Code:
02:05.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
        Subsystem: Atheros Communications Inc. Compex Wireless 802.11 b/g  MiniPCI Adapter, Rev A1 [WLM54G]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 20
        Region 0: Memory at c0200000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath5k
        Kernel modules: ath5k


Edit :

Ah ben tiens, info de dernière minute démontrant le côté erratique de la chose. Je lance le portable en mode connexion ethernet puis /etc/init.d/net.wlan0 start, et je surveille le dmesg du coin de l'oeil :
Code:
mer. 31 déc. 1969 20:00:00 AST 1258.913062] ADDRCONF(NETDEV_UP): wlan0: link is not ready
mer. 31 déc. 1969 20:00:00 AST 1260.346351] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1260.546046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1260.746043] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1260.946046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1267.115991] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1267.316053] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1267.516044] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1267.716052] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1273.877105] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1274.077057] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1274.277047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1274.477047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1280.639630] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1280.839044] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1281.039051] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1281.239045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1287.390798] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1287.590046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1287.790045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1287.990046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1294.162640] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1294.362049] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1294.562047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1294.762044] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1300.920935] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1301.120050] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1301.320047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1301.520043] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1307.675070] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1307.875046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1308.075049] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1308.275048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1314.434618] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1314.634049] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1314.834045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1315.034038] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1321.203618] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1321.403047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1321.603046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1321.803044] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1327.955165] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1328.155051] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1328.355048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1328.555046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1334.713425] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1334.913046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1335.113048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1335.313047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1341.473885] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1341.673049] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1341.873046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1342.073048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1348.228568] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1348.428048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1348.628047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1348.828045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1354.982376] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1355.000209] wlan0: direct probe responded
mer. 31 déc. 1969 20:00:00 AST 1355.000213] wlan0: authenticate with AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1355.200044] wlan0: authenticate with AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1355.202664] wlan0: authenticated
mer. 31 déc. 1969 20:00:00 AST 1355.202792] wlan0: associate with AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1355.402043] wlan0: associate with AP 00:0f:b5:9b:41:ef (try 2)
mer. 31 déc. 1969 20:00:00 AST 1355.602047] wlan0: associate with AP 00:0f:b5:9b:41:ef (try 3)
mer. 31 déc. 1969 20:00:00 AST 1355.802043] wlan0: association with AP 00:0f:b5:9b:41:ef timed out
mer. 31 déc. 1969 20:00:00 AST 1361.960573] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1361.962870] wlan0: direct probe responded
mer. 31 déc. 1969 20:00:00 AST 1361.962874] wlan0: authenticate with AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1361.964584] wlan0: authenticated
mer. 31 déc. 1969 20:00:00 AST 1361.964670] wlan0: associate with AP 00:0f:b5:9b:41:ef (try 1)
mer. 31 déc. 1969 20:00:00 AST 1361.966743] wlan0: RX AssocResp from 00:0f:b5:9b:41:ef (capab=0x401 status=0 aid=3)
mer. 31 déc. 1969 20:00:00 AST 1361.966747] wlan0: associated
mer. 31 déc. 1969 20:00:00 AST 1361.967632] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Et ça peut durer comme ça pendant des heures, ou monter direct au premier coup.
NB : le portable est à 1.5m du PA.

Et pendant que j'écrivais se message, le lien est tombé :
Code:
[ 1687.204050] No probe response from AP 00:0f:b5:9b:41:ef after 500ms, disconnecting.
[ 1688.472670] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1688.672048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1688.872045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1689.072047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
[ 1695.231225] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1695.431046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1695.631047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1695.831045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
[ 1701.987372] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1702.187050] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1702.387044] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1702.587046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
[ 1708.750832] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1708.950048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1709.150049] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1709.350046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
[ 1715.511264] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1715.711045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1715.911045] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1716.111048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out
[ 1722.266072] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 1)
[ 1722.466048] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 2)
[ 1722.666047] wlan0: direct probe to AP 00:0f:b5:9b:41:ef (try 3)
[ 1722.866046] wlan0: direct probe to AP 00:0f:b5:9b:41:ef timed out


NB2 : tous les autres appareils connectés en wifi (Portable, Wii, DS...) sur ce même PA et de distances bien supérieures n'ont AUCUN pb de déconnexion.

J'oubliais de préciser un point aussi très important, c'est que même quand le lien monte, la connexion est a 1Mb/s alors que les autres appareils sont sur du 54Mb/s.
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 990
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Tue Mar 13, 2012 8:31 am    Post subject: Reply with quote

Je sais pas si cela peut t'aider

Bon courage.
Code:
$ eix -sS atheros
* net-wireless/ar9271-firmware
     Available versions:  ~1.3!m!b!s
     Homepage:            http://linuxwireless.org/en/users/Drivers/ath9k_htc
     Description:         Atheros firmware for AR9271 (ath9k_htc module)

* net-wireless/madwifi-ng
     Available versions:  0.9.3.3 0.9.4 ~0.9.4-r1 0.9.4.4119.20100201 0.9.4.4133.20100621 0.9.4.4165.20110816 {injection kernel_linux}
     Homepage:            http://www.madwifi-project.org/
     Description:         Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards

* net-wireless/madwifi-ng-tools
     Available versions:  0.9.3.3 0.9.4 0.9.4.4119.20100201 0.9.4.4133.20100621 0.9.4.4165.20110816
     Homepage:            http://www.madwifi-project.org/
     Description:         Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards

Found 3 matches.


OU sinon potasse:

https://www.google.ch/search?q=gentoo+Atheros+Communications+Inc.+AR2413+802.11bg&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

-> je trouve deux premier liens
http://forums.gentoo.org/viewtopic-t-898608-start-0.html -> meilleur fonctionnement avec noyau superieur à 2.6.39
http://forums-web2.gentoo.org/viewtopic-p-6240643.html?sid=ec47949b7a4a4303b4e97cede9e434c5 -> bug corriger par patch apparement ajouter dans les noyau après 2.6.32-r7

Mes autres idées sont:

essayer un autre driver et/ou bien vérifier la configuration du noyau (i.e enlever tout les drivers inutiles).

mes 0.02 cents. :wink:
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Tue Mar 13, 2012 11:49 am    Post subject: Reply with quote

fb99 wrote:

[code]$ eix -sS atheros
* net-wireless/ar9271-firmware
Available versions: ~1.3!m!b!s
Homepage: http://linuxwireless.org/en/users/Drivers/ath9k_htc
Description: Atheros firmware for AR9271 (ath9k_htc module)

* net-wireless/madwifi-ng
Available versions: 0.9.3.3 0.9.4 ~0.9.4-r1 0.9.4.4119.20100201 0.9.4.4133.20100621 0.9.4.4165.20110816 {injection kernel_linux}
Homepage: http://www.madwifi-project.org/
Description: Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards

* net-wireless/madwifi-ng-tools
Available versions: 0.9.3.3 0.9.4 0.9.4.4119.20100201 0.9.4.4133.20100621 0.9.4.4165.20110816
Homepage: http://www.madwifi-project.org/
Description: Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards

Found 3 matches.

C'est gentil, mais ces drivers sont en fait obsolètes depuis qu'ils ont été intégrés au noyau, et tout le monde recommande d'utiliser ceux du noyau.

Quote:
OU sinon potasse:

https://www.google.ch/search?q=gentoo+Atheros+Communications+Inc.+AR2413+802.11bg&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Si tu savais le nombre de jours et d'heures que j'ai déjà passées en recherches. Hier encore, j'ai passé plus de 10h RIEN que sur ça.

Quote:
-> je trouve deux premier liens
http://forums.gentoo.org/viewtopic-t-898608-start-0.html -> meilleur fonctionnement avec noyau superieur à 2.6.39

Je connais, j'en parle dans mon premier post, et c'est même le sujet du post, cette incompatibilité. Seulement, si tu lis mes posts, tu constates que j'ai testé aussi avec du 2.6.32 donc < 2.6.39.

Quote:

http://forums-web2.gentoo.org/viewtopic-p-6240643.html?sid=ec47949b7a4a4303b4e97cede9e434c5 -> bug corriger par patch apparement ajouter dans les noyau après 2.6.32-r7
Oui, donc ce n'est pas ça puisque je suis aussi sur un 3.2.1. De plus, si tu regardes bien, lui a une erreur au chargement du module. Moi, je n'en ai pas. Ça fait quand même une nuance sévère.

Quote:

essayer un autre driver et/ou bien vérifier la configuration du noyau (i.e enlever tout les drivers inutiles).

Il n'y a pas d'autre driver.
Quant à épurer le noyau, j'ai entamé ça hier, à tel point que je me suis retrouvé avec un Wifi qui montait, et stable, mais plus d'accès à wlan0 par iwconfig. Comme si je n'avais pas de carte wifi. Un truc assez dingue, dont j'ai gardé les éléments pour le reproduire ici si je tombe sur un cador pour m'aider.
Parce que bon, si tu n'avais pas lu mes 2 posts en diagonale, tu aurais bien vu qu'il était plutôt déplacé de me donner un lien de recherche google.
Mais... merci quand même.
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 990
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Wed Mar 14, 2012 2:08 am    Post subject: Reply with quote

loin de vouloir de blesser, les solutions sont souvent simples. A force de chercher on s'embrouille je voulais juste essayer de donner des pistes pour t'aider.

Autre piste, avec un livecd (liveusb), ça marche ? déjà essayer d'autres sources (vanilla, gentoo, ...) pour le noyau.

autre vieux problème que j'avais lu, pour des personnes qui avait un dual boot avec windows s'il désactivait le wifi sur ce dernier plus moyen de l'utiliser.

Et pour finir, je sais que ce n'est pas trop la pensée de gentoo qui peut tout faire marcher, mais maintenant il y a de bête clé usb wifi pour 10€, donc admettons que tu sois vraiment sous payé mais 1€ de l'heure pas encore vu ça chez nous ( tu aurais déjà rentabiliser ton seul jour d'hier).

Dernière piste, le forum anglais est plus lu, donc pourquoi ne pas poster là-bas.

Bon courage, et encore désolé si je t'ai fais perdre ton temps avec des liens pourraves ou si je t'ai blessé.
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum