Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eix-remote update [РЕШЕНО]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
proff
n00b
n00b


Joined: 03 Feb 2012
Posts: 2

PostPosted: Sun Mar 11, 2012 5:09 pm    Post subject: eix-remote update [РЕШЕНО] Reply with quote

пытался сделать eix-remote update (app-portage/eix-0.25.0)
выдаёт такую ошибку:

/tmp/eix-remote.ddMWBtd0/1/_var_lib_layman_roslin.eix was created with an incompatible eix-update:
It uses database format 28 (current is 29).
Please run 'eix-update' and try again.
problems arised with cachefile _var_lib_layman_roslin.eix

* could not read all eix cachefiles of /tmp/eix-remote.ctxuwTKk/eix-caches.tbz2

Probably your eix cachefile was *not* updated successfully.
Unless the above messages suggest another cause or you specified a
wrong filename, the most likely cause of this is that the server uses
another eix version than you or produced broken data. Please inspect
/tmp/eix-remote.ctxuwTKk/eix-caches.tbz2
whether this is a valid *.tar.bz2 archive containing eix cachefiles
(if it has already been deleted, download it using fetch).
If this is not the case (but was freshly downloaded), please report a bug.
Note that the archive is *not* broken if only the cachefile format versions
differ: In that case only report a bug if the eix cachefile format versions
in the downloaded file are *older* than that of the most current ~x86 eix
version in the portage tree (but first retry after several days before
reporting such a bug to give the server maintainers a chance to upgrade
after a version bump of eix).
Conversely, if the downloaded versions are even newer than that supported by
your eix, you will have to upgrade to the most current ~x86 version of eix
to use eix-remote: This inconvenience cannot be avoided and is not a bug!


Last edited by proff on Thu Mar 22, 2012 9:12 am; edited 1 time in total
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 237
Location: Russia && Saint-Petersburg

PostPosted: Mon Mar 12, 2012 10:41 pm    Post subject: Reply with quote

написано же - база на серваке создана старой версий
твоя текущая не понимает
1. даунгрейд
2. ждать
3. ну или выкинуть eix-remote :3
выбирай
Back to top
View user's profile Send private message
proff
n00b
n00b


Joined: 03 Feb 2012
Posts: 2

PostPosted: Thu Mar 22, 2012 9:10 am    Post subject: [РЕШЕНО] Reply with quote

всё решилось откатом app-portage/eix до версии 0.23.10
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum