Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
arista don't accept mov video and gui not start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 756
Location: Italy

PostPosted: Tue Jun 24, 2014 9:08 am    Post subject: arista don't accept mov video and gui not start Reply with quote

Hi. I installed Arista to convert my video, but i have a problem with arista cli:

Quote:

$ arista-transcode -o prova.mp4 -p android 123___06/MVI_1628.MOV
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Encoding MVI_1628.MOV for computer (android) failed!
Not a recognized media file!


I know arista depends on gstreamer... so i checked all plugin of gstreamer... and i set almost all use on, but the problem is not solved

Quote:

# eix gst-plugins-meta
[U] media-plugins/gst-plugins-meta
Available versions:
(0.10) 0.10-r8 ~0.10-r9
(1.0) 1.0-r1 ~1.0-r2
{X a52 aac alsa cdda dts dv dvb dvd ffmpeg flac http jack lame libass libvisual mms mp3 mpeg musepack ogg opus oss pulseaudio taglib theora v4l vcd vorbis vpx wavpack x264 xv xvid ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 0.10-r8(0.10)(10:50:52 24/06/2014)(X a52 aac alsa cdda dts dvd ffmpeg flac jack lame libass libvisual mms mp3 mpeg musepack ogg opus oss taglib theora v4l vcd vorbis vpx wavpack x264 xv xvid -dv -dvb -http -pulseaudio)
Homepage: http://www.gentoo.org
Description: Meta ebuild to pull in gst plugins for apps







I have another problem with Arista.
When i try to start gui:

Quote:

$ arista-gtk
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Traceback (most recent call last):
File "/usr/bin/arista-gtk", line 1671, in <module>
main = MainWindow(options)
File "/usr/bin/arista-gtk", line 397, in __init__
self.setup_source()
File "/usr/bin/arista-gtk", line 544, in setup_source
model.set_value(iter, 0, theme.load_icon(icon, size, 0))
glib.GError: Icona «gtk-cdrom» non presente nel tema


It seems there is an icon-missing problem.

I found this bug open https://bugs.gentoo.org/show_bug.cgi?id=499970 and changed kde icon to gnome icon, as suggeste in the bug discussion, but i don't solve it...

Any other idea?

Of course, gnome-icon-theme is installed., and i have also that icon:

Quote:

# equery f gnome-icon-theme | grep gtk-cdrom
/usr/share/icons/gnome/16x16/devices/gtk-cdrom.png
/usr/share/icons/gnome/22x22/devices/gtk-cdrom.png
/usr/share/icons/gnome/24x24/devices/gtk-cdrom.png
/usr/share/icons/gnome/256x256/devices/gtk-cdrom.png
/usr/share/icons/gnome/32x32/devices/gtk-cdrom.png
/usr/share/icons/gnome/48x48/devices/gtk-cdrom.png
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum