Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsa Lib conf.c:3314 Cannot open shared library [SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Neskweek
n00b
n00b


Joined: 20 Jun 2004
Posts: 35
Location: Nantes - France

PostPosted: Sat Dec 08, 2012 3:09 pm    Post subject: Reply with quote

ExecutorElassus wrote:
I tried this same fix, and now all my audio in wine (say, playing games) sounds horribly distorted and overdriven (and oddly, the intro cinematic plays twice as fast). Further, every time I open alsamixer, the volume for PCM, Surround, and a bunch of other channels is set to 100%. Any guess what's going wrong?

Cheers,

EE


Pulseaudio is wrongly configured.
That's all
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 765
Location: Stuttgart, Germany

PostPosted: Tue Jan 22, 2013 5:28 pm    Post subject: Reply with quote

Neskweek: so, I'm back here again, with ALSA and pulseaudio not playing nicely together again.

First question: in what way is pulseaudio wrongly configured, and how do I fix it?
Second: now I have no sound at all, with any program, after a recent update. Alsamixer is using the correct soundcard, and the levels are correct. How do I debug?

Thanks,

EE
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 765
Location: Stuttgart, Germany

PostPosted: Tue Jan 22, 2013 5:46 pm    Post subject: Reply with quote

incidentally, to answer the "why are you using pulseaudio" question:

gnome-settings-daemon, gnome-control-center, and gnome-shell all explicitly require pulseadio to be enabled on alsa-plugins. With that installed, many other packages install pulseaudio support in turn.

Is there a way around this behavior?

Cheers,

EE
Back to top
View user's profile Send private message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 409
Location: Shake & Bake

PostPosted: Sat Mar 09, 2013 4:27 pm    Post subject: Reply with quote

ExecutorElassus:

Use /etc/portage/package.use and set the flag as needed only on those apps the explictly depend on pulseaudio. Then do an emerge -pvuN world to see what needs rebuilding w/o pulseaudio, which should not show the gnome settings-daemon gnome-control center and gnome-shell as they already have pulseaudio. It the pretend flag shows them being rebuilt, you need to double check your package.use settings (did you save it and are the packages properly listed).
Back to top
View user's profile Send private message
Muzer
n00b
n00b


Joined: 19 Jun 2011
Posts: 7

PostPosted: Wed Apr 03, 2013 12:41 am    Post subject: Reply with quote

Neskweek wrote:
midnigther wrote:
Problem solved. I disabled the pulseaudio flag.

Ooooww Common ! :/... Disabling the feature doesn't solve the the problem !!!...

Well then, I got the same problem, and did found the solution here.

The cause : It's a multilib problem:
PulseAudio is set to ALWAYS use 64 bit libraries.
So porgram like Skype, GuitarPro6, Wine 32bit etc... doesn't work because they need 32bit libraries.

There you go for Gentoo (tested and working) :

0. Install, if not done, emul-linux-x86-soundlibs
emerge emul-linux-x86-soundlibs

1. Create /etc/ld.so.conf.d/alsa32.conf with the following contents:
Code:
/usr/lib32/alsa-lib


2. Create /etc/ld.so.conf.d/alsa64.conf with the following contents:
Code:
/usr/lib/alsa-lib


3. ldconfig

4. Open /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.
like this :

Code:
# PulseAudio alsa plugin configuration file to set the pulseaudio plugin as
# default output for applications using alsa when pulseaudio is running.

hook_func.pulse_load_if_running {
#replace this         
#       lib "/usr/lib/alsa-lib/libasound_module_conf_pulse.so"
#by this : 
        lib "libasound_module_conf_pulse.so"
        func "conf_pulse_hook_load_if_running"
}

@hooks [
        {
                func pulse_load_if_running
                files [
                        "/usr/share/alsa/pulse-default.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]



And that should do it.





Why is this required now?

I use pulseaudio because I like some of its features and it does indeed seem to unify audio such that it works in stubborn applications, which ALSA alone has never done for me too well. It's also easier to configure things like surround sound up/downmixing, and pavucontrol is a very useful tool. I see no reason to discontinue using pulseaudio.

I'm sure I didn't need it before a recent update, but after it, I do. What has changed? How can I make the fix more permanent so it isn't overwritten every ALSA update?
Back to top
View user's profile Send private message
gendjaral
n00b
n00b


Joined: 11 Aug 2012
Posts: 39
Location: DE Munich

PostPosted: Fri Apr 05, 2013 9:58 pm    Post subject: Reply with quote

Neskweek wrote:

Ooooww Common ! :/... Disabling the feature doesn't solve the the problem !!!...

Full ack! :)
Neskweek wrote:

...
4. Open /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.
...

Thanks a lot!

If you visit Germany/Munich I buy you a pizza! :D

Best,
gendjaral
Back to top
View user's profile Send private message
heheman3000
n00b
n00b


Joined: 22 Oct 2006
Posts: 18

PostPosted: Tue Apr 23, 2013 11:29 pm    Post subject: Reply with quote

Great! This also fixed my problem with no sound in Starcraft 2 on Wine 1.5.28.
Back to top
View user's profile Send private message
Muzer
n00b
n00b


Joined: 19 Jun 2011
Posts: 7

PostPosted: Tue Aug 27, 2013 6:37 pm    Post subject: Reply with quote

Is it possible to fix this permanently? It's annoying having to reinsert it every update. Perhaps it could be fixed in the package?

EDIT: Lol, I forgot I posted in this thread already, sorry if it seems like I'm repeating myself ;)

I'm wondering if relative paths for libraries would be possible, so if fixing it in the package you could replace the path with alsa-lib/libasound_module_conf_pulse.so - that way you wouldn't need the ld.conf.so.d files either.
Back to top
View user's profile Send private message
Beresford
n00b
n00b


Joined: 14 Aug 2005
Posts: 5
Location: Graz

PostPosted: Tue Jun 24, 2014 1:25 pm    Post subject: Reply with quote

Thank you :) It worked for me too :D

Now (in my case) steam works as expected without any spontanious self-kill of itself :)

Have a nice week :)

Cheers,
siegfried

Neskweek wrote:
midnigther wrote:
Problem solved. I disabled the pulseaudio flag.

Ooooww Common ! :/... Disabling the feature doesn't solve the the problem !!!...

Well then, I got the same problem, and did found the solution here.

The cause : It's a multilib problem:
PulseAudio is set to ALWAYS use 64 bit libraries.
So porgram like Skype, GuitarPro6, Wine 32bit etc... doesn't work because they need 32bit libraries.

There you go for Gentoo (tested and working) :

0. Install, if not done, emul-linux-x86-soundlibs
emerge emul-linux-x86-soundlibs

1. Create /etc/ld.so.conf.d/alsa32.conf with the following contents:
Code:
/usr/lib32/alsa-lib


2. Create /etc/ld.so.conf.d/alsa64.conf with the following contents:
Code:
/usr/lib/alsa-lib


3. ldconfig

4. Open /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.
like this :

Code:
# PulseAudio alsa plugin configuration file to set the pulseaudio plugin as
# default output for applications using alsa when pulseaudio is running.

hook_func.pulse_load_if_running {
#replace this         
#       lib "/usr/lib/alsa-lib/libasound_module_conf_pulse.so"
#by this : 
        lib "libasound_module_conf_pulse.so"
        func "conf_pulse_hook_load_if_running"
}

@hooks [
        {
                func pulse_load_if_running
                files [
                        "/usr/share/alsa/pulse-default.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]



And that should do it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum