Joined: 12 May 2004
|Posted: Tue Mar 06, 2012 12:26 pm Post subject: [ GLSA 201203-12 ] OpenSSL: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: OpenSSL: Multiple vulnerabilities (GLSA 201203-12)
Date: March 06, 2012
Updated: July 07, 2014
Bug(s): #397695, #399365
Multiple vulnerabilities have been found in OpenSSL, allowing
remote attackers to cause a Denial of Service or obtain sensitive
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
Vulnerable: < 1.0.0g
Unaffected: >= 1.0.0g
Unaffected: >= 0.9.8t < 0.9.9
Unaffected: >= 0.9.8u < 0.9.9
Unaffected: >= 0.9.8v < 0.9.9
Unaffected: >= 0.9.8w < 0.9.9
Unaffected: >= 0.9.8x < 0.9.9
Unaffected: >= 0.9.8y < 0.9.9
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures
Multiple vulnerabilities have been found in OpenSSL:
- Timing differences for decryption are exposed by CBC mode encryption
in OpenSSL’s implementation of DTLS (CVE-2011-4108).
- A policy check failure can result in a double-free error when
X509_V_FLAG_POLICY_CHECK is set (CVE-2011-4109).
- Clients and servers using SSL 3.0 handshakes do not clear the block
cipher padding, allowing a record to contain up to 15 bytes of
uninitialized memory, which could include sensitive information
- Assertion errors can occur during the handling of malformed X.509
certificates when OpenSSL is built with RFC 3779 support
- A resource management error can occur when OpenSSL’s server gated
cryptography (SGC) does not properly handle handshake restarts
- Invalid parameters in the GOST block cipher are not properly handled
by the GOST ENGINE(CVE-2012-0027).
- An incorrect fix for CVE-2011-4108 creates an unspecified
vulnerability for DTLS applications using OpenSSL (CVE-2012-0050).
A remote attacker may be able to cause a Denial of Service or obtain
sensitive information, including plaintext passwords.
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0g"
Last edited by GLSA on Tue Jul 08, 2014 4:29 am; edited 6 times in total