Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Conflicts util-linux & sysvinit(after emerge --sync)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lduser
n00b
n00b


Joined: 06 Jan 2012
Posts: 22

PostPosted: Sat Mar 03, 2012 4:31 pm    Post subject: [SOLVED]Conflicts util-linux & sysvinit(after emerge --s Reply with quote

I did `emerge --sync' (last update system and world were 8 january 2012)
and I get blocks for update:

sys-apps/util-linux-2.20.1-r1 [2.19.1-r1]
sys-apps/sysvinit-2.88-r3 [2.88-r2]

...

I've solved it by masking that packages...


Last edited by lduser on Mon Mar 05, 2012 7:51 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8974

PostPosted: Sat Mar 03, 2012 6:22 pm    Post subject: Reply with quote

Masking updates on core packages is probably the wrong solution. However, you have not provided enough output for us to help you. Please show the full output of emerge --pretend --update --deep --verbose --tree world ; emerge --info.
Back to top
View user's profile Send private message
lduser
n00b
n00b


Joined: 06 Jan 2012
Posts: 22

PostPosted: Sun Mar 04, 2012 11:32 am    Post subject: Reply with quote

Hi Hu!

localhost / # emerge -pv --update --deep --verbose --tree world
Code:

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] sys-apps/util-linux-2.20.1-r1 [2.19.1-r1] USE="cramfs crypt loop-aes ncurses nls slang static-libs%* unicode -ddate% -old-linux -perl (-selinux) (-uclibc)"
[blocks b      ]  <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)
[ebuild     U  ]   sys-apps/sysvinit-2.88-r3 [2.88-r2] USE="(-ibm) (-selinux) -static" 0 kB
[ebuild     U  ] sys-apps/util-linux-2.20.1-r1 [2.19.1-r1] USE="cramfs crypt loop-aes ncurses nls slang static-libs%* unicode -ddate% -old-linux -perl (-selinux) (-uclibc)" 0 kB

Total: 2 packages (2 upgrades), Size of downloads: 0 kB
Conflict: 1 block



and:

localhost / # emerge --info
Code:

Portage 2.1.10.44 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 3.0.4-calculate x86_64)
=================================================================
System uname: Linux-3.0.4-calculate-x86_64-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 03 Mar 2012 09:00:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* **"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--sort-common"
LINGUAS="en en_GB ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X X509 a52 aac acl acpi alsa amd64 audit bash-completion bashlogger berkdb bluetooth branding bzip2 caps cdda cdparanoia cdr clertype cli consolekit cracklib crypt cups curl cxx dbus declarative devfs-compat djvu dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig gcrypt gd gdbm gdu gif gmp gnutls gphoto2 gpm hal iconv ieee1394 imagemagick ipv6 jbig jpeg jpeg2k kde kipi lcms ldap libnotify libssh2 loop-aes lzma mad mmx mng modules mp3 mp4 mpeg mudflap multilib musicbrainz nas ncurses network-cron networkmanager nls nptl nptlonly ntlm ogg opengl openmp pam pam_ssh pango pcre pdf phonon plasma plugins png policykit postgres postgresql ppds pppd profile qt3support qt4 readline samba scanner sdl semantic-desktop session skey slang spell sse sse2 ssl startup-notification static-libs subversion symlink sysfs tcpd threads truetype udev unicode usb utils v4l v4l2 vorbis wicd x264 xattr xcb xcomposite xft xinerama xml xorg xpm xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick synaptics keyboard mouse mutouch" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB ru" LIRC_DEVICES="all" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS





PS: I'm building this system through chroot (my new system is using `sys-kernel/gentoo-sources-3.2.1-r2')


PSS: And I can't build `cross-mingw32/gcc-4.5.3-r1' (crossdev is stable current version):

Code:

* Messages for package cross-mingw32/gcc-4.5.3-r1:

 * Fallback PaX marking -r
 *      /var/tmp/portage/cross-mingw32/gcc-4.5.3-r1/image//usr/libexec/gcc/mingw32/4.5.3/cc1
 * Fallback PaX marking -r
 *      /var/tmp/portage/cross-mingw32/gcc-4.5.3-r1/image//usr/libexec/gcc/mingw32/4.5.3/cc1plus
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). Once again, please do NOT file
 * a bug report unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *      /usr/bin/g++-4.5.3
 *      /usr/bin/c++-4.5.3
 *      /usr/bin/gcc-4.5.3
 *      /usr/bin/cpp-4.5.3
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * sys-devel/gcc-4.5.3-r2
 *      /usr/bin/c++-4.5.3
 *      /usr/bin/cpp-4.5.3
 *      /usr/bin/g++-4.5.3
 *      /usr/bin/gcc-4.5.3
 *
 * Package 'cross-mingw32/gcc-4.5.3-r1' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.
 *
 * Please include /var/tmp/portage/cross-mingw32/gcc-4.5.3-r1/work/build/gcc-build-logs.tar.bz2 in your bug report
 *

 * GNU info directory index is up-to-date.




The best regards.
Back to top
View user's profile Send private message
Pegasus87
Guru
Guru


Joined: 09 Sep 2004
Posts: 369

PostPosted: Sun Mar 04, 2012 3:38 pm    Post subject: Reply with quote

same problem here...
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sun Mar 04, 2012 3:43 pm    Post subject: Reply with quote

your util-linux and sysvinit problem is a soft blocker, portage will automatically take care of it.


where does you cross-mingw32 come from? I am unable to find it in portage.

V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2700
Location: Hamburg/Germany

PostPosted: Sun Mar 04, 2012 3:47 pm    Post subject: Reply with quote

The lower case character "b" indicates that portage handles it automatically - that is not a problem, only an info.
Back to top
View user's profile Send private message
Pegasus87
Guru
Guru


Joined: 09 Sep 2004
Posts: 369

PostPosted: Sun Mar 04, 2012 4:53 pm    Post subject: Reply with quote

Ok, then it is a little bit different in my case. I get B, so portage doesn't care about it.
Code:

emerge -avu system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-devel/gnuconfig-20110814 [20110202] 50 kB
[ebuild     U  ] sys-apps/less-444 [441] USE="unicode" 496 kB
[ebuild     U  ] net-misc/rsync-3.0.9 [3.0.8] USE="acl iconv ipv6 -static -xattr" 775 kB
[ebuild     U  ] sys-apps/util-linux-2.20.1-r1 [2.19.1-r1] USE="cramfs crypt ncurses nls perl unicode -ddate% -loop-aes -old-linux (-selinux) -slang -static-libs% (-uclibc)" 4,507 kB                                                               
[ebuild     U  ] sys-apps/findutils-4.4.2-r1 [4.4.2] USE="nls (-selinux) -static" 2,100 kB
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.42 [1.41.14] USE="nls -static-libs%" 501 kB
[ebuild     U  ] app-arch/tar-1.26 [1.23-r2] USE="nls -static" 2,285 kB
[ebuild     U  ] sys-fs/e2fsprogs-1.42 [1.41.14] USE="nls -static-libs%" 5,577 kB
[ebuild     U  ] sys-devel/gcc-4.5.3-r2 [4.5.3-r1] USE="cxx fortran gcj gtk mudflap (multilib) nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -graphite (-hardened) (-libssp) -lto -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla (-libffi%)" 66,295 kB                                                                                 
[blocks B      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)

Total: 9 packages (9 upgrades), Size of downloads: 82,581 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/sysvinit-2.88-r2::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)

  (sys-apps/util-linux-2.20.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.73-r1::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-164-r2::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by (www-plugins/nspluginwrapper-1.4.4-r1::gentoo, installed)
    >=sys-apps/util-linux-2.16.0 required by (app-emulation/qemu-kvm-0.13.0-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (x11-libs/libSM-1.2.0::gentoo, installed)
    >=sys-apps/util-linux-2.17.2 required by (sys-fs/cryptsetup-1.1.3-r3::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by (sys-power/pm-utils-1.4.1::gentoo, installed)
    sys-apps/util-linux required by (sci-misc/boinc-6.12.33::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.5::gentoo, installed)
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Sun Mar 04, 2012 4:58 pm    Post subject: Reply with quote

please try emerge -aDuv world.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8974

PostPosted: Sun Mar 04, 2012 5:47 pm    Post subject: Reply with quote

Veldrin wrote:
where does you cross-mingw32 come from? I am unable to find it in portage.
This is typically set up by using sys-devel/crossdev, which will set up links in an overlay to point to the corresponding sys-devel/gcc, sys-devel/binutils, etc.
Back to top
View user's profile Send private message
lduser
n00b
n00b


Joined: 06 Jan 2012
Posts: 22

PostPosted: Sun Mar 04, 2012 6:09 pm    Post subject: Reply with quote

Veldrin wrote:
your util-linux and sysvinit problem is a soft blocker, portage will automatically take care of it.


where does you cross-mingw32 come from? I am unable to find it in portage.

V.


It is can find out by:

Code:

emerge crossdev


and:

Code:

crossdev --stable --target mingw32



++++++++++++++++++++++++++++++++++++++++++

toralf wrote:
The lower case character "b" indicates that portage handles it automatically - that is not a problem, only an info.


Thanks! it has helped me...
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Mar 05, 2012 3:06 am    Post subject: Reply with quote

portage wrote:

[blocks B ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)


Code:

emerge -v sysvinit
emerge -v util-linux

_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
evian007
n00b
n00b


Joined: 20 Feb 2012
Posts: 4

PostPosted: Sat Mar 02, 2013 7:13 pm    Post subject: I fixed it. My solution is... Reply with quote

Code:
emerge -aDuv --autounmask-write system
etc-update
emerge -aDuv system
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum