Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-video/mplayer-1.0_rc4_p20120116 with vaapi use flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Tue May 29, 2012 4:18 pm    Post subject: media-video/mplayer-1.0_rc4_p20120116 with vaapi use flag Reply with quote

I made an ebuild based on latest git code:
http://www.linuxsystems.it/2012/05/media-video-mplayer-1-0_rc4_p20120116-with-vaapi-use-flag/
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 155

PostPosted: Wed May 30, 2012 6:57 pm    Post subject: Reply with quote

Thanks for this. Are the VA API patches tied to the older release of mplayer (p20120116), or do they work with a newer version (i.e. p20120405) of mplayer ebuild?
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Wed May 30, 2012 8:23 pm    Post subject: Reply with quote

I didn't try because p20120116 is new enough and it was surely more widely tested with VA-API. You will probably have to solve some conflicts anyway...
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1130

PostPosted: Sun Jun 03, 2012 12:06 pm    Post subject: Reply with quote

any chance to get vaapi enabled mplayer in the portage?
_________________
gentoo user
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Sun Jun 03, 2012 12:14 pm    Post subject: Reply with quote

The real question is: no chance to get vaapi-mplayer merged upstream?
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Sun Jun 03, 2012 1:03 pm    Post subject: Reply with quote

darkbasic wrote:
The real question is: no chance to get vaapi-mplayer merged upstream?

Update the code to latest svn, then post a patch the the mailing list. Doesn't have to be you personally, but the only way upstream will ever have vaapi support is when and if someone does that.
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 300

PostPosted: Wed Jun 06, 2012 10:12 pm    Post subject: Reply with quote

I was interested at first and then added your overlay over... only to discover that your maplyer ebuild has a hard dependency to media-video/ffmpeg and not virtual/ffmpeg. I'm not aware of how media-video/ffmpeg is hard coded to mplayer but alas I use mplayer2 along with smplayer2 using libav as a backend. So no go if I cannot keep libav around. No particular requirement for libav, although I decided to switch to it a while back.
_________________
mkinitramfs-ll:topic 879125::(bar-)overlay
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Wed Jun 06, 2012 10:17 pm    Post subject: Reply with quote

Every mplayer ebuild in portage depends on media-video/ffmpeg instead of virtual. Can you please try with virtual/ffmpeg and libav? If it works I will update the dependencies.

Thanks
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
tclover
Guru
Guru


Joined: 10 Apr 2011
Posts: 300

PostPosted: Fri Jun 08, 2012 5:16 pm    Post subject: Reply with quote

It's no good, media-video/ffmpeg is hardcoded into media-video/mplayer: mplayer does not compile against media-video/libav.
_________________
mkinitramfs-ll:topic 879125::(bar-)overlay
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Fri Jun 08, 2012 5:30 pm    Post subject: Reply with quote

Thanks, I imagined it.
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 124

PostPosted: Mon Nov 12, 2012 9:04 pm    Post subject: Reply with quote

I made an updated ebuild: http://www.linuxsystems.it/2012/11/media-videomplayer-1-1_rc1_p20120820-with-vaapi-use-flag/
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum