Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Blocco mouse in basso a destra del desktop
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sat Feb 25, 2012 8:38 am    Post subject: [RISOLTO]Blocco mouse in basso a destra del desktop Reply with quote

Ciao a tutti ragazzuoli sto diventando matto con un problema strano : in pratica quando passo il mouse nell'angolo in basso a destro del desktop il mouse per un attimo si blocca e poi riprende a funzionare! Ho letto in giro che il problema sono gli ati-drivers.
Ho provato diverse volte ad editare in maniera differente xorg.conf senza risultati, ho provato tutte le versione degli ati-driver stabili/instabili. tranne la versione 11.4 che necessita di un kernel con con la funzione " big kernel lock " ma tale funzione ormai non è più presente nei gentoo-sources presenti in portage. Esiste un overlay con i gentoo-sources un pò più datati per provare i driver 11.4 ? Oppure qualcuno sa come posso risolvere il mio problema?
La scheda video è un'ati mobile hd 4570 e utilizzo kde 4.7.4 con xorg-server 1.11.2-r2


Last edited by xveilsidex on Mon Feb 27, 2012 6:37 pm; edited 2 times in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4785
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sat Feb 25, 2012 11:07 am    Post subject: Reply with quote

usare un kernel più vecchio degli header non è mai una buona idea, per una simile legacy è autolesionismo.
Se non hai particolari esigenze perchè non provi KMS? La 4570 dovrebbe essere supportata.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Sat Feb 25, 2012 1:44 pm    Post subject: Reply with quote

Si lo sapevo che non è una buona cosa, ciò che voglio è eliminare questo difetto insopportarbile e avere il direct rendering ! cmq provo con il kms e vedo come va! ;)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4785
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Sun Feb 26, 2012 1:56 pm    Post subject: Reply with quote

Se vuoi usare KMS con profitto ti ricordo che è meglio builtin, devi includere i blob (firmware) nel kernel ed averli comunque sull'immagine se ne fai uso (c'è un mio post con tutti i dettagli da qualche parte) e che per la sospensione dovresti usare sys-power/suspend non hibernate di tuxonice che ha problemi di compatibilità (qui non ho mai trovato genio di applicarmi a configurarlo, se lo fai condividi... ovviamente).
Se hai problemi con gli edid ho postato la patch sul forum internazionale.

Scusa se non ti riporto tutto ma è domenica e so che non hai problemi a fare una ricerca.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Mon Feb 27, 2012 6:36 pm    Post subject: Reply with quote

grazie della risposta, ho risolto con kms, funziona abbastanza bene, l'unica cosa che ho notato rispetto ai classici ati-drivers è che la ventola gira un pò più velocemente ma preferisco questo piccolo difetto ( se cosi si può chiamare ) al fastidioso blocco in basso a destra!
Back to top
View user's profile Send private message
xveilsidex
Guru
Guru


Joined: 27 Dec 2005
Posts: 370
Location: Bari

PostPosted: Fri Mar 02, 2012 4:48 pm    Post subject: Reply with quote

Dunque, finalmente ho risolto il problema della ventola che continuava a girare sempre alla massima velocità anche in idle.
L'errore che ho commesso è quello di aver settato in xorg.conf questa riga :
Code:

"DynamicClocks" "on"

credendo di poter gestire automaticamente il funzionamento della gpu in base al carico di lavoro.
In realtà tale funzione è obsoleta come indica QUESTO POST

Per la corretta gestione della velocità della ventola/core gpu occorre cambiare il profilo di funzionamento della scheda video.
Ci sono vari profili di funzionamento, rispettivamente : 1. "default" 2. "auto" 3. "low" 4. "high" come indica QUESTA GUIDA
Code:

cat /sys/class/drm/card0/device/power_profile
default
echo "low" > /sys/class/drm/card0/device/power_profile
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum