Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error con el driver de wifi...creo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
eidan
n00b
n00b


Joined: 26 Feb 2012
Posts: 4

PostPosted: Wed Apr 04, 2012 4:18 pm    Post subject: Error con el driver de wifi...creo Reply with quote

el caso es que estoy intentando leer unos errores que me salen al iniciar gentoo, y a raíz de esto descubrí que tengo el /var/log/messages inundado con el siguiente error:

Code:
Apr  4 01:07:22 gentoo kernel: [130031.104386] WARNING: at drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix.clone.16+0x155/0x1f0()
Apr  4 01:07:22 gentoo kernel: [130031.104393] Hardware name: To Be Filled By O.E.M.
Apr  4 01:07:22 gentoo kernel: [130031.104397] Modules linked in:
Apr  4 01:07:22 gentoo kernel: [130031.104405] Pid: 0, comm: swapper/3 Tainted: G        W    3.2.1-gentoo-r2 #15
Apr  4 01:07:22 gentoo kernel: [130031.104410] Call Trace:
Apr  4 01:07:22 gentoo kernel: [130031.104415]  <IRQ>  [<ffffffff8104da6b>] ? warn_slowpath_common+0x7b/0xc0
Apr  4 01:07:22 gentoo kernel: [130031.104434]  [<ffffffff814f9565>] ? ath_rc_get_highest_rix.clone.16+0x155/0x1f0
Apr  4 01:07:22 gentoo kernel: [130031.104442]  [<ffffffff814f968b>] ? ath_get_rate+0x8b/0x490
Apr  4 01:07:22 gentoo kernel: [130031.104451]  [<ffffffff8172b356>] ? rate_control_get_rate+0x86/0x140
Apr  4 01:07:22 gentoo kernel: [130031.104460]  [<ffffffff8173463a>] ? invoke_tx_handlers+0x84a/0x1140
Apr  4 01:07:22 gentoo kernel: [130031.104468]  [<ffffffff814ef319>] ? ath9k_tx+0x99/0x140
Apr  4 01:07:22 gentoo kernel: [130031.104477]  [<ffffffff816ca0db>] ? nf_nat_get_offset+0x5b/0x80
Apr  4 01:07:22 gentoo kernel: [130031.104486]  [<ffffffff817350c6>] ? ieee80211_tx+0x76/0xf0
Apr  4 01:07:22 gentoo kernel: [130031.104494]  [<ffffffff81735828>] ? ieee80211_xmit+0x98/0xd0
Apr  4 01:07:22 gentoo kernel: [130031.104503]  [<ffffffff81735e5f>] ? ieee80211_subif_start_xmit+0x38f/0x850
Apr  4 01:07:22 gentoo kernel: [130031.104513]  [<ffffffff81658352>] ? dev_hard_start_xmit+0x272/0x5f0
Apr  4 01:07:22 gentoo kernel: [130031.104523]  [<ffffffff8166cdbb>] ? sch_direct_xmit+0xeb/0x1e0
Apr  4 01:07:22 gentoo kernel: [130031.104531]  [<ffffffff81658836>] ? dev_queue_xmit+0x166/0x600
Apr  4 01:07:22 gentoo kernel: [130031.104539]  [<ffffffff8168f000>] ? ip_finish_output2+0x250/0x250
Apr  4 01:07:22 gentoo kernel: [130031.104546]  [<ffffffff8168f13a>] ? ip_finish_output+0x13a/0x2f0
Apr  4 01:07:22 gentoo kernel: [130031.104553]  [<ffffffff8168ffc7>] ? ip_queue_xmit+0x157/0x3b0
Apr  4 01:07:22 gentoo kernel: [130031.104561]  [<ffffffff8106ffe8>] ? getnstimeofday+0x48/0xc0
Apr  4 01:07:22 gentoo kernel: [130031.104570]  [<ffffffff816a59ba>] ? tcp_transmit_skb+0x3ba/0x8a0
Apr  4 01:07:22 gentoo kernel: [130031.104579]  [<ffffffff816a3969>] ? tcp_rcv_established+0x189/0x670
Apr  4 01:07:22 gentoo kernel: [130031.104587]  [<ffffffff816aa835>] ? tcp_v4_do_rcv+0x1b5/0x450
Apr  4 01:07:22 gentoo kernel: [130031.104594]  [<ffffffff81693d99>] ? __inet_lookup_established+0x139/0x260
Apr  4 01:07:22 gentoo kernel: [130031.104602]  [<ffffffff816ad384>] ? tcp_v4_rcv+0x6d4/0x7e0
Apr  4 01:07:22 gentoo kernel: [130031.104610]  [<ffffffff81672e98>] ? nf_hook_slow+0xd8/0x120
Apr  4 01:07:22 gentoo kernel: [130031.104619]  [<ffffffff8168b4a0>] ? ip_rcv_finish+0x2e0/0x2e0
Apr  4 01:07:22 gentoo kernel: [130031.104628]  [<ffffffff8168b535>] ? ip_local_deliver_finish+0x95/0x150
Apr  4 01:07:22 gentoo kernel: [130031.104636]  [<ffffffff81653a2f>] ? __netif_receive_skb+0x1cf/0x350
Apr  4 01:07:22 gentoo kernel: [130031.104644]  [<ffffffff8165564d>] ? netif_receive_skb+0x8d/0xa0
Apr  4 01:07:22 gentoo kernel: [130031.104654]  [<ffffffff816f9ad4>] ? ieee80211_data_to_8023+0x184/0x460
Apr  4 01:07:22 gentoo kernel: [130031.104662]  [<ffffffff8172ff1e>] ? ieee80211_deliver_skb.clone.25+0xde/0x2a0
Apr  4 01:07:22 gentoo kernel: [130031.104671]  [<ffffffff81730ce1>] ? ieee80211_rx_handlers+0xc01/0x1b90
Apr  4 01:07:22 gentoo kernel: [130031.104678]  [<ffffffff810462de>] ? select_task_rq_fair+0x54e/0x9d0
Apr  4 01:07:22 gentoo kernel: [130031.104686]  [<ffffffff810468c2>] ? find_busiest_group+0x162/0xc50
Apr  4 01:07:22 gentoo kernel: [130031.104695]  [<ffffffff8173228e>] ? ieee80211_prepare_and_rx_handle+0x61e/0x8e0
Apr  4 01:07:22 gentoo kernel: [130031.104704]  [<ffffffff8103fbf1>] ? ttwu_do_wakeup+0x11/0x90
Apr  4 01:07:22 gentoo kernel: [130031.104712]  [<ffffffff8173285c>] ? ieee80211_rx+0x30c/0x940
Apr  4 01:07:22 gentoo kernel: [130031.104720]  [<ffffffff814f3656>] ? ath_rx_tasklet+0xcb6/0x1d40
Apr  4 01:07:22 gentoo kernel: [130031.104728]  [<ffffffff81008410>] ? nommu_map_sg+0xd0/0xd0
Apr  4 01:07:22 gentoo kernel: [130031.104736]  [<ffffffff814f06fd>] ? ath9k_tasklet+0xad/0x190
Apr  4 01:07:22 gentoo kernel: [130031.104744]  [<ffffffff81052eea>] ? tasklet_action+0x5a/0xc0
Apr  4 01:07:22 gentoo kernel: [130031.104751]  [<ffffffff81053510>] ? __do_softirq+0x90/0x110
Apr  4 01:07:22 gentoo kernel: [130031.104760]  [<ffffffff8174d72c>] ? call_softirq+0x1c/0x30
Apr  4 01:07:22 gentoo kernel: [130031.104769]  [<ffffffff81003b8d>] ? do_softirq+0x4d/0x80
Apr  4 01:07:22 gentoo kernel: [130031.104775]  [<ffffffff81053865>] ? irq_exit+0x75/0x80
Apr  4 01:07:22 gentoo kernel: [130031.104783]  [<ffffffff810039dc>] ? do_IRQ+0x5c/0xd0
Apr  4 01:07:22 gentoo kernel: [130031.104791]  [<ffffffff8174bc6b>] ? common_interrupt+0x6b/0x6b
Apr  4 01:07:22 gentoo kernel: [130031.104795]  <EOI>  [<ffffffff81009e70>] ? default_idle+0x20/0x40
Apr  4 01:07:22 gentoo kernel: [130031.104809]  [<ffffffff81000a66>] ? cpu_idle+0x66/0x90
Apr  4 01:07:22 gentoo kernel: [130031.104816] ---[ end trace 6229151a66ad661c ]---


Se repite continuamente, incluso varias veces por segundo y por eso no puedo encontrar el trozo que busco.
Alguna idea de a qué se puede deber?? He buscado bastante, pero no he encontrado una respuesta.
Gracias.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 377
Location: LANDETE (Cuenca)

PostPosted: Wed Apr 04, 2012 5:06 pm    Post subject: Reply with quote

Al parecer tienes un chip Atheros y "probablemente" el driver equivocado, da la casualidad que tengo un chip Atheros versión 5 que "probablemente" será igual al tuyo, por consiguiente entra en la compilación del kernel y activa lo siguiente:
Device Drivers -> Network device support -> Wireless LAN -> <M>Atheros Wireless Cards -> <M>Atheros 5xxx wireless cards support
... y desactiva la línea que hace referencia al driver ath9 ... reinicia la máquina después de la compilación y si todo sale como debería asunto resuelto ... digo.
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
eidan
n00b
n00b


Joined: 26 Feb 2012
Posts: 4

PostPosted: Thu Apr 05, 2012 2:55 pm    Post subject: Aun no Reply with quote

Probé cambiar el driver desde el kernel como me dijiste, pero el wifi dejó de funcionar y tuve que volver a la configuración anterior. De todas formas el driver es el que me indicó la salida de lspci -n en http://kmuto.jp/debian/hcl/index.rhtmlx . De todas formas posteo mi lspci -vvv -s:

Code:


01:08.0 Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)
   Subsystem: Atheros Communications Inc. Device 2091
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
   Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 168, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 18
   Region 0: Memory at f7ff0000 (32-bit, non-prefetchable) [size=64K]
   Capabilities: [44] Power Management version 2
      Flags: PMEClk- DSI- D1- D2- AuxCurrent=100mA PME(D0+,D1-,D2-,D3hot+,D3cold-)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Kernel driver in use: ath9k


Gracias por la respuesta de todas formas.
Back to top
View user's profile Send private message
eidan
n00b
n00b


Joined: 26 Feb 2012
Posts: 4

PostPosted: Thu Apr 05, 2012 5:19 pm    Post subject: Parece que al reinstalar el driver dejó de dar error Reply with quote

Pues eso, desde la reinstalación el error ya no sale... Si vuelve a salir te aviso, pero muchas gracias por la ayuda.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum