Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas configurando la variable USE [Solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Sun Feb 12, 2012 11:45 pm    Post subject: Problemas configurando la variable USE [Solucionado] Reply with quote

Despues de estar casi una semana batallando con el kernel y el inicio del sistema ahora tengo este problemilla con las useflags.
Entiendo para que se utiliza dicha variable, pues leei el handbook, pero igual tengo problemas.

Entiendo que son para compilar los paquetes con soporte para X cosa, pero tengo problemas con mi variable.
Yo por ejemplo utilizo Fluxbox como WM, thunar para navegador de archivos y otras cosillas mas ligeras.

Ahora estoy teniendo problemas a la hora de intentar instalar thunar:
Code:
[ebuild  N     ] media-libs/libogg-1.3.0  USE="-static-libs"
[ebuild  N     ] media-sound/alsa-headers-1.0.24
[ebuild  N     ] sys-apps/sdparm-1.06
[ebuild   R    ] sys-apps/pciutils-3.1.7  USE="-zlib*"
[ebuild  N     ] xfce-base/libxfce4util-4.8.2  USE="-debug"
[ebuild  N     ] x11-libs/startup-notification-0.12  USE="-static-libs"
[ebuild  N     ] media-libs/alsa-lib-1.0.24.1  USE="-alisp -debug -doc -python -static-libs" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
[ebuild  N     ] dev-libs/libusb-1.0.9_rc3  USE="-debug -doc -static-libs"
[ebuild  N     ] media-libs/libvorbis-1.3.2  USE="-static-libs"
[ebuild  N     ] dev-libs/libtasn1-2.9-r1  USE="-doc -static-libs"
[ebuild  N     ] dev-libs/libatasmart-0.18  USE="-static-libs"
[ebuild  N     ] media-libs/libexif-0.6.20  USE="nls -doc -static-libs"
[ebuild  N     ] dev-libs/libcdio-0.82  USE="cxx -cddb -minimal -static-libs"
[ebuild  N     ] media-libs/flac-1.2.1-r3  USE="cxx ogg sse -3dnow (-altivec) -debug -static-libs"
[ebuild  N     ] dev-db/sqlite-3.7.7.1  USE="extensions fts3 readline threadsafe -debug -doc -icu -secure-delete -soundex -tcl -test -unlock-notify"
[ebuild  N     ] net-libs/libproxy-0.4.7  USE="-gnome -kde -mono -networkmanager -perl -python -test"
[ebuild  N     ] gnome-base/gnome-common-3.1.0
[ebuild  N     ] app-text/rarian-0.8.1-r1  USE="-static-libs"
[ebuild  N     ] dev-libs/libunique-3.0.2  USE="introspection -debug -doc -test"
[ebuild  N     ] app-text/scrollkeeper-dtd-1.0
[ebuild  NS    ] app-text/docbook-xml-dtd-4.4-r2 [4.1.2-r6]
[ebuild  N     ] sys-block/parted-3.0  USE="debug nls readline -device-mapper (-selinux) -static-libs -test"
[ebuild  N     ] sys-fs/lvm2-2.02.88  USE="lvm1 readline static static-libs (-clvm) (-cman) (-selinux)"
[ebuild  N     ] x11-proto/resourceproto-1.2.0
[ebuild  N     ] virtual/perl-MIME-Base64-3.08
[ebuild  N     ] x11-themes/sound-theme-freedesktop-0.7
[ebuild  N     ] dev-libs/libusb-0.1.12-r7  USE="cxx -debug -doc -static-libs"
[ebuild  N     ] sys-block/eject-2.1.5-r2  USE="nls"
[ebuild  N     ] virtual/libusb-0
[ebuild  N     ] xfce-base/xfconf-4.8.1  USE="-debug -perl"
[ebuild  N     ] media-libs/libsndfile-1.0.25  USE="alsa -minimal -sqlite -static-libs"
[ebuild  N     ] net-libs/gnutls-2.10.5  USE="cxx nls zlib -bindist -doc -examples -guile -lzo -test"
[ebuild  N     ] app-text/gnome-doc-utils-0.20.6
[ebuild  N     ] dev-perl/URI-1.55
[ebuild  N     ] xfce-base/garcon-0.1.9  USE="-debug"
[ebuild  N     ] x11-libs/libXres-1.0.5  USE="-static-libs"
[ebuild  N     ] dev-libs/libIDL-0.8.14  USE="-debug"
[ebuild  N     ] virtual/eject-0
[ebuild  N     ] virtual/libusb-1
[ebuild  N     ] net-wireless/bluez-4.98-r1  USE="alsa consolekit cups usb -caps -debug -gstreamer -pcmcia -test-programs"
[ebuild  N     ] xfce-base/libxfce4ui-4.8.1  USE="startup-notification -debug -glade"
[ebuild  N     ] xfce-base/exo-0.6.2  USE="-debug -python"
[ebuild  N     ] x11-libs/libwnck-2.30.7  USE="introspection startup-notification -doc"
[ebuild  N     ] net-libs/glib-networking-2.30.1-r1  USE="libproxy ssl -gnome"
[ebuild  N     ] gnome-base/orbit-2.14.19-r1  USE="-debug -doc -test"
[ebuild  N     ] sys-apps/usbutils-004  USE="zlib -network-cron -python"
[ebuild  N     ] gnome-base/gconf-2.32.4  USE="introspection ldap policykit -debug -doc"
[ebuild   R    ] sys-fs/udev-171-r5  USE="extras* gudev* hwdb* keymap*"
[ebuild  N     ] xfce-base/xfce4-panel-4.8.6  USE="-debug"
[ebuild  N     ] net-libs/libsoup-2.36.1  USE="introspection ssl -debug -doc -samba -test"
[ebuild  N     ] dev-libs/openobex-1.5  USE="bluetooth usb -debug -irda -syslog"
[ebuild  N     ] app-mobilephone/obex-data-server-0.4.5  USE="gtk usb -debug -imagemagick"
[ebuild  N     ] media-libs/libcanberra-0.28-r5  USE="alsa gtk gtk3 sound udev -gnome -gstreamer -oss -pulseaudio -tdb"
[ebuild  N     ] x11-libs/libnotify-0.7.4  USE="introspection -doc -test"
[ebuild  N     ] x11-misc/notification-daemon-0.5.0
[ebuild  N     ] virtual/notification-daemon-0  USE="-gnome"
[ebuild  N     ] sys-apps/sg3_utils-1.29
[ebuild  N     ] sys-apps/rescan-scsi-bus-1.29
[ebuild  N     ] sys-fs/udisks-1.0.4-r1  USE="nls -debug -doc -remote-access"
[ebuild  N     ] sys-apps/gnome-disk-utility-3.0.2-r200  USE="-avahi -doc -fat -gnome-keyring -nautilus -remote-access"
[ebuild  N     ] gnome-base/gnome-keyring-2.32.1-r1  USE="pam -debug -doc -test"
[ebuild  N     ] gnome-base/libgnome-keyring-2.32.0  USE="-debug -doc -test"
[ebuild  N     ] net-libs/libsoup-gnome-2.36.1  USE="introspection -debug -doc"
[ebuild  N     ] gnome-base/gvfs-1.10.1  USE="bluetooth cdda gdu http udev -afp -archive -avahi -bluray -doc -fuse -gnome-keyring -gphoto2 -ios -samba"
[ebuild  N     ] xfce-base/thunar-1.2.3  USE="dbus exif libnotify pcre startup-notification udev -debug -test" XFCE_PLUGINS="trash"

The following USE changes are necessary to proceed:
#required by sys-fs/udev-171-r5[extras], required by xfce-base/thunar-1.2.3[udev], required by thunar (argument)
=sys-apps/pciutils-3.1.7 -zlib

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).


Y asi con otros paquetes, no entiendo se supone que las use son para compilar los paquetes dandole soporte a algo, por ejemplo a KDE.
Entonces ya no se que hacer para instalar mis paquetes, en la variable use si tengo algunas, pero realmente estoy muy confundido con esto de las variables.

Saludos


Last edited by lince_0011 on Mon Feb 13, 2012 7:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3726

PostPosted: Mon Feb 13, 2012 9:39 am    Post subject: Reply with quote

no veo nada del otro mundo, lo único que te dice es que añadas =sys-apps/pciutils-3.1.7 -zlib a tu /etc/portage/package.use
o tienes otro problema que igual me he pasado por alto ?

saluetes
Back to top
View user's profile Send private message
cameta
l33t
l33t


Joined: 04 Aug 2004
Posts: 690

PostPosted: Mon Feb 13, 2012 10:42 am    Post subject: Reply with quote

Esto mismo me ocurre a mi a veces al actualizar el sistema. Muchas veces te pide que añadas o quites use.
PS
No se si exagero, pero el 90 % de los problemas que se ven en el foro se deben a las USE que faltan o sobran. :wink:
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
lince_0011
n00b
n00b


Joined: 09 Aug 2011
Posts: 68

PostPosted: Mon Feb 13, 2012 7:46 pm    Post subject: Reply with quote

gringo wrote:
no veo nada del otro mundo, lo único que te dice es que añadas =sys-apps/pciutils-3.1.7 -zlib a tu /etc/portage/package.use
o tienes otro problema que igual me he pasado por alto ?

saluetes


Gracias por responder.
El problema no era saber que agregar, el problema era a que archivo agregarlo.

Saludos
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum