Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PHP 5.2.17 php-patchset-5.2.17-r0.tar.bz2 not founf
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
fneudoerfl
n00b
n00b


Joined: 06 Feb 2012
Posts: 3

PostPosted: Mon Feb 06, 2012 4:23 pm    Post subject: PHP 5.2.17 php-patchset-5.2.17-r0.tar.bz2 not founf Reply with quote

emerge failed because the file php-patchset-5.2.17-r0.tar.bz2 is not found on any server!

perhaps somebody has a link for a download so i can put the file in the portage distfiles folder.

i need this for installing php 5.2.17
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8979

PostPosted: Tue Feb 07, 2012 3:04 am    Post subject: Reply with quote

That PHP is very old. Given the general history of security problems in the PHP project, I would be surprised if there are no known vulnerabilities in a version that old. Could you explain why you need to use an old PHP instead of one of the supported versions?
Back to top
View user's profile Send private message
fneudoerfl
n00b
n00b


Joined: 06 Feb 2012
Posts: 3

PostPosted: Tue Feb 07, 2012 9:38 am    Post subject: Reply with quote

The Problem is that dependencies in a very large project not even work with php 5.3 because of structural changes in the language syntax. So I need for some month the old version.
Back to top
View user's profile Send private message
zdvori
n00b
n00b


Joined: 23 Jun 2005
Posts: 3
Location: Czech

PostPosted: Thu Feb 09, 2012 12:12 pm    Post subject: Reply with quote

I uploaded it for you here:
http://compono.cz/php-patchset-5.2.17-r0.tar.bz2
For me, this is also very disturbing. This is the last version that runs on the PHP-GTK, which runs some of our internal applications.
I see no reason why not to keep it in portage.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8979

PostPosted: Fri Feb 10, 2012 3:40 am    Post subject: Reply with quote

It is fairly common to drop old versions of a package when they are not maintained upstream, especially if there are known security issues in the old version. Dropping the old version encourages users to upgrade to a fixed release. According to the php.net website, PHP 5.2.x is no longer supported, so I think that it is not receiving security fixes.
Back to top
View user's profile Send private message
fneudoerfl
n00b
n00b


Joined: 06 Feb 2012
Posts: 3

PostPosted: Fri Feb 10, 2012 12:42 pm    Post subject: Reply with quote

zdvori thank you for the file. This fixed my problem.
Back to top
View user's profile Send private message
trzemo
n00b
n00b


Joined: 02 Oct 2012
Posts: 1

PostPosted: Tue Oct 02, 2012 10:04 am    Post subject: Reply with quote

Can you reupload php-patchset-5.2.17-r0.tar.bz2 ?

I need it.

I will be greatefull.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7974

PostPosted: Sat Oct 06, 2012 4:09 am    Post subject: Reply with quote

Be sure to verify the checksums: http://bbgentoo.ilb.ru/distfiles/php-patchset-5.2.17-r0.tar.bz2
Back to top
View user's profile Send private message
baldpope
n00b
n00b


Joined: 11 Jan 2013
Posts: 1

PostPosted: Fri Jan 11, 2013 5:18 pm    Post subject: similar need, different file Reply with quote

Sorry to resurrect an older thread, but we are trying to recover an old application and the current version of php 5.3 does not work for us, a deprecated function...

After some reading, I believe I need the patchset for 5.3.2..

php-patchset-5.3.2-r0.tar.bz2

I have the ebuild file for 5.3.2 and I think I'm only missing the patchset. Any help would be greatly appreciated

-bp
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum