Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How do I get hold of an old ebuild? swig-1.3.38
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Isomorph
n00b
n00b


Joined: 22 Sep 2002
Posts: 50
Location: Denmark

PostPosted: Sun Feb 05, 2012 3:40 pm    Post subject: How do I get hold of an old ebuild? swig-1.3.38 Reply with quote

How do I get hold of an old ebuild ?

I need swig-1.3.36 in order to compile wxRuby, but the oldest in portage is 1.3.40.

Is there anywhere I can find old ebuilds that have been removed from portage, so that I can install it locally?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5617

PostPosted: Sun Feb 05, 2012 4:11 pm    Post subject: Reply with quote

Why do you think you need swig 1.3.36 ?
Back to top
View user's profile Send private message
Isomorph
n00b
n00b


Joined: 22 Sep 2002
Posts: 50
Location: Denmark

PostPosted: Sun Feb 05, 2012 4:52 pm    Post subject: Reply with quote

VoidMage wrote:
Why do you think you need swig 1.3.36 ?

wxruby can maximum use version 1.3.38, because it says so. So I need a older version of swig.
Code:

cybert ~ # cat /var/tmp/portage/dev-ruby/wxruby-2.0.1/temp/build.log
 * Package:    dev-ruby/wxruby-2.0.1
 * Repository: x-portage
 * USE:        doc elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking wxruby-2.0.1.tar.gz to /var/tmp/portage/dev-ruby/wxruby-2.0.1/work
>>> Source unpacked in /var/tmp/portage/dev-ruby/wxruby-2.0.1/work
>>> Compiling source in /var/tmp/portage/dev-ruby/wxruby-2.0.1/work/wxruby-2.0.1 ...
(in /var/tmp/portage/dev-ruby/wxruby-2.0.1/work/wxruby-2.0.1)
Enabling DYNAMIC build
Enabling RELEASE build
Enabling UNICODE build
The following wxWidgets features are not available and will be skipped:
  PrinterDC
rake aborted!
SWIG version 2.0.4 is installed, maximum version permitted is 1.3.38

(See full trace by running task with --trace)
 * ERROR: dev-ruby/wxruby-2.0.1 failed (compile phase):
 *   rake compile failed
 *
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2369:  Called die
 * The specific snippet of code:
 *       rake compile || die "rake compile failed"
 *
 * If you need support, post the output of 'emerge --info =dev-ruby/wxruby-2.0.1',
 * the complete build log and the output of 'emerge -pqv =dev-ruby/wxruby-2.0.1'.
 * This ebuild is from an overlay named 'x-portage': '/usr/local/portage/'
 * The complete build log is located at '/var/tmp/portage/dev-ruby/wxruby-2.0.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/wxruby-2.0.1/temp/environment'.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9049

PostPosted: Sun Feb 05, 2012 6:26 pm    Post subject: Reply with quote

That is an artificial failure forced by the wxRuby build system. It may work with newer versions if the check is bypassed. I see that you are using an overlay to obtain wxRuby. Are there newer versions available? They may have already fixed their support for newer SWIG.
Back to top
View user's profile Send private message
Isomorph
n00b
n00b


Joined: 22 Sep 2002
Posts: 50
Location: Denmark

PostPosted: Sun Feb 05, 2012 6:55 pm    Post subject: Reply with quote

Hu wrote:
That is an artificial failure forced by the wxRuby build system. It may work with newer versions if the check is bypassed. I see that you are using an overlay to obtain wxRuby. Are there newer versions available? They may have already fixed their support for newer SWIG.


The ebuild for wxruby it a modification of a old one I had in my /usr/local/portage directory.
I made a modification in order to update to the latest version 2.0.1

Here is the new ebuild.

Code:

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit ruby gems eutils

DESCRIPTION="ruby bindings for wxwidgets"
HOMEPAGE="http://wxruby.rubyforge.org/wiki/wiki.pl"
SRC_URI="http://rubyforge.org/frs/download.php/63379/${P}.tar.gz"

LICENSE="wxWinLL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND=">=dev-lang/ruby-1.8
   >=x11-libs/wxGTK-2.8.7
   >=dev-lang/swig-2.0.1
   dev-ruby/rake
   >=dev-ruby/rubygems-0.9.4"

# Overriding the src_unpack() from gems
src_unpack() {
   if [ "${A}" != "" ]; then
      unpack ${A}
   fi
}


src_compile() {
   rake compile || die "rake compile failed"
}

src_install() {
   # Have to use rake gem instead of rake install because the rake file
   # doesn't respect destdir settings.
   rake gem

   if  use amd64; then
      export GEM_SRC="${S}/${P}-x86_64-linux.gem"
   elif use x86; then
      export GEM_SRC="${S}/${P}-x86-linux.gem"
   fi
   
   gems_src_install || die "Gem install failed"
}
Back to top
View user's profile Send private message
Isomorph
n00b
n00b


Joined: 22 Sep 2002
Posts: 50
Location: Denmark

PostPosted: Mon Feb 06, 2012 1:06 am    Post subject: Reply with quote

Panagiotis Christopoulos send me this link. So I will look on the ebuilds tomorrow.

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-lang/swig/?hideattic=0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum