Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Circular Dependencies at End of Install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jagdpanther
Apprentice
Apprentice


Joined: 22 Nov 2003
Posts: 230

PostPosted: Tue Jan 31, 2012 11:02 pm    Post subject: [solved] Circular Dependencies at End of Install Reply with quote

Circular dependencies after install and emerge trying to install old Python:

After installing Gentoo on a new Dell using the instructions in http://www.gentoo.org/doc/en/gentoo-x86-quickinstall.xml, I ran 'emerge --sync' and then tried :
emerge --update --deep --newuse world -p and received
Code:
Calculating dependencies... done!


[nomerge       ] virtual/dev-manager-0
[nomerge       ]  sys-fs/udev-171-r5  USE="acl extras* rule_generator -action_modeswitch -build -debug -edd -floppy -gudev -hwdb -introspection -keymap (-selinux) -test"
[nomerge       ]   dev-libs/gobject-introspection-1.30.0-r2  USE="-doc -test"
[nomerge       ]    dev-lang/python-2.7.2-r3  USE="gdbm* ipv6* ncurses* readline* ssl* threads* tk* (wide-unicode) xml* -berkdb -build* -doc -examples -sqlite -wininst"
[nomerge       ]     dev-lang/tk-8.5.9-r1  USE="(-aqua) -debug -threads -truetype -xscreensaver"
[nomerge       ]      x11-libs/libX11-1.4.4  USE="ipv6 -doc -static-libs -test"
[ebuild  N     ]       x11-libs/libxcb-1.7  USE="-doc (-selinux) -static-libs" 0 kB
[nomerge       ] sys-apps/portage-2.1.10.44  USE="(ipc) -build -doc -epydoc -python2 -python3 (-selinux)" LINGUAS="-pl"
[ebuild   R    ]  dev-lang/python-3.1.4-r3  USE="gdbm ipv6 ncurses readline ssl threads tk* (wide-unicode) xml -build -doc -examples -sqlite -wininst" 0 kB
[nomerge       ] x11-libs/libxcb-1.7  USE="-doc (-selinux) -static-libs"
[ebuild   R    ]  dev-lang/python-2.7.2-r3  USE="gdbm* ipv6* ncurses* readline* ssl* threads* tk* (wide-unicode) xml* -berkdb -build* -doc -examples -sqlite -wininst" 0 kB
[ebuild  N     ]   dev-tcltk/blt-2.4z-r10  USE="-X -jpeg -static-libs" 0 kB
[ebuild  N     ]    dev-lang/tk-8.5.9-r1  USE="(-aqua) -debug -threads -truetype -xscreensaver" 0 kB
[ebuild  N     ]     x11-libs/libXt-1.1.1  USE="-static-libs" 0 kB
[nomerge       ] sys-apps/shadow-4.1.4.3  USE="cracklib nls pam -audit (-selinux) -skey"
[ebuild     U  ]  sys-auth/pambase-20101024-r2 [20101024] USE="consolekit* cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild  N     ]   sys-auth/consolekit-0.4.5-r1  USE="pam -debug -doc -policykit -test" 0 kB
[ebuild  N     ]    x11-libs/libX11-1.4.4  USE="ipv6 -doc -static-libs -test" 0 kB

Total: 9 packages (1 upgrade, 6 new, 2 reinstalls), Size of downloads: 0 kB

 * Error: circular dependencies:

(dev-lang/python-2.7.2-r3::gentoo, ebuild scheduled for merge) depends on
 (dev-lang/tk-8.5.9-r1::gentoo, ebuild scheduled for merge) (buildtime)
  (x11-libs/libX11-1.4.4::gentoo, ebuild scheduled for merge) (buildtime)
   (x11-libs/libxcb-1.7::gentoo, ebuild scheduled for merge) (buildtime)
    (dev-lang/python-2.7.2-r3::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying any of the following changes:
- dev-lang/python-2.7.2-r3 (Change USE: -tk)
- dev-lang/python-2.7.2-r3 (Change USE: +build)

Note that this change can be reverted, once the package has been installed.


I haven't added much: cat /var/lib/portage/world
Code:
app-admin/syslog-ng
app-portage/eix
sys-apps/portage
sys-boot/grub
sys-kernel/vanilla-sources
sys-process/vixie-cron


My use flags: USE="mmx sse sse2"

and emerge --info:
Code:
Portage 2.1.10.44 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.1.10-rr01 x86_64)
=================================================================
System uname: Linux-3.1.10-rr01-x86_64-Intel-R-_Xeon-R-_CPU_W3690_@_3.47GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 31 Jan 2012 21:45:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.2
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo ftp://gentoo.chem.wisc.edu/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j13"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=100"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre pppd readline session sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


Any idea how I messed up? I have never had this type of problem with Gentoo installs before.
This install is based on stage3-amd64-20120126.tar.bz2

Also look at what happens when trying to emerge gentoolkit:

Code:
emerge gentoolkit -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-misc/realpath-1.16  USE="nls"
[ebuild  N     ] dev-python/setuptools-0.6.21
[ebuild  N     ] dev-python/argparse-1.2.1
[ebuild  N     ] app-portage/gentoolkit-0.3.0.4-r5
[uninstall     ] dev-lang/python-2.7.2-r3
[blocks b      ] >=dev-lang/python-2.6[-xml] (">=dev-lang/python-2.6[-xml]" is blocking app-portage/gentoolkit-0.3.0.4-r5)


Last edited by jagdpanther on Wed Feb 01, 2012 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Tue Jan 31, 2012 11:12 pm    Post subject: Reply with quote

You can temporarily disable the "tk" flag as emerge suggests.
The gentoolkit emerge shows no error, blocks with small b (as opposed to capital B) are autoresolved by portage.
Back to top
View user's profile Send private message
jagdpanther
Apprentice
Apprentice


Joined: 22 Nov 2003
Posts: 230

PostPosted: Wed Feb 01, 2012 4:07 pm    Post subject: Reply with quote

Thanks. New system built.

I added: "=dev-lang/python-2.7.2-r3 -tk" to /etc/portage/package.use

then

emerge system
emerge world
emerge --update --deep --newuse world

then removed "=dev-lang/python-2.7.2-r3 -tk" from /etc/portage/package.use

emerge --update --deep --newuse world
recompiled python with tk flag

Then I replaced /var/lib/portage/world with the world file from my old Gentoo system and am in the middle of a 733 package ermerge.

Thanks again for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum